Bug 142353 - Euro sign is not displayed (space instead) in a received mail
Summary: Euro sign is not displayed (space instead) in a received mail
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: messageviewer (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-01 09:22 UTC by Hauke Laging
Modified: 2007-03-04 13:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hauke Laging 2007-03-01 09:22:08 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    SuSE RPMs

I just received a
Content-Type: text/plain;
  charset="iso-8859-15"
e-mail which contains the string "2€-Stück" in its body. The Euro sign is replaced by a space in the normal kmail window. The same happens when opening a seperate window by double click. The sign is correctly displayed when opening the source window (by pressing "v") and when replying.
Comment 1 Thomas McGuire 2007-03-01 19:06:48 UTC
Have you set the correct encoding via "View->Set Encoding"?
Comment 2 Hauke Laging 2007-03-01 19:17:07 UTC
The setting was "automatic". I just tried iso-8859-15 - no change.

I admit that I don't know where the problem is. The message could be wrong so that the space is OK. But why does the sign occur then when replying or viewing the source? Thus not very probable.
Comment 3 Thomas McGuire 2007-03-01 19:22:06 UTC
Maybe the message is lying about its encoding? Did you try UTF-8?
Otherwise, I have no idea.
Comment 4 Ingo Klöcker 2007-03-03 22:31:06 UTC
Which font are you using for displaying the message text? Maybe this font doesn't contain the glyph of the Euro symbol. Since the message composer and the message source viewer use different fonts this would explain why the Euro is only missing in the message viewer.

In the font configuration screen you can edit the "The Quick Brown Fox [...]" text. So if you enter a Euro symbol you can easily see whether the font includes a glyph for the Euro symbol.
Comment 5 Hauke Laging 2007-03-04 00:05:43 UTC
I have found the problem. I was "kind of related" to the font but not the font itself. A long time ago I activated the option "view -> fixed width" (don't know the correct English term for it) which is toggled by pressing "x". It doesn't work here as expected anyway and additionally it replaces the € by a space...
Comment 6 Ingo Klöcker 2007-03-04 13:45:24 UTC
Okay, then it's probably the font you've configured as "Fixed width font". Maybe you've configured some font which isn't available anymore (due to an update of your distribution). For me toggling between fixed width and normal font works and the € is shown with both fonts.

I'll close this report as WORKSFORME.