Bug 141871 - kopete crashed - reason unknown - backtrace included
Summary: kopete crashed - reason unknown - backtrace included
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: IRC Plugin (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-18 17:25 UTC by Elias Probst
Modified: 2008-11-29 23:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2007-02-18 17:25:00 UTC
Version:           0.12.4 (using KDE KDE 3.5.6)
Installed from:    Gentoo Packages
Compiler:          gcc-Version 4.1.1 (Gentoo 4.1.1-r3) CFLAGS="-ggdb -O2 -march=nocona -msse3 -pipe -fomit-frame-pointer -fvar-tracking"
OS:                Linux

Kopete crashed while it was in background.
Accounts which were online:
IRC (2 channels open)
ICQ (1 account)
Jabber (2 accounts)

Hope the backtrace helps:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1241368912 (LWP 3982)]
[KCrash handler]
#9  0x00000029 in ?? ()
#10 0xb5630b71 in IRCUserContact::updateStatus (this=0x83786f0)
    at ircusercontact.cpp:141
#11 0xb560ce98 in IRCAccount::engineStatusChanged (this=0x8332b68, 
    newStatus=KIRC::Engine::Disconnected) at ircaccount.cpp:512
#12 0xb560f3fc in IRCAccount::qt_invoke (this=0x8332b68, _id=41, 
    _o=0xbff42cf4) at ircaccount.moc:249
#13 0xb68dce74 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#14 0xb564a517 in KIRC::Engine::statusChanged (this=0x8332d40, 
    t0=KIRC::Engine::Disconnected) at kircengine.moc:1301
#15 0xb564a560 in KIRC::Engine::setStatus (this=0x8332d40, status=135306464)
    at kircengine.cpp:145
#16 0xb564a65b in KIRC::Engine::slotConnectionClosed (this=0x8332d40)
    at kircengine.cpp:219
#17 0xb56511d1 in KIRC::Engine::qt_invoke (this=0x8332d40, _id=68, 
    _o=0xbff42f14) at kircengine.moc:2031
#18 0xb68dcf0e in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#19 0xb68dd962 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#20 0xb6f9f39c in KBufferedIO::closed (this=0x839a090, t0=0)
    at kbufferedio.moc:96
#21 0xb6f9958a in KExtendedSocket::close (this=0x839a090) at kextsock.cpp:1289
#22 0xb564a594 in KIRC::Engine::setStatus (this=0x8332d40, 
    status=KIRC::Engine::Closing) at kircengine.cpp:170
#23 0xb56524dc in KIRC::Engine::quit (this=0x8332d40, reason=@0xbff42fec)
    at kircengine_commands.cpp:204
#24 0xb560f907 in ~IRCAccount (this=0x8332b68) at ircaccount.cpp:219
#25 0xb7ea0dca in ~Protocol (this=0x837c738) at kopeteprotocol.cpp:73
#26 0xb562130f in ~IRCProtocol (this=0x837c738) at ircprotocol.cpp:314
#27 0xb7eab7b8 in ~PluginManager (this=0x8272a70)
    at kopetepluginmanager.cpp:116
#28 0xb7ea8acd in __tcf_0 () at /usr/kde/3.5/include/kstaticdeleter.h:126
#29 0xb616229c in __cxa_finalize () from /lib/libc.so.6
#30 0xb7e95a7b in __do_global_dtors_aux ()
   from /usr/kde/3.5/lib/libkopete.so.1
#31 0xb7f1d958 in _fini () from /usr/kde/3.5/lib/libkopete.so.1
#32 0xb7f7af48 in _dl_fini () from /lib/ld-linux.so.2
#33 0xb6161fdf in exit () from /lib/libc.so.6
#34 0xb6815bf8 in ?? () from /usr/qt/3/lib/libqt-mt.so.3
#35 0x00000001 in ?? ()
#36 0x0810b760 in ?? ()
#37 0x0811ba70 in ?? ()
#38 0xb6edef3e in KApplication::shutDown (this=0x811ba70)
    at kapplication.moc:234
#39 0xb6edfb5b in KApplication::xioErrhandler (this=0xb6d11610, dpy=0x811ba70)
    at kapplication.cpp:728
#40 0xb6edfb86 in kde_xio_errhandler (dpy=0x811ba70) at kapplication.cpp:179
#41 0xb63ac07b in _XIOError () from /usr/lib/libX11.so.6
#42 0xb63ac056 in _XIOError () from /usr/lib/libX11.so.6
#43 0xb63acfb4 in _XRead () from /usr/lib/libX11.so.6
#44 0xbff433a8 in ?? ()
#45 0xb61e8201 in poll () from /lib/libc.so.6
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Comment 1 Elias Probst 2007-02-18 19:20:42 UTC
The same just happened again after (~20-30 seconds) I switched to away state on IRC (msg was: "/away Döner").
Maybe the umlaut used caused trouble?
Comment 2 Lubos Lunak 2008-07-21 16:22:45 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 3 Elias Probst 2008-11-29 23:30:51 UTC
It seems this was fixed!