Bug 141768 - kmail recursive search crash
Summary: kmail recursive search crash
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: search (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash with 10 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-16 02:02 UTC by Richard Lynch
Modified: 2010-01-03 12:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Lynch 2007-02-16 02:02:03 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages
Compiler:          gcc 4.1.1 Gentoo packaged
OS:                Linux

Searching (using the popup dialog, not just the box on the main window) for "From" "contains" "manager@complaints.com" crashes the search, right after it begins (or possibly finishes?) populating the search results pane.

Backtrace is pased below.

If you need me to re-compile something with debugging "on" to get a more detailed backtrace in threading section (see backtrace) I'll give it my best shot...  I'm on Gentoo with packages, though, so this could take me awhile...

I don't think my boss will let me just hand you 17000 emails that form his core business, though, so if we need access to that, we'll probably have to arrange an NDA or something.  Sorry.

Some possible RED HERRINGS:
RED HERRING #1.
It's a fairly large sub-folder structure of machine-processed emails.
~17,000 emails from 2005, 2006, 2007 are procesed and moved from "Inbox" to boxes like:
processed.2006.07.13
(for a July 13th email)

RED HERRING #2.
The emails were imported from Outlook export .pst, through libpst (aka readpst) into mbox format, and then finally into KMail.
Some of these emails are so messed up by Outlook, as they were forwarded internally, and don't have real email addresses or Message_ID.
The From looks like this:
"manager@complaints.com" <EX:/O=COMMENTS/OU=CIMAIN/CN=RECIPIENTS/CN=MANAGER.COMPLAINTS>
I was trying to find such emails, so that I can do something reasonable to reconstruct valid data out of them, so ALL the results would have been this funky not valid email format.

I've ended up just writing a PHP script to hack through the IMAP stucture and find the bad emails...

BACKTRACE:
(looks like some kind of threading issue to me... [shudder])

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1248322896 (LWP 24213)]
[New Thread -1274631264 (LWP 24217)]
[New Thread -1266238560 (LWP 24216)]
[New Thread -1257845856 (LWP 24215)]
[New Thread -1249453152 (LWP 24214)]
[KCrash handler]
#6  0xb7c1fee9 in KMFolder::open () from /usr/kde/3.5/lib/libkmailprivate.so
#7  0xb7d99be5 in KMFolderSearch::addSerNum ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#8  0xb7d9a47f in KMFolderSearch::qt_invoke ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#9  0xb60fc4b9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#10 0xb7d96c7e in KMSearch::found () from /usr/kde/3.5/lib/libkmailprivate.so
#11 0xb7d9a6af in KMSearch::slotSearchFolderResult ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#12 0xb7d9aad2 in KMSearch::qt_invoke ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#13 0xb60fc4b9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#14 0xb7c3f833 in FolderStorage::searchResult ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#15 0xb7cc6cd5 in KMFolderImap::slotSearchDone ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#16 0xb7cd4d98 in KMFolderImap::qt_invoke ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#17 0xb60fc4b9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#18 0xb7e0b8fd in KMail::SearchJob::searchDone ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#19 0xb7e0c8bf in KMail::SearchJob::slotSearchFolder ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#20 0xb7e0d1de in KMail::SearchJob::qt_invoke ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#21 0xb60fc420 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb7cc7025 in KMFolderImap::folderComplete ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#23 0xb7cc7171 in KMFolderImap::finishMailCheck ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#24 0xb7cd4af1 in KMFolderImap::slotListFolderResult ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#25 0xb7cd4ef5 in KMFolderImap::qt_invoke ()
   from /usr/kde/3.5/lib/libkmailprivate.so
#26 0xb60fc4b9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#27 0xb6c9ba9e in KIO::Job::result () from /usr/kde/3.5/lib/libkio.so.4
#28 0xb6ca3efc in KIO::Job::emitResult () from /usr/kde/3.5/lib/libkio.so.4
#29 0xb6ca758e in KIO::SimpleJob::slotFinished ()
   from /usr/kde/3.5/lib/libkio.so.4
#30 0xb6ca791d in KIO::ListJob::slotFinished ()
   from /usr/kde/3.5/lib/libkio.so.4
#31 0xb6cacece in KIO::ListJob::qt_invoke () from /usr/kde/3.5/lib/libkio.so.4
#32 0xb60fc4b9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#33 0xb60fd10d in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#34 0xb6c8bf5c in KIO::SlaveInterface::finished ()
   from /usr/kde/3.5/lib/libkio.so.4
#35 0xb6c8e676 in KIO::SlaveInterface::dispatch ()
   from /usr/kde/3.5/lib/libkio.so.4
#36 0xb6c8ce48 in KIO::SlaveInterface::dispatch ()
   from /usr/kde/3.5/lib/libkio.so.4
#37 0xb6c89aeb in KIO::Slave::gotInput () from /usr/kde/3.5/lib/libkio.so.4
#38 0xb6c89ca0 in KIO::Slave::qt_invoke () from /usr/kde/3.5/lib/libkio.so.4
#39 0xb60fc4b9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#40 0xb60fd002 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#41 0xb6435e10 in QSocketNotifier::activated ()
   from /usr/qt/3/lib/libqt-mt.so.3
#42 0xb611a5b0 in QSocketNotifier::event () from /usr/qt/3/lib/libqt-mt.so.3
#43 0xb609d3d7 in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#44 0xb609df91 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#45 0xb66eb5be in KApplication::notify () from /usr/kde/3.5/lib/libkdecore.so.4
#46 0xb6092041 in QEventLoop::activateSocketNotifiers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#47 0xb604d76e in QEventLoop::processEvents () from /usr/qt/3/lib/libqt-mt.so.3
#48 0xb60b3f01 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#49 0xb60b3d86 in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#50 0xb609ce5f in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#51 0x0804a444 in ?? ()
#52 0xbfaa92e4 in ?? ()
#53 0xbfaa94d0 in ?? ()
#54 0x00000000 in ?? ()
Comment 1 Richard Lynch 2007-02-16 02:05:30 UTC
I could have sworn I picked 3.5.5 in the popup on the KDE version (which is also the KMail version)...

It's KDE/KMail 3.5.5
Comment 2 brazzmonkey 2007-06-01 09:40:38 UTC
I do encounter similar bug on kubuntu feisty (kde updated to 3.5.7). my debug output seems slightly different, though.

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1242769712 (LWP 11019)]
[New Thread -1282864240 (LWP 11023)]
[New Thread -1274471536 (LWP 11022)]
[New Thread -1266078832 (LWP 11021)]
[New Thread -1257686128 (LWP 11020)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb52f557a in KMMessage::asDwString () from /usr/lib/libkmailprivate.so
#7  0xb5313d55 in KMMessage::asString () from /usr/lib/libkmailprivate.so
#8  0xb556bbcd in KMSearchRuleString::matches ()
   from /usr/lib/libkmailprivate.so
#9  0xb530c1ae in KMSearchPattern::matches () from /usr/lib/libkmailprivate.so
#10 0xb548a70a in KMSearchPattern::matches () from /usr/lib/libkmailprivate.so
#11 0xb548ab53 in FolderStorage::slotProcessNextSearchBatch ()
   from /usr/lib/libkmailprivate.so
#12 0xb548aef1 in FolderStorage::search () from /usr/lib/libkmailprivate.so
#13 0xb53ada36 in KMSearch::slotProcessNextBatch ()
   from /usr/lib/libkmailprivate.so
#14 0xb53adb0b in KMSearch::qt_invoke () from /usr/lib/libkmailprivate.so
#15 0xb6fce88b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#16 0xb6fcf330 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb735cba6 in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#18 0xb6ff6596 in QTimer::event () from /usr/lib/libqt-mt.so.3
#19 0xb6f65a60 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#20 0xb6f6788f in QApplication::notify () from /usr/lib/libqt-mt.so.3
#21 0xb76a1c32 in KApplication::notify () from /usr/lib/libkdecore.so.4
#22 0xb6ef81e9 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#23 0xb6f584ab in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#24 0xb6f0cd25 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#25 0xb6f80136 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#26 0xb6f7ff46 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#27 0xb6f67609 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#28 0x08061e25 in ?? ()
#29 0xbf94a30c in ?? ()
#30 0x00000001 in ?? ()
#31 0x00000001 in ?? ()
#32 0x00000000 in ?? ()
Comment 3 Thomas McGuire 2007-06-09 14:49:00 UTC
The crash in comment #2 is the one in bug 127188.
Comment 4 Björn Ruberg 2010-01-03 12:51:12 UTC
Cannot reproduce in KDE 4.3. Can you?