Bug 141250 - Configure dialog size bigger than most laptop resolutions
Summary: Configure dialog size bigger than most laptop resolutions
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.5
Platform: Fedora RPMs Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 141858 143466 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-02-06 01:48 UTC by Andy
Modified: 2007-03-25 22:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Said overly large window (194.56 KB, image/png)
2007-03-07 17:28 UTC, Charlie Dyson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2007-02-06 01:48:30 UTC
Version:           1.4.5 (using KDE KDE 3.5.6)
Installed from:    0Fedora RPMs
OS:                Linux

The default configure menu window size is bigger than 1280x800, a very common wide screen laptop resolution.  The bottom menu buttons are out of reach.
Comment 1 Mark Kretschmann 2007-02-18 12:21:35 UTC
*** Bug 141858 has been marked as a duplicate of this bug. ***
Comment 2 Charlie Dyson 2007-03-07 17:28:39 UTC
Created attachment 19904 [details]
Said overly large window

1024x768 resolution
Comment 3 Mark Kretschmann 2007-03-22 09:46:55 UTC
SVN commit 645294 by markey:

Make the settings dialog less tall. It's an evil hack - we simple resize it 70px less tall before showing. I hope it has no side effects (e.g. truncated content with big fonts), but I can't figure out a proper fix.

BUG: 141250


 M  +3 -1      Options1.ui  
 M  +4 -1      Options8.ui  
 M  +5 -0      configdialog.cpp  


--- branches/stable/extragear/multimedia/amarok/src/Options1.ui #645293:645294
@@ -9,7 +9,7 @@
             <x>0</x>
             <y>0</y>
             <width>425</width>
-            <height>686</height>
+            <height>540</height>
         </rect>
     </property>
     <property name="sizePolicy">
@@ -650,6 +650,8 @@
         </spacer>
     </vbox>
 </widget>
+<customwidgets>
+</customwidgets>
 <connections>
     <connection>
         <sender>kcfg_ShowTrayIcon</sender>
--- branches/stable/extragear/multimedia/amarok/src/Options8.ui #645293:645294
@@ -9,7 +9,7 @@
             <x>0</x>
             <y>0</y>
             <width>425</width>
-            <height>557</height>
+            <height>418</height>
         </rect>
     </property>
     <property name="minimumSize">
@@ -293,6 +293,9 @@
 <layoutdefaults spacing="6" margin="11"/>
 <includehints>
     <includehint>kactivelabel.h</includehint>
+    <includehint>kactivelabel.h</includehint>
     <includehint>klineedit.h</includehint>
+    <includehint>klineedit.h</includehint>
+    <includehint>kactivelabel.h</includehint>
 </includehints>
 </UI>
--- branches/stable/extragear/multimedia/amarok/src/configdialog.cpp #645293:645294
@@ -206,6 +206,11 @@
     connect( m_opt7->dbSetupFrame->databaseEngine, SIGNAL( activated( int ) ), SLOT( updateButtons() ) );
     connect( m_opt1->kComboBox_browser, SIGNAL( activated( int ) ), SLOT( updateButtons() ) );
     connect( m_opt1->kLineEdit_customBrowser, SIGNAL( textChanged( const QString& ) ), SLOT( updateButtons() ) );
+
+    //HACK The dialog always comes up too tall.. is there a proper fix?
+    QSize size = minimumSizeHint();
+    size.setHeight( size.height() - 70 );
+    resize( size );
 }
 
 AmarokConfigDialog::~AmarokConfigDialog()
Comment 4 Mark Kretschmann 2007-03-25 22:30:46 UTC
*** Bug 143466 has been marked as a duplicate of this bug. ***