Bug 139162 - crash when clicking on .tar.gz package
Summary: crash when clicking on .tar.gz package
Status: RESOLVED UNMAINTAINED
Alias: None
Product: ark
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-23 11:33 UTC by Norbert
Modified: 2009-04-08 03:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert 2006-12-23 11:33:23 UTC
Version:           2.6.4 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1232234176 (LWP 28433)]
[New Thread -1237361760 (LWP 28735)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb691201e in __lll_mutex_lock_wait ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb690e68b in _L_mutex_lock_238 () from /lib/tls/i686/cmov/libpthread.so.0
#3  0xb7dec120 in __after_morecore_hook () from /lib/tls/i686/cmov/libc.so.6
#4  0x08168e28 in ?? ()
#5  0x08158dd8 in ?? ()
#6  0xb772ff48 in ?? () from /usr/lib/libqt-mt.so.3
#7  0xbfe42b48 in ?? ()
#8  0xb7f6cff4 in ?? () from /lib/ld-linux.so.2
#9  0xb7f6d2e0 in _rtld_global () from /lib/ld-linux.so.2
#10 0x080c62b8 in ?? ()
#11 0xbfe42ba8 in ?? ()
#12 0xb7f6030e in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
#13 0xb7f6030e in _dl_rtld_di_serinfo () from /lib/ld-linux.so.2
#14 0xb7ce7299 in exit () from /lib/tls/i686/cmov/libc.so.6
#15 0xb7185142 in QApplication::x11_initialize_style ()
   from /usr/lib/libqt-mt.so.3
#16 0xb780e9cd in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#17 0xb780ea19 in KApplication::xioErrhandler () from /usr/lib/libkdecore.so.4
#18 0xb6ed4f4d in _XIOError () from /usr/lib/libX11.so.6
#19 0xb6ed6817 in _XSend () from /usr/lib/libX11.so.6
#20 0xb6ed77b0 in _XEventsQueued () from /usr/lib/libX11.so.6
#21 0xb6ec3262 in XPending () from /usr/lib/libX11.so.6
#22 0xb71a5360 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#23 0xb721925e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#24 0xb721906e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#25 0xb7200731 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#26 0xb675249f in kdemain () from /usr/lib/libkdeinit_ark.so
#27 0xb676d524 in kdeinitmain () from /usr/lib/kde3/ark.so
#28 0x0804e4df in ?? ()
#29 0x00000004 in ?? ()
#30 0x080baa08 in ?? ()
#31 0x00000001 in ?? ()
#32 0x00000000 in ?? ()
Comment 1 Lubos Lunak 2008-07-21 16:22:50 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 2 Raphael Kubo da Costa 2009-04-05 04:27:14 UTC
Does this crash still happen to you?
Comment 3 Raphael Kubo da Costa 2009-04-08 03:06:55 UTC
Marking as UNMAINTAINED -- no answer to the confirmation request and could not reproduce it in KDE4.