Bug 139130 - Anti-alias doesn't seem to work on rotated text.
Summary: Anti-alias doesn't seem to work on rotated text.
Status: RESOLVED NOT A BUG
Alias: None
Product: kword
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Other
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-22 16:35 UTC by david
Modified: 2007-01-10 16:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description david 2006-12-22 16:35:52 UTC
Version:           2 pre alpha (using KDE Devel)
Installed from:    Compiled sources
OS:                I Don't Know

As I can see from the screenshots from Zander's blog (see url below), once you rotate a text, the police looks realy ugly. this is perhaps not the case on real screan, but the "normal" text looks clean.

As I think I understood flake ( but here I may be wrong ) : the flake shape renders a text and then tools alow to modify this shape whithout the shape knowing it's beeing transformed. 
So : is the text is correctly rendered inside the shape and the, once rotated, the text flake doesn't know it has to re-make the anti-alias for a rotated or zoomed thing ?

I place it as Hy priority because it seems quite anoying and may ask to rethink a big part of KOlibs. But I'm not a dev, so I hope I am wrong.

URLs to the Images : 
http://members.home.nl/zander/images/200612-Text%20runaround.png
http://members.home.nl/zander/images/200612-shapeSelector.png
http://members.home.nl/zander/images/200612-kword.png
Comment 1 Thomas Zander 2006-12-31 14:27:53 UTC
Hi,

thanks for noticing.
Actually, it is my fault. I have been taking screenshots showing technical features without much regard of which font I used. And I ended up using a pretty bad font which indeed makes the screenshots look bad.

I updated the text-runaround image using Futura (a postscript type-2 font) which already looks a lot better.
To compare;
old: http://members.home.nl/zander/images/200612-Text%20runaround-old.png
new: http://members.home.nl/zander/images/200612-Text%20runaround.png 

Luckely its not a problem in the code, its that the free fonts just need more work.
Comment 2 Kurt Pfeifle 2007-01-10 16:59:59 UTC
Sorry, 

I fail to see how the new screenshot shows better font rendering. It's just a different font, but the rendering is *just* *as* *bad*.

Please notice the jittering "base line" in the string "Ut wisi enim" in the left skewed box. Notice the weird character distances in the very first headline word "Yeah".

Granted, font rendering may not be an affair of KWord2 at all, and may be "outsourced" to an external helper application/library (I dunno anything about programming). Granted, you may again have selected just a bad font to make the screenshot from, or uploaded the wrong one....

But fact is, you *haven't* convinced me that this the new screenshot you've linked to is so much better as regards to the font. And fact is that I can convince *any* stranger to my opinion by just pointing to the respective spots in the screenshots.

The text re-flowing and re-shaping features of Flake are very impressive, though! :-)

Cheers,
Kurt  [still waiting for the Pizza service phone number :-)  ]