Bug 139024 - camera GUI new items selection doesn't work
Summary: camera GUI new items selection doesn't work
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Gphoto2 (show other bugs)
Version: 0.9.0
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 139333 140715 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-12-19 21:10 UTC by David Agnese
Modified: 2017-08-16 06:13 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.9.1


Attachments
compdig (3.52 KB, application/x-shellscript)
2007-02-20 20:52 UTC, Gerhard Kulzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Agnese 2006-12-19 21:10:10 UTC
Version:           0.9.0 (using KDE KDE 3.5.4)
Installed from:    Compiled From Sources
Compiler:          gcc version 3.3.2 (Mandrake Linux 10.0 3.3.2-6mdk) Configured with: ../configure --prefix=/usr --libdir=/usr/lib --with-slibdir=/lib --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --enable-long-long --enable-__cxa_atexit --enable-clocale=gnu --enable-languages=c,c++,ada,f77,objc,java,pascal --host=i586-mandrake-linux-gnu --with-system-zlib
Thread model: posix
OS:                Linux

When I use the "select new elements" option in the camera GUI (not sure about the english name of the option as my desktop is in french) new photos are not selected.
I've got a green mark appearing above all the photos I've already downloaded and no mark above the one I've not, so Digikam seams to identify the new elements but is not selecting them.
This is working in 0.8.2 version (I've reinstalled it to check).
I'm using a Canon Powershot S45 in normal mode.
Comment 1 caulier.gilles 2007-01-17 15:33:42 UTC
*** Bug 139333 has been marked as a duplicate of this bug. ***
Comment 2 caulier.gilles 2007-02-20 09:51:49 UTC
*** Bug 141962 has been marked as a duplicate of this bug. ***
Comment 3 Amanda Angell 2007-02-20 10:06:20 UTC
I did a search before reporting this bug as my own, but I apologise for not seeing this. I can confirm that I also have this bug with my Canon Ixus400 in 0.9.1 but it works in 0.8.2 (I rolled-back to check). Exact same issue as david.
Comment 4 caulier.gilles 2007-02-20 10:09:52 UTC
Armanda,

I have just review the source code, and i think i have found the problem. It duing to a stupid condition test. I need Aspirin... Marcel, you is a medecine man, please help me (:=))))

So, can you use svn repository and recompile all to check my patch ?

Gilles
Comment 5 caulier.gilles 2007-02-20 10:13:21 UTC
Armanda, 

Forget to said, that i don't have a Canon camera. I cannot check the patch here in live...

In fact, only Canon camera report a flag about pictures witch are already donwloaded.

We have planed to provide an universal way to list already downloaded file using digiKam databse instead gphoto2, but it's not yet implemented. This way 
will support all camera type (serial, ptp, ums, ect)

Gilles
Comment 6 Amanda Angell 2007-02-20 10:19:04 UTC
That will be great, Gilles. I look forward to it. :)

With regards to the svn repository, it's a bit "over my head", so to speak. I'm not sure I can compile digiKam myself, I'm a little inexperienced. :( Apologies.
Comment 7 caulier.gilles 2007-02-20 10:19:42 UTC
SVN commit 635536 by cgilles:

digiKam from trunk : Gphoto camera interface : fix condition to handle file already downloaded (is only used by Canon camera). 

Feedback is require. Thanks in advance

CCBUGS: 139024

 M  +1 -3      gpcamera.cpp  
 M  +1 -1      gpcamera.h  


--- trunk/extragear/graphics/digikam/utilities/cameragui/gpcamera.cpp #635535:635536
@@ -5,7 +5,7 @@
  * Description : Gphoto2 camera interface
  * 
  * Copyright 2003-2005 by Renchi Raju
- * Copyright 2006 by Gilles Caulier
+ * Copyright 2006-2007 by Gilles Caulier
  *
  * This program is free software; you can redistribute it
  * and/or modify it under the terms of the GNU General
@@ -497,8 +497,6 @@
         {
             if (info.file.status == GP_FILE_STATUS_DOWNLOADED)
                 itemInfo.downloaded = GPItemInfo::DownloadedYes;
-            else
-                itemInfo.downloaded = GPItemInfo::DownloadedNo;
         }
         
         if (info.file.fields & GP_FILE_INFO_PERMISSIONS) 
--- trunk/extragear/graphics/digikam/utilities/cameragui/gpcamera.h #635535:635536
@@ -5,7 +5,7 @@
  * Description : Gphoto2 camera interface
  * 
  * Copyright 2003-2005 by Renchi Raju
- * Copyright 2006 by Gilles Caulier
+ * Copyright 2006-2007 by Gilles Caulier
  *
  * This program is free software; you can redistribute it
  * and/or modify it under the terms of the GNU General
Comment 8 caulier.gilles 2007-02-20 10:24:44 UTC
Armanda, 

To checkout svn "trunk" source code (UNSTABLE) and compile it, look here :

http://www.digikam.org/?q=download/svn

Read the README file and check all depencies before to compile. You have some libraries developement packages to install (like libtiff-dev for example).

Gilles

Comment 9 Amanda Angell 2007-02-20 10:53:11 UTC
Going to try compiling it now, thanks! Will let you know how it all goes.
Comment 10 Amanda Angell 2007-02-20 14:05:28 UTC
No joy I'm afraid. Still the same problem. Will check-back tomorrow.. compiling is hard work. ;)
Comment 11 Gerhard Kulzer 2007-02-20 20:45:07 UTC
Am Tuesday 20 February 2007 schrieb Amanda Angell:
[bugs.kde.org quoted mail]

I confirm, with a Canon A95, same 'problem'. And it did work once!
Gerhard
Comment 12 Gerhard Kulzer 2007-02-20 20:52:07 UTC
Am Tuesday 20 February 2007 schrieb Amanda Angell:
[bugs.kde.org quoted mail]
Hi Amanda, to make life easier (in particular when compiling digiKam :-) I 
send you this little helper script that works fine when you once went through 
the whole thing ba hand. Just change directory  and stuff to your needs. It 
creates a shadow directory under /var/tmp/graphics which contains the 
compilation artefacts only (sources are links only). Of course you can choose 
another path.

Gerhard


Created an attachment (id=19763)
compdig
Comment 13 caulier.gilles 2007-02-21 07:26:12 UTC
Gerhard,

Can you reproduce the problem with my last fix from svn trunk and your Canon camera ?

Gilles
Comment 14 Gerhard Kulzer 2007-02-21 21:40:48 UTC
Am Wednesday 21 February 2007 schrieb Gilles Caulier:
[bugs.kde.org quoted mail]
Tested right now with Canon A95: it works again, the new items are marked and 
can be selected.

Gerhard
Comment 15 caulier.gilles 2007-02-21 21:49:41 UTC
Amanda,

before to close this bug report, can you confirm if it's work for you too ?

Thanks in advance

Gilles
Comment 16 Amanda Angell 2007-02-22 06:13:24 UTC
Yes Gilles, I can confirm that it is working for me too! Tried several times, it's all great now. :D Thanks so much for your efforts!

Amanda
Comment 17 caulier.gilles 2007-02-22 07:39:44 UTC
*** Bug has been marked as fixed ***.
Comment 18 Frank Siegert 2007-02-25 00:59:02 UTC
*** Bug 140715 has been marked as a duplicate of this bug. ***
Comment 19 David Agnese 2007-03-01 21:44:00 UTC
Sorry for haven't been able to check the svn version earlier but with 2 kids under 3 years old and a wife quite reluctant seeing me in front of my computer, I couldn't find the time to compile svn version.
Has some problems compiling svn and 0.9.1 RC2 versions, I'll submit my problem in another bug report (finaly found a way to compile it)
Thank you for your great job.
I can confirm that the bug is solved too.
Now I can keep svn version as default
Comment 20 David Agnese 2007-06-22 20:41:18 UTC
Upgrading to version 0.9.2 with kubuntu packages, new item selection doesn't work anymore.
I've compiled the source but the problem is the same.
Comment 21 Roland 2007-06-23 09:04:45 UTC
I can also confirm that the item selection doesn't work anymore concerning the opensuse packages 0.9.2.
All items are always marked as new, even those which have already been downloaded.
Comment 22 David Agnese 2007-06-23 10:27:40 UTC
In my case, the difference is made between photos that have already been downloaded (green mark) and photos that haven't been (no mark) but choosing select new item doesn't select new photos
Comment 23 Roland 2007-06-23 16:10:17 UTC
To verify the behavior in version 0.9.2 more precisely I made some additional tests always by restarting the digikam tool and reconnecting the camera (Canon Powershot):

Yellow stars identifying new photos are available. The green ticks never appear after the camera has been connected; these ticks become only visible after selected photos have been downloaded.

Next time reconnecting the camera the previous status concerning new items is shown again not considering the recent downloads.

On the other hand, the selection process of "new items" correctly works in my case ...
Comment 24 caulier.gilles 2007-06-23 16:26:43 UTC
Roland, David,

About New items from camera, it's partially implemented. This is relevant of future database structure witch be done in next release dedicaced to KDE4.

I will try to simplify the situation :

- 1/ From GPhoto2 cameras, _only_ Canon support new items flag directly on firmware.
- 2/ Trying to provide ana lternative on non-Canon camera, without touch the digiKam database, i have implemented something in Camera GUi witch use the last date when user as downloaded something from camera. This is a limited and a temporally solution. Look this entry for more informations :

http://bugs.kde.org/show_bug.cgi?id=107316#c15

Gilles
Comment 25 David Agnese 2007-06-25 20:23:29 UTC
Tried again today as your post mentionned that it should work with Canon camera (I've got a Canon Powershot S45) and don't know how or why but everything worked fine.
I did several tests and it worked everytime.
Don't really know what changed in my config since last time so I don't have any clue on why it's working now.
For Roland problem, I know that there is 2 way of connecting canon Powershot (normal and PTP mode) and I'm using normal mode
Comment 26 caulier.gilles 2007-08-31 07:59:35 UTC
Arnd,

The original report of this file sound like fixed. Of course, the universal method to identify which pictures have been already downloaded on digiKAm reporistiry still to do. But this subject is already in another B.K.O file.

I propose to close this file now. Right ?

Gilles
Comment 27 Arnd Baecker 2007-08-31 09:40:50 UTC
Yes, closing this as FIXED.
Note that the method to identify which pictures 
have been already downloaded is discussed in:
http://bugs.kde.org/show_bug.cgi?id=107316#c15