Bug 136702 - Keyboard navigation in kpdf in konq only possible after focusing it with the mouse after changing tab
Summary: Keyboard navigation in kpdf in konq only possible after focusing it with the ...
Status: RESOLVED FIXED
Alias: None
Product: kpdf
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
: 142747 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-11-02 11:55 UTC by Marius
Modified: 2007-03-09 17:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marius 2006-11-02 11:55:55 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages

When changing between tabs in konqueror, each time you get to your embedded kpdf showing a pdf you have to click inside the doc area to be able to use up/down or page up/page down keyboard navigation. This can become very annoying for someone changing alot between pdf's using only the keyboard.
Comment 1 Marius 2007-01-30 19:33:01 UTC
Still applies to 3.5.6
Comment 2 Pino Toscano 2007-01-30 19:37:35 UTC
I don't see this was marked as FIXED.
Comment 3 Albert Astals Cid 2007-01-31 20:22:32 UTC
SVN commit 628869 by aacid:

Fix Keyboard navigation in kpdf in konq only possible after focusing it with the mouse after changing tab
BUGS: 136702


 M  +1 -0      part.cpp  


--- branches/KDE/3.5/kdegraphics/kpdf/part.cpp #628868:628869
@@ -192,6 +192,7 @@
 	// widgets: [] | [right 'pageView']
 	m_pageView = new PageView( m_splitter, m_document );
 	m_pageView->setFocus(); //usability setting
+	m_splitter->setFocusProxy(m_pageView);
 	connect( m_pageView, SIGNAL( urlDropped( const KURL& ) ), SLOT( openURLFromDocument( const KURL & )));
 	connect( m_pageView, SIGNAL( rightClick(const KPDFPage *, const QPoint &) ), this, SLOT( slotShowMenu(const KPDFPage *, const QPoint &) ) );
 
Comment 4 Pino Toscano 2007-03-09 17:41:06 UTC
*** Bug 142747 has been marked as a duplicate of this bug. ***