Bug 136430 - Crash trying to play RealMedia
Summary: Crash trying to play RealMedia
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.3
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-28 21:07 UTC by Vivia Nikolaidou
Modified: 2007-01-28 03:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vivia Nikolaidou 2006-10-28 21:07:12 UTC
Version:           1.4.3 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

Hi,

I had some (very old) RealAudio and RealMedia files sitting in my collection directory. The collection scanner crashes when trying to detect them. Trying to drag then from the file browser to the playlist crashes Amarok (Backtrace follows). I am running the standard Kubuntu Edgy packages, but when I compiled Amarok by myself, the collection scanner crashed as well (Don't know about playing them, I never needed to). Worked fine with the Dapper packages. Please feel free to contact me if you need the files themselves, though it seems that just all .ra and .rm files I have (back from the 1990's) are problematic.

--------------

[New Thread -1306616928 (LWP 22050)]
[Thread -1306616928 (LWP 22050) exited]
[New Thread -1306616928 (LWP 22062)]
*** stack smashing detected ***: amarok terminated

Program received signal SIGABRT, Aborted.
[Switching to Thread -1306616928 (LWP 22062)]
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb68b2770 in raise () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2  0xb68b3ef3 in abort () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#3  0xb68e7d0b in __fsetlocking () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#4  0xb696be41 in __stack_chk_fail () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#5  0xb7f02324 in sqlite3WhereBegin () from /usr/lib/libamarok.so.0
No symbol table info available.
#6  0xb7eafdc2 in TagLib::RealMedia::RealMediaFF::init ()
   from /usr/lib/libamarok.so.0
No symbol table info available.
#7  0xb7eb053e in TagLib::RealMedia::RealMediaFF::RealMediaFF ()
   from /usr/lib/libamarok.so.0
No symbol table info available.
#8  0xb7eb167c in TagLib::RealMedia::File::File () from /usr/lib/libamarok.so.0
No symbol table info available.
#9  0xb7eb19fe in RealMediaFileTypeResolver::createFile ()
   from /usr/lib/libamarok.so.0
No symbol table info available.
#10 0xb6dc2e21 in TagLib::FileRef::create () from /usr/lib/libtag.so.1
No symbol table info available.
#11 0xb6dc3252 in TagLib::FileRef::FileRef () from /usr/lib/libtag.so.1
No symbol table info available.
#12 0xb7d03b2b in MetaBundle::readTags () from /usr/lib/libamarok.so.0
No symbol table info available.
#13 0xb7d060d9 in MetaBundle::MetaBundle () from /usr/lib/libamarok.so.0
No symbol table info available.
#14 0xb7c16c6f in CollectionDB::bundlesByUrls () from /usr/lib/libamarok.so.0
No symbol table info available.
#15 0xb7da7646 in UrlLoader::doJob () from /usr/lib/libamarok.so.0
No symbol table info available.
#16 0xb7e1c205 in ThreadWeaver::Thread::run () from /usr/lib/libamarok.so.0
No symbol table info available.
#17 0xb633e101 in QThreadInstance::start () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#18 0xb6d13504 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#19 0xb695651e in clone () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
Comment 1 Matti Moell 2006-11-11 00:19:22 UTC
I have the same Problem running amarok from svn (11.11.06) I wanted to scan the collection but it stopped scanning and told me that taglib might be broken. 
it showed me the 3 existing .rm files in my collection an one file (songxy.mp) I searched for this file but it didn't exist in my collection, this song showed up like 15 times in the list of tracks that could not be scanned.
 

I deleted all .rm files in my collection and then it worked perfectly. 

thanks guys hope you fix that quickly

~matti~

Comment 2 Martin Aumueller 2006-12-28 21:49:08 UTC
Do you still happen to have such a .rm file that you could make available to us for reproducing the crash?
Comment 3 Andrew Ash 2007-01-03 21:09:32 UTC
This bug has also been reported into Ubuntu's launchpad at https://launchpad.net/bugs/77566  

It also includes a crash report.
Comment 4 Sam Liddicott 2007-01-05 10:09:16 UTC
I can't add an audio file as it is too big, but you can download one anytime you like like this:

URL: http://www.bbc.co.uk/bbc7/listenagain/

click a day of the week, e.g.

http://www.bbc.co.uk/bbc7/listenagain/

find a listen again link and feed it to mplayer, e.g.

mplayer -quiet -dumpstream -playlist http://www.bbc.co.uk/bbc7/listenagain/friday/rams/1345.ram -dumpfile badfile.ra

Comment 5 Martin Aumueller 2007-01-28 01:54:54 UTC
Very probably this crash is due to the fact that the file does not have any tags and that Amarok tried to get the tags from the database and media devices because of this. However, this would crash the collection scanner, is it does not have access to media devices.
Please reopen, if 1.4.5 does not fix it for you.
Comment 6 Martin Aumueller 2007-01-28 01:57:20 UTC
Sorry, this is another issue than in #5.
Comment 7 Martin Aumueller 2007-01-28 03:21:55 UTC
SVN commit 627768 by aumuell:

initialize in order to avoid crashes with some .rm files
BUG: 137695
BUG: 136430


 M  +1 -0      ChangeLog  
 M  +32 -4     src/metadata/rmff/rmff.cpp  


--- trunk/extragear/multimedia/amarok/ChangeLog #627767:627768
@@ -101,6 +101,7 @@
     * Amarok now saves playlists with relative paths by default.
 
   BUGFIXES:
+    * Some .rm files would make Amarok crash. (BR 137695)
     * Remember 'User Cover Art for Folder Icons' when organizing files.
       (BR 138582)
     * "Listening since..." has been changed to the more clear "First
--- trunk/extragear/multimedia/amarok/src/metadata/rmff/rmff.cpp #627767:627768
@@ -122,8 +122,22 @@
 
 
 RealMediaFF::RealMediaFF(const char *file, bool readProperties, AudioProperties::ReadStyle /*propertiesStyle*/)
-   : m_filename(0), m_head(0), m_tail(0), m_err(0), media_hdrs(0), m_id3v1tag(0), 
-     m_flipYearInMetadataSection(0), m_readProperties(readProperties)
+: m_filename(0)
+, m_head(0)
+, m_tail(0)
+, m_err(0)
+, m_hdr(0)
+, m_props(0)
+, media_hdrs(0)
+, m_contenthdr(0)
+, m_md(0)
+, m_title(0)
+, m_author(0)
+, m_copyright(0)
+, m_comment(0)
+, m_id3v1tag(0)
+, m_flipYearInMetadataSection(0)
+, m_readProperties(readProperties)
 {
    m_filename = strdup(file);
 
@@ -150,8 +164,22 @@
 
 
 RealMediaFF::RealMediaFF(RealMediaFF &src)
-   : m_filename(0), m_head(0), m_tail(0), m_err(0), media_hdrs(0), m_id3v1tag(0), 
-     m_flipYearInMetadataSection(0), m_readProperties(src.m_readProperties)
+: m_filename(0)
+, m_head(0)
+, m_tail(0)
+, m_err(0)
+, m_hdr(0)
+, m_props(0)
+, media_hdrs(0)
+, m_contenthdr(0)
+, m_md(0)
+, m_title(0)
+, m_author(0)
+, m_copyright(0)
+, m_comment(0)
+, m_id3v1tag(0)
+, m_flipYearInMetadataSection(0)
+, m_readProperties(src.m_readProperties)
 {
    m_filename=strdup(src.m_filename);
 
Comment 8 Martin Aumueller 2007-01-28 03:22:52 UTC
I could not reproduce your problems any longer. Please reopen, if still not fixed.