Bug 136019 - ktorrent doesn't set individual upload limits.
Summary: ktorrent doesn't set individual upload limits.
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
: 142711 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-10-20 14:14 UTC by Xushi
Modified: 2007-05-01 12:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xushi 2006-10-20 14:14:01 UTC
Version:           2.0.3 (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages
Compiler:          gcc version 4.1.1 (Gentoo 4.1.1) CFLAGS="-Os -march=pentium-m -pipe -fomit-frame-pointer -ftracer -fweb -fvar-tracking -fvisibility-inlines-hidden"
OS:                Linux

Ktorrent can set a total upload, but cannot set individual upload limits for each torrent.

My wish is to set individual uploads as well as total upload.


Thanks.
Comment 1 Joris Guisson 2006-10-21 12:07:50 UTC
That is planned, but I don't know when we will get to this.
Comment 2 Bram Schoenmakers 2007-03-09 09:45:51 UTC
Bug 142711 also mentions configuring the individual download speeds.
Comment 3 Bram Schoenmakers 2007-03-09 09:47:54 UTC
Hmm.. strange... I marked bug 142711 as duplicate of this one, but no message about that appeared here. Bugzilla is messed up currently, it seems.
Comment 4 Joris Guisson 2007-05-01 12:54:58 UTC
SVN commit 660025 by guisson:

Added upload and download limits for individual torrents.

BUG: 136019



 M  +1 -0      ChangeLog  
 M  +3 -3      apps/ktorrent/Makefile.am  
 M  +16 -0     apps/ktorrent/ktorrentview.cpp  
 M  +1 -0      apps/ktorrent/ktorrentview.h  
 M  +3 -0      apps/ktorrent/ktorrentviewmenu.cpp  
 M  +1 -0      apps/ktorrent/ktorrentviewmenu.h  
 A             apps/ktorrent/speedlimitsdlg.cpp   [License: GPL (v2+)]
 A             apps/ktorrent/speedlimitsdlg.h   [License: GPL (v2+)]
 A             apps/ktorrent/speedlimitsdlgbase.ui  
 M  +4 -2      ktorrent.kdevelop  
 M  +6 -0      libktorrent/interfaces/torrentinterface.h  
 M  +6 -0      libktorrent/mse/streamsocket.cpp  
 M  +7 -0      libktorrent/mse/streamsocket.h  
 M  +5 -4      libktorrent/net/Makefile.am  
 M  +10 -2     libktorrent/net/bufferedsocket.cpp  
 M  +15 -0     libktorrent/net/bufferedsocket.h  
 M  +22 -68    libktorrent/net/downloadthread.cpp  
 M  +10 -21    libktorrent/net/downloadthread.h  
 A             libktorrent/net/networkthread.cpp   [License: GPL (v2+)]
 A             libktorrent/net/networkthread.h   [License: GPL (v2+)]
 A             libktorrent/net/socketgroup.cpp   [License: GPL (v2+)]
 A             libktorrent/net/socketgroup.h   [License: GPL (v2+)]
 M  +36 -8     libktorrent/net/socketmonitor.cpp  
 M  +31 -0     libktorrent/net/socketmonitor.h  
 M  +16 -60    libktorrent/net/uploadthread.cpp  
 M  +7 -21     libktorrent/net/uploadthread.h  
 M  +5 -0      libktorrent/torrent/peer.cpp  
 M  +7 -0      libktorrent/torrent/peer.h  
 M  +9 -0      libktorrent/torrent/peermanager.cpp  
 M  +3 -0      libktorrent/torrent/peermanager.h  
 M  +108 -1    libktorrent/torrent/torrentcontrol.cpp  
 M  +8 -0      libktorrent/torrent/torrentcontrol.h