Bug 135958 - Flickering in Problems Tab
Summary: Flickering in Problems Tab
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: Problem reporter (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-19 13:06 UTC by Christoph Bartoschek
Modified: 2006-12-29 10:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Bartoschek 2006-10-19 13:06:54 UTC
Version:           Subversion 3.4 branch revision 596958 (using KDE KDE 3.5.5)
Compiler:          g++ 4.1 
OS:                Linux

Whenever the line information of a message in the Problems tab changes there is flickering. It seems as if the tab is cleared and then the new values are entered.

Just write a line of code that is marked as wrong. For example:

void a() {
   for ();
}

Then press enter in front of void to insert new lines. Each time the entries in the problems bar flicker.
Comment 1 Matt Rogers 2006-11-04 16:12:24 UTC
I can't reproduce that here with a revision > 600000. Which tab do you see the flickering in?
Comment 2 Matt Rogers 2006-11-05 16:34:26 UTC
you're correct, it does remove and readd.
Comment 3 Jens Dagerbo 2006-12-29 10:54:10 UTC
SVN commit 617453 by dagerbo:

This patch does a few related things:
#removes a lot of unused and weird stuff from problemreporter
#all parser activation decisions are moved back into cppsupport where it belongs, problemreporter is just UI
#fixes flickering problem tabs
#fixes a case where  already open documents don't get a problem icon marker
#fixes sorting so it happens numerically, no lexographically
#afaik fixes repeated entries. if this still happens, I don't think problem reporter is responsible
#afaik fixes the remaining cases where the parser could be invoked against non-c/c++ files

BUG: 111341
BUG: 117621
BUG: 131716
BUG: 135958


 M  +53 -14    cppsupportpart.cpp  
 M  +9 -4      cppsupportpart.h  
 M  +44 -144   problemreporter.cpp  
 M  +7 -16     problemreporter.h