Bug 135154 - Crash in CPPSourceCodeDocument::addCodeOperation loading .h files
Summary: Crash in CPPSourceCodeDocument::addCodeOperation loading .h files
Status: RESOLVED DUPLICATE of bug 130720
Alias: None
Product: umbrello
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-05 17:05 UTC by Al Dunstan
Modified: 2007-03-21 06:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Al Dunstan 2006-10-05 17:05:37 UTC
Version:           1.5.3 (using KDE KDE 3.5.3)
Installed from:    Fedora RPMs
Compiler:           Code is written for MS Visual C++, but I wanted to generate some UML via Umbrello.
OS:                Linux

I tried to import a .h file into Umbrello, but it crashes (reliably).  The code I'm trying to import is written for MS Visual C++ (I just wanted some UML diagrams to figure out how the code works).

The code is on a Samba share (mount.cifs) but copying it to a local directory made no change.

Reproducing it is easy - import the file referred to below.


Backtrace is:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208497408 (LWP 1444)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x082b9c71 in CPPSourceCodeDocument::addCodeOperation ()
#7  0x08120008 in ClassifierCodeDocument::addOperation ()
#8  0x08121565 in ClassifierCodeDocument::qt_invoke ()
#9  0x082b9e0f in CPPSourceCodeDocument::qt_invoke ()
#10 0x032e60b7 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x08119eae in UMLClassifier::operationAdded ()
#12 0x0811b665 in UMLClassifier::addOperation ()
#13 0x081541b8 in Import_Utils::insertMethod ()
#14 0x08233402 in CppTree2Uml::parseFunctionDeclaration ()
#15 0x08235133 in CppTree2Uml::parseDeclaration ()
#16 0x08232890 in CppTree2Uml::parseSimpleDeclaration ()
#17 0x0823e8d6 in TreeParser::parseDeclaration ()
#18 0x0823eb2e in TreeParser::parseClassSpecifier ()
#19 0x08235794 in CppTree2Uml::parseClassSpecifier ()
#20 0x0823e82d in TreeParser::parseTypeSpecifier ()
#21 0x08232819 in CppTree2Uml::parseSimpleDeclaration ()
#22 0x0823e8d6 in TreeParser::parseDeclaration ()
#23 0x0823ea90 in TreeParser::parseLinkageBody ()
#24 0x0823e863 in TreeParser::parseNamespace ()
#25 0x082344b9 in CppTree2Uml::parseNamespace ()
#26 0x0823e932 in TreeParser::parseDeclaration ()
#27 0x0823e9f2 in TreeParser::parseTranslationUnit ()
#28 0x082346f4 in CppTree2Uml::parseTranslationUnit ()
#29 0x0813cdf7 in CppImport::feedTheModel ()
#30 0x0813d271 in CppImport::parseFile ()
#31 0x081263d8 in ClassImport::importFiles ()
#32 0x08197967 in UMLApp::slotImportClasses ()
#33 0x08199615 in UMLApp::qt_invoke ()
#34 0x032e6154 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#35 0x032e660a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#36 0x03c419f7 in KAction::activated () from /usr/lib/libkdeui.so.4
#37 0x03c775c4 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#38 0x03c92dba in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#39 0x03c9306b in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#40 0x032e6154 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#41 0x0365d146 in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#42 0x03303843 in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#43 0x033fa2f2 in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#44 0x03c4d3dd in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#45 0x03324300 in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#46 0x0328174d in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#47 0x0328267f in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#48 0x03a16251 in KApplication::notify () from /usr/lib/libkdecore.so.4
#49 0x032193d7 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#50 0x03217813 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#51 0x0322b848 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#52 0x03299db2 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#53 0x03299cd6 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#54 0x03281119 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#55 0x08167ec9 in main ()


The code I'm trying to import is saved in APSPM_C3DVector.h:

#ifndef C3DVECTOR_H
#define C3DVECTOR_H

#include "Base.h"
namespace APSPM
{
    class C3DVector
    {
    public:
        C3DVector();
        C3DVector(const C3DVector &rhs);
        C3DVector(DOUBLE_64 x, DOUBLE_64 y, DOUBLE_64 z);
        virtual ~C3DVector();

        // Assignment.
        C3DVector & operator=(const C3DVector &rhs);

        // Access the different parts - x/y/z.
        const double & operator[](int idx) const;
        double & operator[](int idx);

        double & X();
        const double &X() const;

        double & Y();
        const double &Y() const;

        double & Z();
        const double &Z() const;

        // Add & subtract two vectors.
        C3DVector operator+(const C3DVector &) const;
        C3DVector operator-(const C3DVector &) const;

        // Multiply a vector by a scalar.
        C3DVector operator*(DOUBLE_64 scalar) const;
        C3DVector operator/(DOUBLE_64 scalar) const;
        friend C3DVector operator*(DOUBLE_64 scalar, const C3DVector &vector);

        // Compute the magnitude & square-of-magnitude.
        DOUBLE_64 magnitude() const;
        DOUBLE_64 magnitudeSquared() const;

        // The dot product.
        DOUBLE_64 dotProduct(const C3DVector &) const;

        // The cross product.
        C3DVector crossProduct(const C3DVector &) const;

        // A unit vector parallel to this.
        C3DVector unitVector() const;

    private:
        DOUBLE_64 m_x, m_y, m_z;
    };
}
#endif // C3DVECTOR_H


Base.h is not in the current directory, and I didn't see anything in Settings to tell Umbrello where to go look for it.  Some include files it won't find - they're only on the Windows machine on which the code lives.
Comment 1 Oliver Kellogg 2006-10-05 19:36:30 UTC

*** This bug has been marked as a duplicate of 84739 ***
Comment 2 Oliver Kellogg 2007-03-21 06:53:50 UTC
The bug fixed by commit 644749 was covering up the true cause here. 
Comment 3 Oliver Kellogg 2007-03-21 06:54:29 UTC

*** This bug has been marked as a duplicate of 130720 ***