Bug 134355 - configure script fails '--without-akode' option
Summary: configure script fails '--without-akode' option
Status: RESOLVED FIXED
Alias: None
Product: kdemultimedia
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Multimedia Developers
URL:
Keywords:
: 116958 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-19 22:39 UTC by Juuso Alasuutari
Modified: 2006-09-24 00:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
patch for configure.in (796 bytes, patch)
2006-09-19 22:40 UTC, Juuso Alasuutari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juuso Alasuutari 2006-09-19 22:39:00 UTC
Version:            (using KDE KDE 3.5.3)
Installed from:    Compiled From Sources
Compiler:          gcc 4.0.3 
OS:                Linux

'./configure --without-akode' fails for kdemultimedia 3.5.4. Here's what it says:

  checking if mpeglib_artsplug should be compiled... yes
  configure: error: conditional "include_akode_mpeg" was never defined.
  Usually this means the macro was only invoked conditionally.

I can't confirm this, but I'm told that also --with-akode fails. That sounds convincing enough, considering that a line in the configure.in file seems misplaced. Moving it around and running autoconf enables a succesful configure and compile with both '--without-akode' and '--with-akode'.
Comment 1 Juuso Alasuutari 2006-09-19 22:40:36 UTC
Created attachment 17844 [details]
patch for configure.in

$ patch -p0 < akode_fix_in.diff
$ autoconf
Comment 2 Rex Dieter 2006-09-20 14:34:27 UTC
*** Bug 116958 has been marked as a duplicate of this bug. ***
Comment 3 Rex Dieter 2006-09-20 14:35:23 UTC
See also bug #116958 comment 13.
Comment 4 Michael Pyne 2006-09-24 00:41:38 UTC
SVN commit 587757 by mpyne:

Fix bug 134355 (configure script fails when using --without-akode option) by using the
patches provided by Rex Dieter and Juuso Alasuutari.

The AM_CONDITIONAL checks for whether to install the aKode .mcopclass files must always
be run it seems, even if aKode is configured to not install, otherwise a autoconf
sanity check will fail when running configure.

I've also taken the liberty of moving the aKode stuff to akode_artsplugin since that is
the Makefile.am that uses these particular AM_CONDITIONALS().  (This was the Rex Dieter
patch).

P.S. Bug 116958 wasn't really a duplicate of 134355, 134355 was caused by the fix for
116958. ;)

BUG:134355


 M  +13 -1     akode_artsplugin/configure.in.in  
 M  +0 -12     configure.in.in  


--- branches/KDE/3.5/kdemultimedia/akode_artsplugin/configure.in.in #587756:587757
@@ -1,4 +1,16 @@
 if test x$build_arts != xyes || test x$have_akode != xyes
 then
-DO_NOT_COMPILE="$DO_NOT_COMPILE akode_artsplugin"
+  DO_NOT_COMPILE="$DO_NOT_COMPILE akode_artsplugin"
+else
+  KDE_CHECK_LIB(akode_mpeg_decoder,   mpeg_decoder,   have_akode_mpeg=yes,   have_akode_mpeg=no,   -lakode)
+  KDE_CHECK_LIB(akode_mpc_decoder,    mpc_decoder,    have_akode_mpc=yes,    have_akode_mpc=no,    -lakode)
+  KDE_CHECK_LIB(akode_xiph_decoder,   xiph_decoder,   have_akode_xiph=yes,   have_akode_xiph=no,   -lakode)
+  KDE_CHECK_LIB(akode_ffmpeg_decoder, ffmpeg_decoder, have_akode_ffmpeg=yes, have_akode_ffmpeg=no, -lakode)
 fi
+
+# This must always be called to handle the --without-akode case, as autoconf
+# will check these conditionals values it seems.
+AM_CONDITIONAL(include_akode_mpeg,   test x$have_akode_mpeg = xyes)
+AM_CONDITIONAL(include_akode_mpc,    test x$have_akode_mpc = xyes)
+AM_CONDITIONAL(include_akode_xiph,   test x$have_akode_xiph = xyes)
+AM_CONDITIONAL(include_akode_ffmpeg, test x$have_akode_ffmpeg = xyes)
--- branches/KDE/3.5/kdemultimedia/configure.in.in #587756:587757
@@ -367,20 +367,8 @@
 
   AC_SUBST(akode_includes)
   AC_SUBST(akode_libs)
-
-  KDE_CHECK_LIB(akode_mpeg_decoder,   mpeg_decoder,   have_akode_mpeg=yes,   have_akode_mpeg=no,   -lakode)
-  KDE_CHECK_LIB(akode_mpc_decoder,    mpc_decoder,    have_akode_mpc=yes,    have_akode_mpc=no,    -lakode)
-  KDE_CHECK_LIB(akode_xiph_decoder,   xiph_decoder,   have_akode_xiph=yes,   have_akode_xiph=no,   -lakode)
-  KDE_CHECK_LIB(akode_ffmpeg_decoder, ffmpeg_decoder, have_akode_ffmpeg=yes, have_akode_ffmpeg=no, -lakode)
-
-  AM_CONDITIONAL(include_akode_mpeg,   test x$have_akode_mpeg = xyes)
-  AM_CONDITIONAL(include_akode_mpc,    test x$have_akode_mpc = xyes)
-  AM_CONDITIONAL(include_akode_xiph,   test x$have_akode_xiph = xyes)
-  AM_CONDITIONAL(include_akode_ffmpeg, test x$have_akode_ffmpeg = xyes)
-
 ])
 
-
 AC_DEFUN([KDE_CHECK_MPEGLIB_ARTS],
 [
   MPEGLIB_ARTS_MAJOR_VERSION=0