Bug 134217 - For some reason when I go to add the camera it freezes up and won't download photos
Summary: For some reason when I go to add the camera it freezes up and won't download ...
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Gphoto2 (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 134218 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-17 18:01 UTC by Karen
Modified: 2017-08-16 06:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karen 2006-09-17 18:01:50 UTC
Version:            (using KDE KDE 3.5.4KDE 1.2)
Installed from:    00SuSE RPMs
Compiler:          Intell 
OS:                Linux

I go to Digikam, click on camera, click on the camera it detected, it says connecting to camera and then it shows crash handler. It shows this "This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash."  

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".


what does this mean and how can i download my pictures from my camera without it doing this.  How do I download the software for my camera
Comment 1 Marcel Wiesweg 2006-09-17 18:42:13 UTC
*** Bug 134218 has been marked as a duplicate of this bug. ***
Comment 2 Marcel Wiesweg 2006-09-17 18:49:21 UTC
Digikam crashed, but we cannot say why because all debugging information has been removed from your executable (which is usual for packages from your distributor)

To be able to locate the problem, we need more information.
First, which version of digikam are you using?
Please test with the 0.9.0-beta2 version (available at http://sourceforge.net/project/showfiles.php?group_id=42641&package_id=34800&release_id=447678 )
I dont know if there are packages for your distribution.
Alternatively, first try to update gphoto2, which might be the reason for the crash.
If it still crashes, compile 0.9.0-beta2 with debugging information (./configure --enable-debug) and post the backtrace from the crash handler.
Comment 3 Karen 2006-09-17 22:51:25 UTC
How do I find out what version of digikam I am using
and how do I update gphoto2?

--- Marcel Wiesweg <marcel.wiesweg@gmx.de> wrote:

[bugs.kde.org quoted mail]
http://sourceforge.net/project/showfiles.php?group_id=42641&package_id=34800&release_id=447678
> )
> I dont know if there are packages for your
> distribution.
> Alternatively, first try to update gphoto2, which
> might be the reason for the crash.
> If it still crashes, compile 0.9.0-beta2 with
> debugging information (./configure --enable-debug)
> and post the backtrace from the crash handler.
> 



__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
Comment 4 Gerhard Kulzer 2006-09-18 06:54:29 UTC
Am Sonntag, 17. September 2006 22:51 schrieb Karen:
[bugs.kde.org quoted mail]
As with all GUI programs: You find it under the Help menu as 'About digiKam'
>
> --- Marcel Wiesweg <marcel.wiesweg gmx de> wrote:
>
> [bugs.kde.org quoted mail]
> http://sourceforge.net/project/showfiles.php?group_id=42641&package_id=3480
>0&release_id=447678
>
> > )
> > I dont know if there are packages for your
> > distribution.
> > Alternatively, first try to update gphoto2, which
> > might be the reason for the crash.
> > If it still crashes, compile 0.9.0-beta2 with
> > debugging information (./configure --enable-debug)
> > and post the backtrace from the crash handler.
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
> _______________________________________________
> Digikam-devel mailing list
> Digikam-devel@kde.org
> https://mail.kde.org/mailman/listinfo/digikam-devel

Comment 5 caulier.gilles 2006-12-12 09:21:34 UTC
Karen,

This crash still reproductible using digiKam/DigikamImagePlugins 0.9.0-RC2, Exiv2 0.12, and a fresh update of libgphoto2 ?

Thanks in advance for your feedback.

Gilles Caulier
Comment 6 Arnd Baecker 2007-06-06 19:29:46 UTC
Karen,

is this crash still reproduceable using digiKam 0.9.2-beta3, exiv2 0.14 
and a fresh update of libgphoto2 ?

Many thanks in advance for any feedback!
Comment 7 Arnd Baecker 2007-06-26 09:51:29 UTC
Closing this bug now. 
This does not mean it is invalid by itself, but
without updated information (with full debug gdb backtrace) 
using the current 0.9.2 version
it is not possible to find the root of the problem.

Please feel free to re-open if there is any new information.

Thanks a lot for your understanding, 

Arnd