Bug 134061 - fonts with japanese names don't show up in kfontinst
Summary: fonts with japanese names don't show up in kfontinst
Status: RESOLVED FIXED
Alias: None
Product: kcontrol
Classification: Unclassified
Component: kcmfontinst (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Craig Drummond
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-14 12:03 UTC by Con Kolivas
Modified: 2008-06-13 14:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Con Kolivas 2006-09-14 12:03:07 UTC
Version:            (using KDE KDE 3.5.4)
Installed from:    Compiled From Sources
Compiler:          gcc-4.1.1 Configured with: ../gcc-4.1.1/configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --enable-long-long --enable-__cxa_atexit --enable-clocale=gnu --disable-libunwind-exceptions --enable-languages=c,c++ --program-suffix=-4.1.1
OS:                Linux

Fonts starting without english characters in them install fine with kfontinst but then don't show up in the fontlist. Eg the professional hiragino fonts with names like "ヒラギノ丸ゴ Pro W4.otf" don't show up.
Comment 1 Craig Drummond 2007-11-15 23:28:39 UTC
Which fontlist? The font installers, or KDE/Qt apps' font lists? The font installer gets it fontlist from fontconfig. Does fc-list list the font? Is there anywhere I can obtain a free japanese named font to test against?
Comment 2 Con Kolivas 2007-11-15 23:46:30 UTC
I renamed the free font mikachan to the japanese named みかちゃん.ttf

I've uploaded the renamed font and put it into a tar here:

http://vds.kolivas.org/mikachan_font.tar.bz2

fc-list shows it
mikachan\-PB,みかちゃん\-PB:style=Regular

but the kde control centre font installer does not. It seems to be more the actual font filename rather than the fontname itself that's at fault because if that font is renamed to english filename mikachan.ttf it shows up.
Comment 3 Craig Drummond 2007-11-22 11:57:25 UTC
Hmmm... I can confirm this. The KDE3 installer does not list the font, but the KDE4 one does.
Comment 4 Craig Drummond 2008-06-13 14:14:37 UTC
SVN commit 820166 by craig:

Fix conversion of fontconfig's UTF-8 strings into QStrings.
(The fonts:// ioslave code was assuming fontconfig's strings were all ASCII - even though there were other places in kfontinst's code doing a proper conversion!)
BUG:134061


 M  +11 -18    KioFonts.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=820166