Bug 133911 - crashes on exit when on ERD multiplication of relation is set
Summary: crashes on exit when on ERD multiplication of relation is set
Status: RESOLVED DUPLICATE of bug 84739
Alias: None
Product: umbrello
Classification: Applications
Component: general (show other bugs)
Version: 1.5.1
Platform: Gentoo Packages Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-11 15:40 UTC by ajuc
Modified: 2006-09-17 12:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
saved file with ERD that causes crash on exit (275.56 KB, application/octet-stream)
2006-09-11 15:42 UTC, ajuc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ajuc 2006-09-11 15:40:06 UTC
Version:           1.5.1 (using KDE KDE 3.5.2)
Installed from:    Gentoo Packages
Compiler:          gcc version 3.3.6 Gentoo 3.3.6, ssp-3.3.6-1.0, pie-8.7.8
OS:                Linux

Default umbrello instalation from Gento Packages.

Crashes on almost every exit, when I do folowing:

1. open ERD
2. make 2 entities A and B
3. make relation from A to B
4. set multiplication to 0,1 -> n
5. save //maybe not needed to casue crash
6. quit

Backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 25976)]
[New Thread 32769 (LWP 27521)]
[KCrash handler]
#7  0x0856d158 in ?? ()
#8  0x082ccc8b in CPPHeaderClassDeclarationBlock::updateContent ()
#9  0x0817f68b in OwnedHierarchicalCodeBlock::syncToParent ()
#10 0x0817f82b in OwnedHierarchicalCodeBlock::qt_invoke ()
#11 0x082cda9d in CPPHeaderClassDeclarationBlock::qt_invoke ()
#12 0xb70014e6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#13 0xb7001394 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#14 0x081c93ed in UMLObject::modified ()
#15 0x0819b538 in UMLCanvasObject::removeAssociation ()
#16 0x081a1c8c in UMLDoc::removeAssocFromConcepts ()
#17 0x081a1bc2 in UMLDoc::removeAssociation ()
#18 0x08101c5b in UMLAssociation::~UMLAssociation ()
#19 0x0819e118 in UMLDoc::closeDocument ()
#20 0x08195422 in UMLApp::queryExit ()
#21 0xb7973425 in KMainWindow::closeEvent ()
   from /usr/kde/3.5/lib/libkdeui.so.4
#22 0xb7037fe2 in QWidget::event () from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb70fad02 in QMainWindow::event () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb6fa3a2f in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb6fa2e45 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb761a6a5 in KApplication::notify () from /usr/kde/3.5/lib/libkdecore.so.4
#27 0xb7037885 in QWidget::close () from /usr/qt/3/lib/libqt-mt.so.3
#28 0xb6f3abea in QETWidget::translateCloseEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#29 0xb6f34954 in QApplication::x11ClientMessage ()
   from /usr/qt/3/lib/libqt-mt.so.3
#30 0xb6f3594c in QApplication::x11ProcessEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#31 0xb6f4cb84 in QEventLoop::processEvents () from /usr/qt/3/lib/libqt-mt.so.3
#32 0xb6fb5d81 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#33 0xb6fb5c28 in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#34 0xb6fa3c81 in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#35 0x08167e84 in main ()
Comment 1 ajuc 2006-09-11 15:42:57 UTC
Created attachment 17718 [details]
saved file with ERD that causes crash on exit
Comment 2 Oliver Kellogg 2006-09-17 12:03:19 UTC
Umbrello-1.5.4 has the advanced code generators disabled which circumvents the problem.

*** This bug has been marked as a duplicate of 84739 ***