Bug 133584 - [PATCH] Talkers' names lost in IRC channel logs
Summary: [PATCH] Talkers' names lost in IRC channel logs
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: History Plugin (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 80 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 87456 124753 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-05 12:15 UTC by Endel Soolo
Modified: 2008-07-06 11:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch to display names in the history plugin viewer (1.02 KB, patch)
2008-01-25 20:00 UTC, Aaron
Details
Patch to display names in different colors in the history plugin viewer and no timestamps (1.18 KB, patch)
2008-01-25 21:37 UTC, Aaron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Endel Soolo 2006-09-05 12:15:44 UTC
Version:           0.11.3 (using KDE KDE 3.5.4)
Installed from:    Debian testing/unstable Packages
OS:                Linux

The log of a IRC channel shows something like this

(22:02:54) < Hello, John! How are you?
(22:03:55) < Fine, but you?
(22:05:00) < What is going on here?

It does not show who said what.
Channel logs or conference call logs should be shown with names, like this:

(22:02:54) Jack: Hello, John! How are you?
(22:03:55) John: Fine, but you?
(22:05:00) George: What is going on here?

The saved xml log file does already contain talkers' names, so this only affects the log showing part of the program.
Comment 1 Bearcat M. Sandor 2006-09-20 01:13:40 UTC
This has been a bug that has bothered me for quite a while now. I would love to see this fixed.

Id this just a property of the default theme used to view the chat logs?
Comment 2 Marcin Juszkiewicz 2007-02-08 20:08:20 UTC
124753 is probably the same
Comment 3 Pino Toscano 2007-04-18 13:48:48 UTC
*** Bug 124753 has been marked as a duplicate of this bug. ***
Comment 4 Pino Toscano 2007-04-18 14:36:36 UTC
*** Bug 87456 has been marked as a duplicate of this bug. ***
Comment 5 Marcin Juszkiewicz 2007-06-30 14:26:32 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Aaron 2008-01-25 20:00:54 UTC
Created attachment 23275 [details]
Patch to display names in the history plugin viewer

Please let me know what happens to this. My email address is reldruh AT gmail
DOT com. Thank you.
Comment 7 Aaron 2008-01-25 21:37:41 UTC
Created attachment 23281 [details]
Patch to display names in different colors in the history plugin viewer and no timestamps

This is an improved version of the patch I submitted earlier. It displays the
names in different colors so they can be more easily differentiated. It also
gets rid of the timestamps, although I think there should be a checkbox
somewhere to set that.
Comment 8 Dennis Nienhüser 2008-07-06 11:47:53 UTC
SVN commit 828632 by nienhueser:

Add talkers names in history view. Based on Aaron's patch, thanks for the patch! The fix will be in Kopete 0.60, which will be out with KDE 4.1.
CCMAIL: reldruh@gmail.com
BUG: 133584


 M  +23 -5     historydialog.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=828632