Bug 132701 - deleting folders doesn't work properly
Summary: deleting folders doesn't work properly
Status: RESOLVED FIXED
Alias: None
Product: kooka
Classification: Unclassified
Component: general (show other bugs)
Version: 0.44
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Marten
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-20 18:22 UTC by Rodney Warren-Smith
Modified: 2020-12-18 08:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodney Warren-Smith 2006-08-20 18:22:16 UTC
Version:           0.44 (using KDE 3.5.1 Level "a" , SUSE 10.1)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.16.13-4-default

There are two aspects to this.

First, if you right-click on a folder in the folder tree view, one of the options is "delete image" when it should be "delete folder".

If you select this option, there is a good chance the application will crash with a SIGSEGV (possibly only if this leaves the ScanImages folder empty??). Unfortunately, there's no debugging information in the crash report, so I can't offer much more than this.
Comment 1 Jonathan Marten 2008-02-19 19:22:04 UTC
Have done a number of fixes in the gallery context menus, including changing the action name to "Folder" or "Image" as appropriate.  See commit 768538. 

If you can compile from SVN, please check out and try the work version at branches/work/kooka-kde3 which incorporates this fix. 
Comment 2 Jonathan Marten 2008-02-19 19:24:24 UTC
Crash and backtrace soon after deleting the last item from the gallery.  Possibly the same as reported.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb64766d0 (LWP 26667)]
[KCrash handler]
#6  0x002f002f in ?? ()
#7  0xb7b6a5ad in ~KFileIconViewItem (this=0x831f360)
    at /ws/release-current/kdelibs-current/kio/kfile/kfileiconview.cpp:49
#8  0x08091bc4 in ~ThumbViewItem (this=0x831f360)
    at /ws/kooka-3.5/kooka-kde3/kooka/thumbviewitem.h:42
#9  0xb6ed18d1 in QIconView::clear () from /usr/qt/3/lib/libqt-mt.so.3
#10 0x0806f692 in KookaView::slShowThumbnails (this=0x817a7a8, 
    dirKfi=0x82812c8, forceRedraw=false)
    at /ws/kooka-3.5/kooka-kde3/kooka/kookaview.cpp:1005
#11 0x08071f0f in KookaView::qt_invoke (this=0x817a7a8, _id=24, _o=0xbfff7774)
    at ./kookaview.moc:363
#12 0xb6d10619 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#13 0x08088175 in ScanPackager::showThumbnails (this=0x81d7108, t0=0x82812c8)
    at ./scanpackager.moc:331
#14 0x0808c52a in ScanPackager::slClicked (this=0x81d7108, newItem=0x82812c8)
    at /ws/kooka-3.5/kooka-kde3/kooka/scanpackager.cpp:573
#15 0x0808cdb4 in ScanPackager::qt_invoke (this=0x81d7108, _id=131, 
    _o=0xbfff78f4) at ./scanpackager.moc:414
#16 0xb6d10619 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#17 0xb7056474 in QListView::clicked () from /usr/qt/3/lib/libqt-mt.so.3
#18 0xb6df3831 in QListView::contentsMouseReleaseEventEx ()
   from /usr/qt/3/lib/libqt-mt.so.3
#19 0xb6df3f24 in QListView::contentsMouseReleaseEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#20 0xb764ffa8 in KListView::contentsMouseReleaseEvent (this=0x81d7108, 
    e=0xbfff7bb4)
    at /ws/release-current/kdelibs-current/kdeui/klistview.cpp:878
#21 0xb6e24dff in QScrollView::viewportMouseReleaseEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb6e2203e in QScrollView::eventFilter () from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb6df0a06 in QListView::eventFilter () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb6d0feec in QObject::activate_filters ()
   from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb6d0ff5b in QObject::event () from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb6d48fec in QWidget::event () from /usr/qt/3/lib/libqt-mt.so.3
#27 0xb6cb1f47 in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#28 0xb6cb2c99 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#29 0xb7342045 in KApplication::notify (this=0xbfff8480, receiver=0x81d7920, 
    event=0xbfff7ffc)
    at /ws/release-current/kdelibs-current/kdecore/kapplication.cpp:550
#30 0xb6c52f92 in QETWidget::translateMouseEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#31 0xb6c52867 in QApplication::x11ProcessEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#32 0xb6c62831 in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#33 0xb6cc85d0 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#34 0xb6cc8456 in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#35 0xb6cb19df in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#36 0x0806a498 in main (argc=137636192, argv=0x8310a40)
    at /ws/kooka-3.5/kooka-kde3/kooka/main.cpp:118
Comment 3 Jonathan Marten 2008-02-19 19:31:24 UTC
Possibly same backtrace as bug 66713.
Comment 4 Jonathan Marten 2008-05-17 13:40:21 UTC
SVN commit 808701 by marten:

Replaced the home-made thumbnail preview pane with a KDirOperator/KFileIconView
combination.  Eliminates some possible crashes (bugs 66713, 132701, 144074) related
to the ownership and destruction of KFileIconViewItem's (see the comments in
thumbview.cpp for more discussion).  Also simplifies the communication between
the scan packager and the previewer, since most file operations are noticed
automatically and the thumbnail view updated.

Implement a popup menu for the thumbnail view, with much the same operations
as the gallery tree - bug 69464

CCBUG:69464
CCBUG:66713
CCBUG:132701
CCBUG:144074


 M  +2 -2      kooka/Makefile.am  
 M  +7 -2      kooka/kooka.cpp  
 M  +60 -75    kooka/kookapref.cpp  
 M  +1 -5      kooka/kookapref.h  
 M  +65 -113   kooka/kookaview.cpp  
 M  +9 -7      kooka/kookaview.h  
 M  +75 -77    kooka/scanpackager.cpp  
 M  +6 -4      kooka/scanpackager.h  
 M  +220 -371  kooka/thumbview.cpp  
 M  +49 -100   kooka/thumbview.h  
 A             kooka/thumbviewdiroperator.cpp   [License: GPL (v2) (+Qt exception)]
 A             kooka/thumbviewdiroperator.h   [License: GPL (v2) (+Qt exception)]
 D             kooka/thumbviewitem.cpp  
 D             kooka/thumbviewitem.h  
 M  +1 -1      libkscan/kscancontrols.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=808701
Comment 5 Jonathan Marten 2008-05-17 13:49:00 UTC
Thumbnail gallery rewritten in SVN version to hopefully eliminate this crash.
Please test that from branches/work/kooka-kde3 if possible, see http://techbase.kde.org/Projects/Kooka for build instructions.
Comment 6 Justin Zobel 2020-12-03 21:39:02 UTC
Thank you for the report, Rodney.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 7 Bug Janitor Service 2020-12-18 04:34:40 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!