Bug 132362 - Support for BOTH "jpgComment" and "jpgUser comment" EXIF data
Summary: Support for BOTH "jpgComment" and "jpgUser comment" EXIF data
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Metadata-Exif (show other bugs)
Version: 0.8.2
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-14 00:18 UTC by Bjoern Aage Brandal
Modified: 2017-08-13 07:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 0.10.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bjoern Aage Brandal 2006-08-14 00:18:52 UTC
Version:           0.8.2 rc1 (using KDE KDE 3.5.2)
Installed from:    Ubuntu Packages

From what I can see the comments in digikam are stored in the EXIF data "jpgComment" wich is a limited field with respect to e.g. number of characters.

It would be very nice if the add comment function is divided into two fields, one for the (limited) jpgComment and one field for the jpgUsercomment (which does not have limitations for the text length). Then a short comment could be added to the jpgComment field (e.g to shortly describe the image for use in krename for renaming the files), and a larger more detailed description added in the "jpgUser comment" field (e.g. the story behind the image etc.)

For the slideshof it should then be configurable if the jpgComment field, the jpgUser comment field or both should be displayed.
Comment 1 Hubert Figuiere 2006-08-14 00:59:19 UTC
*** Bug 132363 has been marked as a duplicate of this bug. ***
Comment 2 caulier.gilles 2006-11-30 15:57:54 UTC
Bjoern,

Look on cyurrent svn implementation the new kipi-plugin MetadataEdit witch can edit separately "Exif User Comment" and "JFIF Comment". You can also sync these field whith the same content...

http://digikam3rdparty.free.fr/Screenshots/KipipluginBatchCommentsEditor.png
http://digikam3rdparty.free.fr/Screenshots/MetadataEditor/metadata_editor/exif01_png.png.html

Gilles Caulier
Comment 3 caulier.gilles 2007-10-02 09:22:09 UTC
Bjoern,

Also digiKam for KDE4 support Xmp metadata witch support multiple captions...

Gilles
Comment 4 caulier.gilles 2007-10-03 12:27:35 UTC
SVN commit 720609 by cgilles:

digiKam from trunk (KDE4) : XMP metadata management with database.

This is the first stage to control XMP metadata contents with Database contents and vis versa. This code handle XMP with current Database schema witch still the same than 0.9.x.

Marcel work currently on the new databse schema describe on the OpenOffice document available at this url :

http://websvn.kde.org/trunk/extragear/graphics/digikam/DBSCHEMA.ODS?view=log

The code will be adapted later by Marcel to handle more XMP tags according with this new schema.

This is the list of current changes :

- Preparing code to handle strings hosted in different languages (comments for example, dixit B.K.O #98462).
- Handle all Xmp.exif and Xmp.tiff tags has Exif metadata content to get photo informations set by camera.
- Do not set Iptc.Urgency tag with Rating value, but use standard Xmp.Rating tags instead. Import of Iptc.Urgency 
as Rating still running if Xmp metadata are not available. (B.K.O: 134206).
- Preparing code to handle Xmp strings set different authors(comments for example, dixit B.K.O #134476).
- Set the Tags name as Xmp.subject (keywords).
- Set the Copyright/Authors information in Xmp tags (schema inspired from Adobe Photoshop 7.0).
- Store Tags Path List into a dedicaced digiKam.org Xmp namespace as a sequence of strings. Do not use Iptc.Keywords for that. Import from Iptc still running if Xmp metadata is not available. This way is very important to restore properlly in database all tags assigned to an imported picture. There is not strings size limitation with Xmp and char encoding is always UTF-8. Nothing will be lost now.
- Xmp is always stored in pictures format witch support this metadata format : jpeg, png, and tiff.

All these changes require to update libkexiv2 and Exiv2 from trunk to compile and run digiKam properlly.

CCMAIL: digikam-devel@kde.org
CCMAIL: marcel.wiesweg@gmx.de

BUG: 134206
BUG: 149966

CCBUGS: 98462
CCBUGS: 132362
CCBUGS: 91811
CCBUGS: 134476
CCBUGS: 136260
CCBUGS: 146714




 M  +59 -44    digikam/metadatahub.cpp  
 M  +1 -1      libs/database/collectionscanner.cpp  
 M  +127 -71   libs/dmetadata/dmetadata.cpp  
 M  +5 -4      libs/dmetadata/dmetadata.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=720609
Comment 5 caulier.gilles 2008-12-05 19:06:52 UTC
This file is now fully implemented in digiKam 0.10.0

Gilles Caulier