Bug 131909 - The favicon on tabs reflects the contents of the location bar, not the contents of the render window.
Summary: The favicon on tabs reflects the contents of the location bar, not the conten...
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 139644 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-08-05 06:07 UTC by Stephan Sokolow
Modified: 2011-06-17 06:34 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.6.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Sokolow 2006-08-05 06:07:03 UTC
Version:           3.5.2 (using KDE 3.5.2, Gentoo)
Compiler:          gcc version 3.4.5 (Gentoo 3.4.5-r1, ssp-3.4.5-1.0, pie-8.7.9)
OS:                Linux (i686) release 2.6.16-gentoo-r9-20060701

The favicon on tabs reflects the contents of the location bar, not the contents of the render window.

This means that, if I empty the location bar and then switch to a different tab, the tab I just switched from will suddenly gain the default KDE folder icon, despite it's render pane not having changed.
Comment 1 lexual 2006-08-08 14:41:07 UTC
confirming for 3.5.4
Comment 2 Michael Leupold 2008-05-18 15:50:43 UTC
Confirmed for 3.5.9 and trunk r809039.
Comment 3 Frank Reininghaus 2008-09-13 00:41:25 UTC
*** Bug 139644 has been marked as a duplicate of this bug. ***
Comment 4 Burkhard Lück 2011-05-16 21:06:59 UTC
confirming for 4.6.2
Comment 5 Dawit Alemayehu 2011-06-17 06:33:53 UTC
Git commit 831d3d151f517e41c87bd1c6f8338cec225959ea by Dawit Alemayehu.
Committed on 11/06/2011 at 08:31.
Pushed by adawit into branch 'KDE/4.6'.

Do not change the tab icon if the supplied url is invalid, e.g blank.

BUG: 131909
FIXED-IN: 4.6.5
REVIEW: 101626

M  +1    -1    konqueror/src/konqview.cpp     

http://commits.kde.org/kde-baseapps/831d3d151f517e41c87bd1c6f8338cec225959ea
Comment 6 Dawit Alemayehu 2011-06-17 06:34:23 UTC
Git commit 56299fa980c40096ce30a850ded19f75155db70c by Dawit Alemayehu.
Committed on 11/06/2011 at 08:31.
Pushed by adawit into branch 'master'.

Do not change the tab icon if the supplied url is invalid, e.g blank.

BUG: 131909
FIXED-IN: 4.6.5
REVIEW: 101626

(cherry picked from commit 831d3d151f517e41c87bd1c6f8338cec225959ea)

M  +1    -1    konqueror/src/konqview.cpp     

http://commits.kde.org/kde-baseapps/56299fa980c40096ce30a850ded19f75155db70c