Bug 131866 - Using valgrind to debug umbrello
Summary: Using valgrind to debug umbrello
Status: RESOLVED DUPLICATE of bug 84739
Alias: None
Product: umbrello
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-04 16:16 UTC by kaplun
Modified: 2006-08-05 11:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Valgrind output just for opening and closing umbrello (69.26 KB, text/plain)
2006-08-04 16:18 UTC, kaplun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaplun 2006-08-04 16:16:21 UTC
Version:           1.5.3 (using KDE 3.5.4, Gentoo)
Compiler:          Target: x86_64-pc-linux-gnu
OS:                Linux (x86_64) release 2.6.17-beyond2.2

Hi,
I'd like to be an Umbrello poweruser since I sometimes need UML for my daily job. But I must admit it's unusable! It crashes every 10 clic! I suggest you to use valgrind to discover how many problems are in its code. 
Sorry being a bit rude. But 4 crashes in half an hour is too much :-)
Comment 1 kaplun 2006-08-04 16:18:32 UTC
Created attachment 17226 [details]
Valgrind output just for opening and closing umbrello
Comment 2 Oliver Kellogg 2006-08-04 22:32:51 UTC
AFAICT your valgrind log does not show anything directly attributable to
the Umbrello source code (look more like problems in X and/or Qt.)
I suspect you have enabled "Use new C++/Java/Ruby code generators"
in the Umbrello general settings? Then this is a duplicate of #84739.
Please update to umbrello-1.5.4 where this feature is disabled.
Comment 3 Oliver Kellogg 2006-08-05 11:04:37 UTC

*** This bug has been marked as a duplicate of 84739 ***