Bug 129648 - Add new option to show Exif tags in html gallery
Summary: Add new option to show Exif tags in html gallery
Status: REPORTED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Generic-HTMLGallery (show other bugs)
Version: 5.5.0
Platform: Ubuntu Packages Linux
: NOR wishlist with 30 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-22 16:00 UTC by Michael
Modified: 2019-12-25 06:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2006-06-22 16:00:00 UTC
Version:           0.8.2-rc1 (using KDE KDE 3.5.3)
Installed from:    Ubuntu Packages
OS:                Linux

It would be inice, if there could be exif tags exported to the html pages, like iso settings. Currently, only date, size and dimensions of a photo are possible.
Comment 1 caulier.gilles 2011-12-22 15:30:31 UTC
Michael,

This file still valid using kipi-plugins 2.4 ?

Gilles Caulier
Comment 2 Bob 2019-11-25 15:20:04 UTC
As of digiKam 6.4.0 the HTML gallery plugin does write the following Exif data within the gallery.xml file made available to each theme:

<exif>
	<exifimagemake>Canon</exifimagemake>
	<exifimagemodel>Canon EOS R</exifimagemodel>
	<exifimageorientation>top, left</exifimageorientation>
	<exifimagexresolution>350</exifimagexresolution>
	<exifimageyresolution>350</exifimageyresolution>
	<exifimageresolutionunit>inch</exifimageresolutionunit>
	<exifimagedatetime>28/09/2019 12:59</exifimagedatetime>
	<exifimageycbcrpositioning>Centered</exifimageycbcrpositioning>
	<exifphotoexposuretime>1/80 s</exifphotoexposuretime>
	<exifphotofnumber>F4</exifphotofnumber>
	<exifphotoexposureprogram>unavailable</exifphotoexposureprogram>
	<exifphotoisospeedratings>160</exifphotoisospeedratings>
	<exifphotoshutterspeedvalue>1/83 s</exifphotoshutterspeedvalue>
	<exifphotoaperturevalue>F4</exifphotoaperturevalue>
	<exifphotofocallength>19.0 mm</exifphotofocallength>
	<exifgpslatitude>51.360615</exifgpslatitude>
	<exifgpslongitude>-0.215532</exifgpslongitude>
	<exifgpsaltitude>71.300</exifgpsaltitude>
</exif>

(Note that where any piece of data is not defined for a particular image, the value `unavailable` will be shown within the corresponding XML element.)

Does this resolve your request?
Comment 3 Bug Janitor Service 2019-12-10 04:33:08 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2019-12-25 04:33:08 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!