Bug 129534 - Media kicker applet doesn't display icons on KDE startup; needs activity, then it works
Summary: Media kicker applet doesn't display icons on KDE startup; needs activity, the...
Status: RESOLVED FIXED
Alias: None
Product: kicker
Classification: Plasma
Component: mediaapplet (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
: 129573 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-06-21 02:43 UTC by Christopher Martin
Modified: 2006-07-10 20:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Martin 2006-06-21 02:43:32 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          GCC 4.1.x 
OS:                Linux

Since 3.5.3 or thereabouts in SVN, the kicker media applet has had an annoying glitch where it doesn't diplay the icons of inserted discs, etc. when you start a KDE session. The icons do appear on the desktop, so the whole media system is working, just not on the kicker.

When some media-related activity occurs (inserting/ejecting/mounting etc.) then all of a sudden the kicker applet starts to work properly, and all the disc icons you would expect suddenly appear on the kicker.

Running the latest kdebase SVN (with the newly merged branch) makes no difference.

Hopefully this can get fixed up for 3.5.4.

Thanks,
Christopher Martin
Comment 1 Christopher Martin 2006-06-21 03:08:06 UTC
Actually, I lied. It's even wierder.

If I enable icons on the desktop, and restart KDE, sometimes I get a DVD icon on the kicker, but NOT on the desktop.

If however, I turn off icons on the desktop, restart KDE, I get no DVD icon on the kicker, as before. If I then go into the Control Center and turn desktop icons ON, I get a DVD icon on the desktop (but the kicker one is still missing until there is some activity). So there's some sort glitch lurking, but it's not as simple as I thought.

A bit random, it seems, where the icon shows up - but once there is activity, then it always is fixed and appears everywhere it should.
Comment 2 Thiago Macieira 2006-06-28 19:26:51 UTC
I can confirm this. r548000 exhibits this problem.
Comment 3 Thiago Macieira 2006-06-28 19:39:53 UTC
*** Bug 129573 has been marked as a duplicate of this bug. ***
Comment 4 Lubos Lunak 2006-07-10 20:00:14 UTC
SVN commit 560584 by lunakl:

Load mediamanager kded module soon in the startup. It used
to do notification about new media after startup, but that was
removed (r468233) even before the startup reorder because it was
a noticeable part of the startup time for some reason. The module
should be loaded soon anyway because media icons can be shown
on the desktop.
BUG: 127971
BUG: 129534



 M  +1 -0      mediamanager.desktop  


--- branches/KDE/3.5/kdebase/kioslave/media/mediamanager/mediamanager.desktop #560583:560584
@@ -120,3 +120,4 @@
 X-KDE-FactoryName=mediamanager
 X-KDE-Kded-autoload=true
 X-KDE-Kded-load-on-demand=true
+X-KDE-Kded-phase=1