Bug 129187 - crash when modifying address bar address
Summary: crash when modifying address bar address
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 123318 130056 130062 130090 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-06-15 13:26 UTC by Raúl
Modified: 2006-07-01 05:40 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl 2006-06-15 13:26:05 UTC
Version:           3.5.2 (using KDE 3.5.3, Debian Package 4:3.5.3-1 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.16-p4s

I was browsing a site and used the trnaslate page tool. So I had a babelfish translated site. I tried to modify the address in order to go to the original web, when I pressed enter I had this backtrace:

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1501067040 (LWP 32600)]
[KCrash handler]
#6  0xa71f3268 in qt_inheritedBy (superClass=0x82df4c8, object=0x8d82e60)
    at kernel/qobject.cpp:596
#7  0xa61b10d6 in qt_cast<KHTMLPart*> ()
   from /usr/lib/kde3/libsearchbarplugin.so
#8  0xa5fbedf5 in KJS::Window::retrieve (p=0x8d82e60) at kjs_window.cpp:384
#9  0xa5fc0ddc in KJS::Window::retrieveWindow (p=0x1) at kjs_window.cpp:354
#10 0xa5e7cb18 in KHTMLPart::begin (this=0x9215428, url=@0xafc15314, 
    xOffset=1, yOffset=1) at khtml_part.cpp:1880
#11 0xa5e7a327 in KHTMLPart::htmlError (this=0x9215428, errorCode=1, 
    text=@0x1, reqUrl=@0x8cd0ef8) at khtml_part.cpp:1724
#12 0xa5e7ac6b in KHTMLPart::openURL (this=0x9215428, url=@0xafc158a0)
    at khtml_part.cpp:599
#13 0xa668378b in KonqView::openURL (this=0x9486bb8, url=@0xafc158a0, 
    locationBarURL=@0xafc1592c, nameFilter=@0x1, tempFile=false)
    at konq_view.cc:223
#14 0xa66a47a9 in KonqMainWindow::openView (this=0x80de598, 
    serviceType=@0xafc159f4, _url=@0xa04ee28, childView=0x9486bb8, 
    req=@0xa04eee4) at konq_mainwindow.cc:888
#15 0xa66b90da in KonqRun::foundMimeType (this=0xa04ee00, _type=@0x1)
    at konq_run.cc:91
#16 0xa7eda7a7 in KParts::BrowserRun::redirectToError (this=0xa04ee00, 
    error=1, errorText=@0x1) at browserrun.cpp:483
#17 0xa7eda85a in KParts::BrowserRun::handleError (this=0xa04ee00, 
    job=0x8d82e60) at browserrun.cpp:453
#18 0xa666bbb0 in KonqRun::handleError (this=0xa04ee00, job=0x9e05b18)
    at konq_run.cc:143
#19 0xa7ed8698 in KParts::BrowserRun::slotBrowserScanFinished (
    this=0xa04ee00, job=0x8d82e60) at browserrun.cpp:173
#20 0xa7ed8a4e in KParts::BrowserRun::qt_invoke (this=0xa04ee00, _id=6, 
    _o=0xafc15c34) at browserrun.moc:101
#21 0xa666bf68 in KonqRun::qt_invoke (this=0xa04ee00, _id=6, _o=0xafc15c34)
    at konq_run.moc:88
#22 0xa71f754b in QObject::activate_signal (this=0x9e05b18, clist=0x9ce50b8, 
    o=0xafc15c34) at kernel/qobject.cpp:2356
#23 0xa7a357e2 in KIO::Job::result (this=0x9e05b18, t0=0x1)
    at jobclasses.moc:162
#24 0xa7a8983c in KIO::Job::emitResult (this=0x9e05b18) at job.cpp:226
#25 0xa7a899ae in KIO::SimpleJob::slotFinished (this=0x9e05b18) at job.cpp:574
#26 0xa7a8a0ed in KIO::TransferJob::slotFinished (this=0x9e05b18)
    at job.cpp:944
#27 0xa7a50de3 in KIO::SimpleJob::slotError (this=0x9e05b18, error=1, 
    errorText=@0x1) at job.cpp:585
#28 0xa7a8b5c3 in KIO::SimpleJob::qt_invoke (this=0x9e05b18, _id=14, 
    _o=0xafc15fe0) at jobclasses.moc:424
#29 0xa7a8b6e3 in KIO::TransferJob::qt_invoke (this=0x9e05b18, _id=14, 
    _o=0xafc15fe0) at jobclasses.moc:1082
#30 0xa71f754b in QObject::activate_signal (this=0x9c3c5a0, clist=0x9b96898, 
    o=0xafc15fe0) at kernel/qobject.cpp:2356
#31 0xa7a3479f in KIO::SlaveInterface::error (this=0x9c3c5a0, t0=1, t1=@0x1)
    at slaveinterface.moc:214
#32 0xa7aa14a0 in KIO::SlaveInterface::dispatch (this=0x9c3c5a0, _cmd=102, 
    rawdata=@0xafc161f0) at slaveinterface.cpp:280
#33 0xa7a48c87 in KIO::SlaveInterface::dispatch (this=0x9c3c5a0)
    at slaveinterface.cpp:173
#34 0xa7a4db9b in KIO::Slave::gotInput (this=0x9c3c5a0) at slave.cpp:300
#35 0xa7a4dd4b in KIO::Slave::qt_invoke (this=0x9c3c5a0, _id=4, _o=0xafc16318)
    at slave.moc:113
#36 0xa71f754b in QObject::activate_signal (this=0x9b1d550, clist=0x9c3c7b8, 
    o=0xafc16318) at kernel/qobject.cpp:2356
#37 0xa71f7e52 in QObject::activate_signal (this=0x9b1d550, signal=2, 
    param=19) at kernel/qobject.cpp:2449
#38 0xa7589f7f in QSocketNotifier::activated (this=0x9b1d550, t0=19)
    at .moc/debug-shared-mt/moc_qsocketnotifier.cpp:85
#39 0xa721780a in QSocketNotifier::event (this=0x9b1d550, e=0xafc16670)
    at kernel/qsocketnotifier.cpp:258
#40 0xa718d87a in QApplication::internalNotify (this=0xafc169bc, 
    receiver=0x9b1d550, e=0xafc16670) at kernel/qapplication.cpp:2635
#41 0xa718da76 in QApplication::notify (this=0xafc169bc, receiver=0x9b1d550, 
    e=0xafc16670) at kernel/qapplication.cpp:2358
#42 0xa786424e in KApplication::notify (this=0xafc169bc, receiver=0x9b1d550, 
    event=0xafc16670) at kapplication.cpp:550
#43 0xa711f001 in QApplication::sendEvent (receiver=0x9b1d550, 
    event=0xafc16670) at qapplication.h:520
#44 0xa717f435 in QEventLoop::activateSocketNotifiers (this=0x80b5010)
    at kernel/qeventloop_unix.cpp:578
#45 0xa7132d06 in QEventLoop::processEvents (this=0x80b5010, flags=4)
    at kernel/qeventloop_x11.cpp:383
#46 0xa71a6255 in QEventLoop::enterLoop (this=0x80b5010)
    at kernel/qeventloop.cpp:198
#47 0xa71a617a in QEventLoop::exec (this=0x80b5010)
    at kernel/qeventloop.cpp:145
#48 0xa718c38d in QApplication::exec (this=0xafc169bc)
    at kernel/qapplication.cpp:2758
#49 0xa66b617c in kdemain (argc=1, argv=0x1) at konq_main.cc:206
#50 0xa7ef8524 in kdeinitmain (argc=1, argv=0x1) at konqueror_dummy.cc:3
#51 0x0804e216 in launch (argc=2, _name=0x8098ee4 "konqueror", 
    args=0x8098ef7 "\001", cwd=0x0, envc=1, envs=0x8098f08 "", 
    reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x1 <Address 0x1 out of bounds>) at kinit.cpp:639
#52 0x0804e966 in handle_launcher_request (sock=8) at kinit.cpp:1206
#53 0x0804ee23 in handle_requests (waitForPid=0) at kinit.cpp:1407
#54 0x0804ffd2 in main (argc=2, argv=0xafc174d4, envp=0x1) at kinit.cpp:1863
#55 0xa7c6deb0 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#56 0x0804b8a1 in _start () at ../sysdeps/i386/elf/start.S:119
Comment 1 Raúl 2006-06-15 13:26:46 UTC
I'm usign all the javascript debug/console option, just in case.
Comment 2 Tommi Tervo 2006-06-15 13:49:37 UTC
Backtrace is similar to closed and fixed bug :-/
http://bugs.kde.org/show_bug.cgi?id=112905
Comment 3 Raúl 2006-06-15 17:55:12 UTC
In that case I wonder why is still present, look at my versions, they are quite new and this bug is supposed to be solved 6+ months ago.
Comment 4 rene B 2006-06-25 19:09:31 UTC
Quit often I type the website url directly in the addressbar. Since KDE 351 and 353 (did not try 352), once in while konqueror crashes. More specific:
- I can type www.
- The first letter of the url should show the urls that are available in the address bar / dropdown list. However, when typing the first letter, konquerer crashes.
- work around is F9, clear history.

GDB trace:
(no debugging symbols found)
Using host libthread_db library "/lib/i686/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1231501104 (LWP 11347)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xbfffe410 in __kernel_vsyscall ()
#7  0xb7014fa1 in raise () from /lib/i686/libc.so.6
#8  0xb7016868 in abort () from /lib/i686/libc.so.6
#9  0xb704a62b in __fsetlocking () from /lib/i686/libc.so.6
#10 0xb70504a5 in malloc_usable_size () from /lib/i686/libc.so.6
#11 0xb70525db in mallopt () from /lib/i686/libc.so.6
#12 0xb7054075 in malloc () from /lib/i686/libc.so.6
#13 0xb6a944ae in XftFontOpenInfo () from /usr/X11R6/lib/libXft.so.2
#14 0xb6a954fa in XftFontOpenPattern () from /usr/X11R6/lib/libXft.so.2
#15 0xb7502c4e in QFontDatabase::styleString ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb7508f19 in QFontDatabase::findFont ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb7495252 in QFontPrivate::load () from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb75c40a1 in QTextEngine::shape () from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb75c2671 in QTextLayout::currentItem ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb75438f2 in qt_format_text () from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb7545740 in QPainter::drawText () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb6842ea0 in KonqComboListBoxPixmap::paint ()
   from /usr/lib/libkdeinit_konqueror.so
#23 0xb7607ab9 in QListBox::paintCell () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb7604d69 in QListBox::viewportPaintEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb7642bfc in QScrollView::eventFilter ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb7600aa3 in QListBox::eventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb6f09278 in KCompletionBox::eventFilter () from /usr/lib/libkdeui.so.4
#28 0xb74e2137 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb74e283a in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb7ae7f0e in KApplication::notify () from /usr/lib/libkdecore.so.4
#31 0xb747a45f in QETWidget::translatePaintEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0xb74811b9 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb74937a6 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb74f6b71 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb74f6a94 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb74e190f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb6808a3c in kdemain () from /usr/lib/libkdeinit_konqueror.so
#38 0xb7f23534 in kdeinitmain () from /usr/lib/kde3/konqueror.so
#39 0x0804e120 in ?? ()
#40 0x00000003 in ?? ()
#41 0x0805b458 in ?? ()
#42 0x00000001 in ?? ()
#43 0x00000000 in ?? ()
Comment 5 Maksim Orlovich 2006-06-29 23:38:36 UTC
comment #4 is unrelated, please file a separate bug report, though this doesn't really have enough information to work with, anyway
Comment 6 Maksim Orlovich 2006-06-29 23:52:28 UTC
*** Bug 123318 has been marked as a duplicate of this bug. ***
Comment 7 Maksim Orlovich 2006-06-30 01:21:55 UTC
SVN commit 556326 by orlovich:

Make this show-popups-thingie a bit less of a DanglingPointerTown.
Fixes crashes on browsing away from cnn.com, other sites.
BUG:129187


 M  +18 -11    khtml_part.cpp  
 M  +1 -1      khtmlpart_p.h  


--- branches/KDE/3.5/kdelibs/khtml/khtml_part.cpp #556325:556326
@@ -1876,10 +1876,14 @@
     removeJSErrorExtension();
     setSuppressedPopupIndicator( false );
     d->m_openableSuppressedPopups = 0;
-    for ( KHTMLPart* part = d->m_suppressedPopupOriginParts.first(); part; part = d->m_suppressedPopupOriginParts.next() ) {
-       KJS::Window *w = KJS::Window::retrieveWindow( part );
-       if (w)
-           w->forgetSuppressedWindows();
+    for ( QValueListIterator<QGuardedPtr<KHTMLPart> > i = d->m_suppressedPopupOriginParts.begin();
+          i != d->m_suppressedPopupOriginParts.end(); ++i ) {
+       
+      if (KHTMLPart* part = *i) {
+        KJS::Window *w = KJS::Window::retrieveWindow( part );
+        if (w)
+          w->forgetSuppressedWindows();
+      }
     }
   }
 
@@ -7360,7 +7364,7 @@
 
     if ( enable && originPart ) {
         d->m_openableSuppressedPopups++;
-        if ( d->m_suppressedPopupOriginParts.find( originPart ) == -1 )
+        if ( d->m_suppressedPopupOriginParts.findIndex( originPart ) == -1 )
             d->m_suppressedPopupOriginParts.append( originPart );
     }
 
@@ -7405,12 +7409,15 @@
 }
 
 void KHTMLPart::showSuppressedPopups() {
-    for ( KHTMLPart* part = d->m_suppressedPopupOriginParts.first(); part; part = d->m_suppressedPopupOriginParts.next() ) {
-       KJS::Window *w = KJS::Window::retrieveWindow( part );
-       if (w) {
-           w->showSuppressedWindows();
-           w->forgetSuppressedWindows();
-       }
+    for ( QValueListIterator<QGuardedPtr<KHTMLPart> > i = d->m_suppressedPopupOriginParts.begin();
+          i != d->m_suppressedPopupOriginParts.end(); ++i ) {
+      if (KHTMLPart* part = *i) {
+        KJS::Window *w = KJS::Window::retrieveWindow( part );
+        if (w) {
+            w->showSuppressedWindows();
+            w->forgetSuppressedWindows();
+        }
+      }
     }
     setSuppressedPopupIndicator( false );
     d->m_openableSuppressedPopups = 0;
--- branches/KDE/3.5/kdelibs/khtml/khtmlpart_p.h #556325:556326
@@ -316,7 +316,7 @@
   KURLLabel* m_statusBarUALabel;
   KURLLabel* m_statusBarJSErrorLabel;
   KURLLabel* m_statusBarPopupLabel;
-  QPtrList<KHTMLPart> m_suppressedPopupOriginParts;
+  QValueList<QGuardedPtr<KHTMLPart> > m_suppressedPopupOriginParts;
   int m_openableSuppressedPopups;
   DOM::DocumentImpl *m_doc;
   khtml::Decoder *m_decoder;
Comment 8 George Staikos 2006-06-30 04:39:49 UTC
*** Bug 130056 has been marked as a duplicate of this bug. ***
Comment 9 Tommi Tervo 2006-06-30 11:25:25 UTC
*** Bug 130062 has been marked as a duplicate of this bug. ***
Comment 10 Maksim Orlovich 2006-07-01 05:40:24 UTC
*** Bug 130090 has been marked as a duplicate of this bug. ***