Bug 129028 - IMAP Message view shows empty list when selected email is deleted or moved outside of KMail
Summary: IMAP Message view shows empty list when selected email is deleted or moved ou...
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-12 10:43 UTC by Arne Schmitz
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arne Schmitz 2006-06-12 10:43:11 UTC
Version:           1.9.1 (using KDE 3.5.2, Debian Package 4:3.5.2-2 (testing/unstable))
Compiler:          Target: x86_64-linux-gnu
OS:                Linux (x86_64) release 2.6.12-1-amd64-k8

Consider the following: On an IMAP account select a message to view it. You realize that it is SPAM. You log onto the Webfrontend of your email provider. Then you mark the offending mail as SPAM. Thus it will be moved to the SPAM folder by the Webmail frontend. The next time KMail updates its IMAP information, the message will be correctly moved. But KMail will show an empty / broken message list view. This is corrected, when switching to some top level folder (like "local folders").
Comment 1 Carsten Burghardt 2006-06-16 19:18:53 UTC
SVN commit 552126 by burghard:

There was an open missing which lead to the famous chain of horror: the parent
folder was not open so the job opened it, the messagelist was
regenerated, the message became invalid, yada yada.
BUGS: 129028


 M  +1 -0      kmfolderimap.cpp  


--- branches/KDE/3.5/kdepim/kmail/kmfolderimap.cpp #552125:552126
@@ -1450,6 +1450,7 @@
       if ( ok && exists < count() ) {
         kdDebug(5006) << "KMFolderImap::slotGetMessagesData - server has less messages (" <<
           exists << ") then folder (" << count() << "), so reload" << endl;
+        open();
         reallyGetFolder( QString::null );
         (*it).cdata.remove(0, pos);
         return;
Comment 2 Michael Seiwert 2006-06-22 11:04:50 UTC
Could this "chain of horror" also be the cause of BUG: 126715 ? I ask because I didn't get any crashes since updating after you fixed this bug.