Bug 128760 - [regression] Mistake in picture placing on page
Summary: [regression] Mistake in picture placing on page
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml renderer (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 130066 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-06-07 16:54 UTC by Martin Reichel
Modified: 2006-07-02 14:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
minimal test case (355 bytes, text/html)
2006-06-30 21:19 UTC, Germain Garand
Details
patch (528 bytes, patch)
2006-06-30 21:48 UTC, Germain Garand
Details
shows rendering problem (208.16 KB, image/png)
2006-07-02 08:56 UTC, Ferdinand Gassauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Reichel 2006-06-07 16:54:19 UTC
Version:           3.5.1 (using KDE 3.5.1 Level "a" , SUSE 10.1)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.16.13-4-default

On this page http://www.pmo.cz/portal/sap/cz/ is map with station state. In Konqueror is map incorect place on right side from dots which are represeting stations. In Firefox is this OK.
Comment 1 Tommi Tervo 2006-06-30 13:25:39 UTC
*** Bug 130066 has been marked as a duplicate of this bug. ***
Comment 2 Germain Garand 2006-06-30 17:26:08 UTC
3.5.x regression.
Comment 3 Germain Garand 2006-06-30 21:19:14 UTC
Created attachment 16836 [details]
minimal test case

whitespace (that should be discarded) issue.
Interestingly, it only happens with absolutely positioned blocks having both
non-static x and y..
Comment 4 Germain Garand 2006-06-30 21:48:17 UTC
Created attachment 16838 [details]
patch

WebCore has this bit, and it looks all fine to me..
Comment 5 Ferdinand Gassauer 2006-07-02 01:17:02 UTC
similar problem here ?
http://wiki.gnutelephony.org/index.php/Main_Page
Comment 6 Germain Garand 2006-07-02 03:42:27 UTC
re #5: no obviously not. 
your url is rendered just as designed. cf. http://wiki.gnutelephony.org//skins/monobook/KHTMLFixes.css
probably intended to work around some prehistoric bug.
Comment 7 Ferdinand Gassauer 2006-07-02 08:56:22 UTC
Created attachment 16850 [details]
shows rendering problem

firefox handles this  page well , konqueror not.
Comment 8 Germain Garand 2006-07-02 12:37:22 UTC
re #7: Ferdinand, please read carefully the messages.
I told you the site intentionally breaks its rendering for khtml-based engines based on JavaScript sniffing. Just have them remove the bogus "KHTMLFixes.css" css file.
Comment 9 Germain Garand 2006-07-02 14:06:22 UTC
SVN commit 557104 by ggarand:

skip out of flow objects when looking for a significant previous renderer
in rendererIsNeeded.

BUG:128760



 M  +2 -0      dom_textimpl.cpp  


--- branches/KDE/3.5/kdelibs/khtml/xml/dom_textimpl.cpp #557103:557104
@@ -389,6 +389,8 @@
         }
 
         RenderObject *first = par->firstChild();
+        while (first && first->isFloatingOrPositioned())
+            first = first->nextSibling();
         RenderObject *next = nextRenderer();
         if (!first || next == first) {
             // Whitespace at the start of a block just goes away.  Don't even