Bug 126356 - CD problems on my ibm/lenovo thinkpad r52 laptop
Summary: CD problems on my ibm/lenovo thinkpad r52 laptop
Status: RESOLVED FIXED
Alias: None
Product: k3b
Classification: Applications
Component: Burning/Hardware (show other bugs)
Version: 0.12.x
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-27 15:49 UTC by Robert Derochette
Modified: 2007-10-12 17:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Derochette 2006-04-27 15:49:09 UTC
Version:           0.12.15 (using KDE 3.5.2, Debian Package 4:3.5.2-2+b1 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.16-thinkpad

Hello,

I am not able to burn anything on a cd using k3b with my IBM/Lenovo thinkpad r52 laptop. I'm using linux 2.6.16. The CD Writer is detected correctly as I can emtpy ReWritable CDs. When burning starts, I get (the message is in french so I'm translating but it might no be the exact wording in the english version) : "Input/output error (not important error)" displayed twice. Then burning fails. Here's the debugging output of cdrecord :

System
-----------------------
K3b Version: 0.12.15

KDE Version: 3.5.2
QT Version:  3.3.6
Kernel:      2.6.16-thinkpad
Devices
-----------------------
HL-DT-ST DVDRAM GSA-4080N 0X21 (/dev/scd0, /dev/sg1) at /media/cdrom0 [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-RAM; DVD-R; DVD-RW; DVD+R; DVD+RW] [DVD-ROM; DVD-R séquentiel; DVD-RAM; DVD RW à réinscription limitée; DVD-RW séquentiel; DVD+RW; DVD+R; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R; Réinscription restreinte]

K3b
-----------------------
Size of filesystem calculated: 181

Used versions
-----------------------
cdrecord: 2.1.1a03

cdrecord
-----------------------
/usr/bin/cdrecord: Warning: Running on Linux-2.6.16-thinkpad
/usr/bin/cdrecord: There are unsettled issues with Linux-2.5 and newer.
/usr/bin/cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
scsidev: '1,0,0'
scsibus: 1 target: 0 lun: 0
Linux sg driver version: 3.5.33
/usr/bin/cdrecord: Warning: using inofficial version of libscg (debian-0.8debian2 '@(#)scsitransp.c 1.91 04/06/17 Copyright 1988,1995,2000-2004 J. Schilling').
SCSI buffer size: 64512
/usr/bin/cdrecord: This version of cdrecord does not include DVD-R/DVD-RW support code.
/usr/bin/cdrecord: See /usr/share/doc/cdrecord/README.DVD.Debian for details on DVD support.
Cdrecord-Clone 2.01.01a03 (i686-pc-linux-gnu) Copyright (C) 1995-2005 Joerg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <cdrtools@packages.debian.org>.
      The original author should not be bothered with problems of this version.
TOC Type: 3 = CD-ROM XA mode 2
Waiting for data on stdin...
Using libscg version 'debian-0.8debian2'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   : 
Vendor_info    : 'HL-DT-ST'
Identifikation : 'DVDRAM GSA-4080N'
Revision       : '0X21'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x000A
Profile: 0x0012 
Profile: 0x0011 
Profile: 0x0014 
Profile: 0x0013 
Profile: 0x001A 
Profile: 0x001B 
Profile: 0x0010 
Profile: 0x0009 
Profile: 0x000A (current)
Profile: 0x0008 (current)
Profile: 0x0002 
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE 
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1053696 = 1029 KB
Drive DMA Speed: 11418 kB/s 64x CD 8x DVD
FIFO size      : 4194304 = 4096 KB
Track 01: data     0 MB         padsize:  238 KB
Total size:        0 MB (00:04.02) = 302 sectors
Lout start:        1 MB (00:06/02) = 302 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 2
  Reference speed: 6
  Is not unrestricted
  Is erasable
  Disk sub type: High speed Rewritable (CAV) media (1)
  ATIP start of lead in:  -12900 (97:10/00)
  ATIP start of lead out: 359849 (79:59/74)
  1T speed low:  4 1T speed high: 10
  2T speed low:  4 2T speed high:  0 (reserved val  6)
  power mult factor: 1 5
  recommended erase/write power: 5
  A1 values: 24 1A D8
  A2 values: 26 B2 48
Disk type:    unknown dye (reserved id code)
Manuf. index: -1
Manufacturer: unknown (not in table)
Manufacturer is unknown because of the orange forum embargo.
As the orange forum likes to get money for recent information,
it may be that this media does not use illegal manufacturer coding.
Blocks total: 359849 Blocks current: 340949 Blocks remaining: 340647
Starting to write CD/DVD at speed 10 in real TAO mode for multi session.
Last chance to quit, starting real write in 3 seconds.
   2 seconds.
   1 seconds.
   0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is ON.
Performing OPC...
Starting new track at sector: 18900
Track 03:    0 of    0 MB written.
/usr/bin/cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 4A 6F 00 00 1A 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 10 2A 30 06 90 21 02 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x21 Qual 0x02 (invalid address for write) Fru 0x0
Sense flags: Blk 0 (not valid) 
resid: 53248
cmd finished after 0.016s timeout 40s
/usr/bin/cdrecord: The current problem looks like a buffer underrun.
/usr/bin/cdrecord: It looks like 'driveropts=burnfree' does not work for this drive.
/usr/bin/cdrecord: Please report.
/usr/bin/cdrecord: Make sure that you are root, enable DMA and check your HW/OS set up.
write track data: error after 317440 bytes
Writing  time:   16.828s
Average write speed   0.2x.
Fixating...
Fixating time:   22.871s
/usr/bin/cdrecord: fifo had 6 puts and 6 gets.
/usr/bin/cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.

cdrecord command:
-----------------------
/usr/bin/cdrecord.mmap -v gracetime=2 dev=1,0,0 speed=10 -tao driveropts=burnfree -eject -multi -waiti -xa -tsize=181s - 

mkisofs
-----------------------
Rock Ridge signatures found
Rock Ridge signatures found
181
Rock Ridge signatures found
Total translation table size: 0
Total rockridge attributes bytes: 252
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
19081 extents written (37 MB)

mkisofs command:
-----------------------
/usr/bin/mkisofs -cdrecord-params 11700,18900 -prev-session /dev/scd0 -gui -graft-points -volid K3b data project -volset  -appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-robert/k3b8oORmc.tmp -rational-rock -hide-list /tmp/kde-robert/k3bAAoOob.tmp -joliet -hide-joliet-list /tmp/kde-robert/k3bYAo6ic.tmp -full-iso9660-filenames -iso-level 2 -path-list /tmp/kde-robert/k3bs1FUKb.tmp 

msinfo
-----------------------
11700,18900

msinfo command:
-----------------------
/usr/bin/cdrecord.mmap dev=1,0,0 -msinfo 




Reading this error log suggested me to turn burnfree off. That's what I did, then I got the same problem, and cdrecord output is now as follows :

System
-----------------------
K3b Version: 0.12.15

KDE Version: 3.5.2
QT Version:  3.3.6
Kernel:      2.6.16-thinkpad
Devices
-----------------------
HL-DT-ST DVDRAM GSA-4080N 0X21 (/dev/scd0, /dev/sg1) at /media/cdrom0 [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-RAM; DVD-R; DVD-RW; DVD+R; DVD+RW] [DVD-ROM; DVD-R séquentiel; DVD-RAM; DVD RW à réinscription limitée; DVD-RW séquentiel; DVD+RW; DVD+R; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R; Réinscription restreinte]

K3b
-----------------------
Size of filesystem calculated: 181

Used versions
-----------------------
cdrecord: 2.1.1a03

cdrecord
-----------------------
/usr/bin/cdrecord: Warning: Running on Linux-2.6.16-thinkpad
/usr/bin/cdrecord: There are unsettled issues with Linux-2.5 and newer.
/usr/bin/cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
scsidev: '1,0,0'
scsibus: 1 target: 0 lun: 0
Linux sg driver version: 3.5.33
/usr/bin/cdrecord: Warning: using inofficial version of libscg (debian-0.8debian2 '@(#)scsitransp.c 1.91 04/06/17 Copyright 1988,1995,2000-2004 J. Schilling').
SCSI buffer size: 64512
/usr/bin/cdrecord: This version of cdrecord does not include DVD-R/DVD-RW support code.
/usr/bin/cdrecord: See /usr/share/doc/cdrecord/README.DVD.Debian for details on DVD support.
Cdrecord-Clone 2.01.01a03 (i686-pc-linux-gnu) Copyright (C) 1995-2005 Joerg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <cdrtools@packages.debian.org>.
      The original author should not be bothered with problems of this version.
TOC Type: 3 = CD-ROM XA mode 2
Waiting for data on stdin...
Using libscg version 'debian-0.8debian2'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   : 
Vendor_info    : 'HL-DT-ST'
Identifikation : 'DVDRAM GSA-4080N'
Revision       : '0X21'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x000A
Profile: 0x0012 
Profile: 0x0011 
Profile: 0x0014 
Profile: 0x0013 
Profile: 0x001A 
Profile: 0x001B 
Profile: 0x0010 
Profile: 0x0009 
Profile: 0x000A (current)
Profile: 0x0008 (current)
Profile: 0x0002 
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE 
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1053696 = 1029 KB
Drive DMA Speed: 11418 kB/s 64x CD 8x DVD
FIFO size      : 4194304 = 4096 KB
Track 01: data     0 MB         padsize:  238 KB
Total size:        0 MB (00:04.02) = 302 sectors
Lout start:        1 MB (00:06/02) = 302 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 2
  Reference speed: 6
  Is not unrestricted
  Is erasable
  Disk sub type: High speed Rewritable (CAV) media (1)
  ATIP start of lead in:  -12900 (97:10/00)
  ATIP start of lead out: 359849 (79:59/74)
  1T speed low:  4 1T speed high: 10
  2T speed low:  4 2T speed high:  0 (reserved val  6)
  power mult factor: 1 5
  recommended erase/write power: 5
  A1 values: 24 1A D8
  A2 values: 26 B2 48
Disk type:    unknown dye (reserved id code)
Manuf. index: -1
Manufacturer: unknown (not in table)
Manufacturer is unknown because of the orange forum embargo.
As the orange forum likes to get money for recent information,
it may be that this media does not use illegal manufacturer coding.
Blocks total: 359849 Blocks current: 340949 Blocks remaining: 340647
Starting to write CD/DVD at speed 10 in real TAO mode for multi session.
Last chance to quit, starting real write in 3 seconds.
   2 seconds.
   1 seconds.
   0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is ON.
Performing OPC...
Starting new track at sector: 18900
Track 03:    0 of    0 MB written.
/usr/bin/cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 4A 6F 00 00 1A 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 10 2A 30 06 90 21 02 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x21 Qual 0x02 (invalid address for write) Fru 0x0
Sense flags: Blk 0 (not valid) 
resid: 53248
cmd finished after 0.016s timeout 40s
/usr/bin/cdrecord: The current problem looks like a buffer underrun.
/usr/bin/cdrecord: It looks like 'driveropts=burnfree' does not work for this drive.
/usr/bin/cdrecord: Please report.
/usr/bin/cdrecord: Make sure that you are root, enable DMA and check your HW/OS set up.
write track data: error after 317440 bytes
Writing  time:   16.828s
Average write speed   0.2x.
Fixating...
Fixating time:   22.871s
/usr/bin/cdrecord: fifo had 6 puts and 6 gets.
/usr/bin/cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.

cdrecord command:
-----------------------
/usr/bin/cdrecord.mmap -v gracetime=2 dev=1,0,0 speed=10 -tao driveropts=burnfree -eject -multi -waiti -xa -tsize=181s - 

mkisofs
-----------------------
Rock Ridge signatures found
Rock Ridge signatures found
181
Rock Ridge signatures found
Total translation table size: 0
Total rockridge attributes bytes: 252
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
19081 extents written (37 MB)

mkisofs command:
-----------------------
/usr/bin/mkisofs -cdrecord-params 11700,18900 -prev-session /dev/scd0 -gui -graft-points -volid K3b data project -volset  -appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-robert/k3b8oORmc.tmp -rational-rock -hide-list /tmp/kde-robert/k3bAAoOob.tmp -joliet -hide-joliet-list /tmp/kde-robert/k3bYAo6ic.tmp -full-iso9660-filenames -iso-level 2 -path-list /tmp/kde-robert/k3bs1FUKb.tmp 

msinfo
-----------------------
11700,18900

msinfo command:
-----------------------
/usr/bin/cdrecord.mmap dev=1,0,0 -msinfo
Comment 1 Francois Marier 2006-04-27 18:47:40 UTC
Robert forgot to mention that he successfully burned a CD using cdrecord (the same version) directly.

See the Debian bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=365056
Comment 2 Sebastian Trueg 2006-04-27 20:25:18 UTC
is dma activated on the drive?
if so, please try dao writing mode or disable multisession mode.
Comment 3 Robert Derochette 2006-04-27 21:08:07 UTC
I hope I'm not making mistakes, but the CD-R/DVD-R drive in my Thinkpad R52 is a PATA device connected to a SATA2 bus. So I don't enable DMA mode with hdparm, the DVD-R device is configured as a SCSI device, and that's how I get CD burning capatibilities.
Comment 4 Christoph Burger-Scheidlin 2006-09-26 01:24:52 UTC
Can you please try with 0.12.17 or 1.0pre2.
Comment 5 Robert Derochette 2006-09-26 14:01:54 UTC
I've just tried k3b 0.12.17. The problem is stil there.

Note that I'm running the latest Debian Sid, and recently cdrecord has been forked to wodim. 
Comment 6 Sebastian Trueg 2006-10-07 10:22:16 UTC
please post the command you used for the successful command line burn and its output.
Comment 7 Robert Derochette 2006-10-07 14:40:13 UTC
Hello,

The command I use is "wodim k3b_image.iso". Here's the output of the 
program.

robert@thinkpad:~/buffer$ wodim k3b_image.iso
This is wodim, not cdrecord. Don't expect it to behave like cdrecord in any
way, don't refer to it as "cdrecord". Send problem reports to
debburn-devel@lists.alioth.debian.org, don't bother Joerg Schilling with any
problems caused by this application.
Copyright (C) 2006 cdrkit maintainers, (C) 1994-2006 Joerg Schilling

wodim: No write mode specified.
wodim: Asuming -tao mode.
wodim: Future versions of wodim may have different drive dependent defaults.

Warning: This version of libscg has not been configured via the standard
autoconfiguration method of the Schily makefile system. There is a high risk
that the code is not configured correctly and for this reason will not 
behave
as expected.
wodim: Warning: using inofficial version of libscg (debburn 
project-0.8ubuntu1+debburn1 '@(#)scsitransp.c       1.91 04/06/17 
Copyright 1988,1995,2000-2004 J. Schilling').
wodim: Warning: using inofficial libscg transport code version 
(cdrkit-team-scsi-linux-sg.c-1.86 '@(#)scsi-linux-sg.c   1.86 05/11/22 
Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   :
Vendor_info    : 'HL-DT-ST'
Identifikation : 'DVDRAM GSA-4080N'
Revision       : '0X21'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Speed set to 1764 KB/s
Starting to write CD/DVD at speed  10.0 in real TAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
trackno=0
Turning BURN-Free on
Track 01: Total bytes read/written: 4444160/4444160 (2170 sectors).


I suppose k3b passes additional parameters to wodim.

Thanks for any help.

Regards,

Robert Derochette

Sebastian Trueg wrote:
[bugs.kde.org quoted mail]
Comment 8 Sebastian Trueg 2006-10-09 10:36:42 UTC
Are you sure you disabled burnfree because it still is used in the second try. But anyway, K3b should be able to detect if the writer supports burnfree.
Comment 9 Sebastian Trueg 2006-11-18 14:40:37 UTC
please try writing an iso image with k3b via the tools->burn cd image menu entry.
Comment 10 Eduard Bloch 2006-11-20 23:00:09 UTC
Wait, let's look on your wodim configuration. Please do "wodim -vv image" and show the log. And show where your /dev/cdrw link points to (assuming that you use the default config, otherwise the device link used in your config).
Comment 11 Sebastian Trueg 2006-11-23 12:10:41 UTC
you may also try disabling multisession. Maybe the writer does not like that.
Comment 12 Sebastian Trueg 2006-12-11 16:12:49 UTC
There has been no information in a long time. I cannot reproduce the bug so I 
will close it.
Comment 13 Francois Marier 2007-10-11 22:29:31 UTC
Just for the record, the original reporter doesn't have these problems anymore.

See the last message on the Debian tracker:
  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=365056
Comment 14 Robert Derochette 2007-10-12 17:02:08 UTC
Hello,

I am the original reporter Robert Derochette. I can confirm k3b works perfectly for me since version 1.0. Sorry for not telling that earlier, and thanks for this wonderful program which is k3b :-)