Bug 126020 - Cannot edit topic line on public channel with "T" button
Summary: Cannot edit topic line on public channel with "T" button
Status: RESOLVED UNMAINTAINED
Alias: None
Product: ksirc
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Andrew Stanley-Jones
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-21 13:53 UTC by Daniel Schepler
Modified: 2010-02-20 19:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Schepler 2006-04-21 13:54:00 UTC
Version:            (using KDE KDE 3.5.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Forwarding my bug report from Debian bug #326552:

I'm currently on #debian-bugs, and the "T" button is grayed out with a
tooltip of "Only op'ed users can change the topic".  However, I can
change the topic manually with /topic, so this is inaccurate.

I can confirm that this bug still exists in ksirc 3.5.2.
Comment 1 Thiago Macieira 2006-04-24 09:18:13 UTC
What network is that? Freenode?
Comment 2 Andrew Stanley-Jones 2006-04-27 13:03:47 UTC
You are correct, this is broken.  The ability to set the topic depends on +t and +o.  If the channel modes are not set +t, then anyone can change the channel topic regardless of the oper status.  If the channel is +t then only those that are +o can change the topic.  

This should be fixed along with the inplace topic editor.  If you show topic, and then double click on the topic it allows you to edit the topic.  The problem is, it allows you to edit the topic regardless of your ability to set it.  So you edit, then hit enter and server may report "unable to set topic".  If the T button is made to work right, then the topic field should be too.
Comment 3 Dario Andres 2010-02-20 19:30:06 UTC
KSIRC was confirmed to be unmaintained, and its main developer is not reachable.
Closing as UNMAINTAINED.

I suggest all the users to try other KDE IRC client alternatives like Konversation, Aki, or the Qt-only Quassel.

Regards