Bug 125802 - ksysv can't be closed if you don't do any changes.
Summary: ksysv can't be closed if you don't do any changes.
Status: RESOLVED DUPLICATE of bug 119631
Alias: None
Product: ksysv
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Niels Sascha Reedijk
URL:
Keywords:
: 120831 123440 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-18 13:43 UTC by Pierre Habouzit
Modified: 2006-05-23 17:50 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Habouzit 2006-04-18 13:43:03 UTC
Version:            (using KDE KDE 3.5.2)
Installed from:    Debian testing/unstable Packages

from http://bugs.debian.org/354851
=======================================================================
ksysv can't be closed only if you don't do any changes.
res variable in queryExit() must be initialized with KMessageBox::Continue.

Patch is (from Fathi BOUDRA <fboudra free fr>):

--- ksysv/TopWidget.cpp 2005-10-10 16:53:26.000000000 +0200·
+++ ../TopWidget.cpp    2006-03-12 23:21:40.000000000 +0100·
@@ -291,7 +291,7 @@·
 }·
··
 bool KSVTopLevel::queryExit() {·
-  uint res = KMessageBox::Yes;·
+  uint res = KMessageBox::Continue;·
··
   if (mChanged) {·
     res = KMessageBox::warningContinueCancel(kapp->mainWidget(),·
Comment 1 Grzegorz Oledzki 2006-04-19 00:36:20 UTC
Is it a duplicate of bug #123440 ?
Comment 2 Pierre Habouzit 2006-04-19 01:04:59 UTC
looks like so.
sorry for the dupe, but at least, there is a fix ;)
Comment 3 Rex Dieter 2006-05-16 14:03:32 UTC
*** Bug 120831 has been marked as a duplicate of this bug. ***
Comment 4 Rex Dieter 2006-05-16 14:04:17 UTC
*** Bug 123440 has been marked as a duplicate of this bug. ***
Comment 5 Dirk Mueller 2006-05-23 17:50:19 UTC

*** This bug has been marked as a duplicate of 119631 ***