Bug 125333 - Jabber constantly disconnects with "unknown error"
Summary: Jabber constantly disconnects with "unknown error"
Status: RESOLVED WORKSFORME
Alias: None
Product: kopete
Classification: Applications
Component: Jabber Plugin (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-11 05:03 UTC by Adam Porter
Modified: 2006-12-30 23:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Porter 2006-04-11 05:03:00 UTC
Version:           0.11.2 (using KDE KDE 3.5.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

(also in Debian at: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=356073)

I have two Jabber accounts: one on jabber.org, and one on a DreamHost.com account.  Kopete will not stay connected to either of these for more than a few minutes before it 
disconnects and says:

"There was a connection error; Sorry, something unexpected happened that I do not know more about."

Topping it off, it won't automatically reconnect.  This makes the Jabber support of Kopete completely useless.  This has been going on for over a month now, as long as I've 
been using Kopete.
Comment 1 Matt Rogers 2006-04-11 05:16:53 UTC
do you have debug output from around the time that it disconnects?
Comment 2 Adam Porter 2006-04-11 12:22:50 UTC
At the moment I'm unable to install the build dependencies, so I can't build Kopete with --enable-debug.  When I get a chance to do that, I'll see what I can do.
Comment 3 Adam Porter 2006-04-14 16:22:25 UTC
Ok, here's what I found:

kopete (jabber): [void JabberByteStream::slotError(int)] Socket error 17
kopete (jabber): [void JabberConnector::slotError(int)] Error detected: 17
kopete (jabber): [virtual void JabberByteStream::close()] Closing stream.
kopete (jabber): [void JabberByteStream::slotConnectionClosed()] Socket has been closed.
kopete (jabber): [virtual void JabberByteStream::close()] Closing stream.
kopete (jabber - raw protocol): [void JabberAccount::slotClientDebugMessage(const QString&)] Client stream error.
kopete (jabber): [void JabberAccount::slotCSError(int)] Error in stream signalled.
kopete (jabber): [void JabberAccount::slotCSError(int)] Disconnecting.
kopete (jabber): [void JabberByteStream::slotError(int)] Socket error 17
kopete (jabber): [void JabberConnector::slotError(int)] Error detected: 17
kopete (jabber): [virtual void JabberByteStream::close()] Closing stream.
kopete (jabber): [void JabberByteStream::slotConnectionClosed()] Socket has been closed.
kopete (jabber): [virtual void JabberByteStream::close()] Closing stream.
kopete (jabber - raw protocol): [void JabberAccount::slotClientDebugMessage(const QString&)] Client stream error.
kopete (jabber): [void JabberAccount::slotCSError(int)] Error in stream signalled.
kopete (jabber): [void JabberAccount::slotCSError(int)] Disconnecting.

After that I can reconnect and everything is fine for a while until it does this again.
Comment 4 Adam Porter 2006-04-14 16:22:58 UTC
Ok, here's what I found:

kopete (jabber): [void JabberByteStream::slotError(int)] Socket error 17
kopete (jabber): [void JabberConnector::slotError(int)] Error detected: 17
kopete (jabber): [virtual void JabberByteStream::close()] Closing stream.
kopete (jabber): [void JabberByteStream::slotConnectionClosed()] Socket has been closed.
kopete (jabber): [virtual void JabberByteStream::close()] Closing stream.
kopete (jabber - raw protocol): [void JabberAccount::slotClientDebugMessage(const QString&)] Client stream error.
kopete (jabber): [void JabberAccount::slotCSError(int)] Error in stream signalled.
kopete (jabber): [void JabberAccount::slotCSError(int)] Disconnecting.
kopete (jabber): [void JabberByteStream::slotError(int)] Socket error 17
kopete (jabber): [void JabberConnector::slotError(int)] Error detected: 17
kopete (jabber): [virtual void JabberByteStream::close()] Closing stream.
kopete (jabber): [void JabberByteStream::slotConnectionClosed()] Socket has been closed.
kopete (jabber): [virtual void JabberByteStream::close()] Closing stream.
kopete (jabber - raw protocol): [void JabberAccount::slotClientDebugMessage(const QString&)] Client stream error.
kopete (jabber): [void JabberAccount::slotCSError(int)] Error in stream signalled.
kopete (jabber): [void JabberAccount::slotCSError(int)] Disconnecting.

After that I can reconnect and everything is fine for a while until it does this again.
Comment 5 Adam Porter 2006-04-14 16:24:13 UTC
Sorry, some problems while the server seemed to be asleep...
Comment 6 Adam Porter 2006-04-15 04:02:48 UTC
By the way, even though my two Jabber accounts are on completely different servers, these disconnects always seem to happen simultaneously.
Comment 7 Olivier Goffart 2006-04-15 10:27:17 UTC
Error 17 is caused because the server close the connexion.

It may also be if you are under a NAT and that it timeout TCP connexion.
(Thiago may confirm)

In Kopete 0.12  Jabber will try to automatically reconnect 3 times.
Comment 8 Adam Porter 2006-08-22 11:45:25 UTC
Forgive me, but I'm reopening this bug.  I'm now using Kopete from KDE 3.5.4, and this problem persists.  I now use three Jabber accounts: one on Jabber.org, one on a DreamHost account, and one on Gmail.  They always end up disconnecting with this error at exactly the same time; all three accounts, even though they are on completely separate servers.

The other big thing is, Jabber is the only protocol with this problem.  MSN, AIM, ICQ, and YIM work fine.  They never, ever exhibit this problem; only Jabber.

Doesn't this suggest that something is amiss with Kopete's Jabber support?
Comment 9 Olivier Goffart 2006-08-22 12:19:52 UTC
please send me the debug output when it does disconnect, including the few last XML message that has been sent or received.
Comment 10 Olivier Goffart 2006-09-17 12:32:22 UTC
I cannot reproduce, and i lack info, so i can't fix it, sorry.
Comment 11 Adam Porter 2006-09-18 10:25:44 UTC
Sorry, I was having trouble building Kopete with debug on.  I also realized that Debian won't be including 0.12.x until after Etch is released.  I installed 0.12.2  myself and will let you know if I have more problems.  Thanks for your help.
Comment 12 Alexander Hungenberg 2006-11-09 17:39:38 UTC
I can confirm this bug on gentoo, kde 3.5.5 and kopete 0.12.3. I can't reproduce it. Sometimes it comes after a few seconds, but other times after a few hours.

I saw this problem in psi, too. But it reconnects silently and very fast. So in my opinion it isn't a kopete bug.

Overall it would be nice, if kopete would reconnect as silent as psi...
Comment 13 auxsvr 2006-12-30 23:40:07 UTC
It happens to me occasionally in kopete 10.3; when it happens, kopete disconnects from all IM protocol connections in use (MSN, jabber). I have a ethereal log that may help (e-mail me if you want it), according to which the jabber server doesn't respond to keep alive messages for a number of occasions as if the connection is over (internet connection was working at the time of the disconnection). My estimate is that the jabber disconnection seems reasonable and the MSN disconnection at the same time seems to be erroneous behaviour.