Bug 125044 - kmail crashes when adding a subfolder with a name containing "/"
Summary: kmail crashes when adding a subfolder with a name containing "/"
Status: RESOLVED DUPLICATE of bug 120448
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-06 15:06 UTC by Evgeniy Stepanov
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Evgeniy Stepanov 2006-04-06 15:06:07 UTC
Version:           unknown (using KDE 3.5.2, Debian Package 4:3.5.2-2 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.16-1-686

An attempt to add a subfolder named "qq/qq" to inbox leads to segfault.
Kmail freshly installed from debian/unstable, no setup has been made.
Before crash, message boxes appear:
"Error while creating file qq/qq: No such file or directory"
and
"Error opening /home/eugeni/.kde/share/apps/kmail/mail/.inbox.directory/qq/qq; this folder is missing."

Stacktrace:
[KCrash handler]
#5  0xa78bec4b in fseek () from /lib/tls/libc.so.6
#6  0xa7ce7e08 in KMMsgDict::writeFolderIds () from /usr/lib/libkmailprivate.so
#7  0xa7ceecbc in FolderStorage::invalidateFolder ()
   from /usr/lib/libkmailprivate.so
#8  0xa7ceed54 in FolderStorage::readFolderIdsFile ()
   from /usr/lib/libkmailprivate.so
#9  0xa7ceed81 in FolderStorage::registerWithMessageDict ()
   from /usr/lib/libkmailprivate.so
#10 0xa7ccf38b in KMFolder::KMFolder () from /usr/lib/libkmailprivate.so
#11 0xa7d0a926 in KMFolderDir::createFolder () from /usr/lib/libkmailprivate.so
#12 0xa7d0c949 in KMFolderMgr::createFolder () from /usr/lib/libkmailprivate.so
#13 0xa7eda88a in KMail::NewFolderDialog::slotOk ()
   from /usr/lib/libkmailprivate.so
#14 0xa5f446c9 in KDialogBase::qt_invoke () from /usr/lib/libkdeui.so.4
#15 0xa7ed7d54 in KMail::NewFolderDialog::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#16 0xa711054b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xa7110fdc in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#18 0xa74aac09 in QButton::clicked () from /usr/lib/libqt-mt.so.3
#19 0xa72c5a6a in QDialog::keyPressEvent () from /usr/lib/libqt-mt.so.3
#20 0xa5eccfde in KDialogBase::keyPressEvent () from /usr/lib/libkdeui.so.4
#21 0xa714aeb1 in QWidget::event () from /usr/lib/libqt-mt.so.3
#22 0xa70a687a in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#23 0xa70a6c0d in QApplication::notify () from /usr/lib/libqt-mt.so.3
#24 0xa77b002e in KApplication::notify () from /usr/lib/libkdecore.so.4
#25 0xa703806f in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#26 0xa702bdaf in QETWidget::translateKeyEvent () from /usr/lib/libqt-mt.so.3
#27 0xa7031d07 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#28 0xa704b2a2 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#29 0xa70bf255 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#30 0xa70bf17a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#31 0xa70a538d in QApplication::exec () from /usr/lib/libqt-mt.so.3
#32 0x0804a098 in ?? ()
#33 0xaf8cf618 in ?? ()
#34 0xaf8cf804 in ?? ()
#35 0x00000000 in ?? ()
Comment 1 Ismail Onur Filiz 2006-05-16 19:01:53 UTC

*** This bug has been marked as a duplicate of 120448 ***