Bug 124706 - kcmyast2 doesn't let enter superuser password
Summary: kcmyast2 doesn't let enter superuser password
Status: RESOLVED NOT A BUG
Alias: None
Product: kcontrol
Classification: Miscellaneous
Component: general (show other bugs)
Version: 3.5.2
Platform: openSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Daniel Molkentin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-01 17:55 UTC by Jordi
Modified: 2006-04-10 13:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jordi 2006-04-01 17:55:42 UTC
Version:           3.5.2 (using KDE KDE 3.5.2)
Installed from:    SuSE RPMs
OS:                Linux

When i try to use any of yast2 modules via KDE control center, clicking on "administrator mode", it doesn't let to type the root password. On the conrary, it displays the KDE version, user, linux kernel version, architecture, etc...
This happens since i've updated my KDE form 3.5.1 to 3.5.2 version

I use opensuse 10.0 eval version,architecture i686, problem is with kcmyast2.
Comment 1 Maksim Orlovich 2006-04-01 17:58:43 UTC
kcmyast2 is a SUSE product, not a KDE one.
Comment 2 joseph eblaste 2006-04-02 18:43:30 UTC
i believe that this is not only true for YAST modules under KControl.  all modules that require root password will have the same effect as the problem mentioned above.  i'm running a fresh install of SUSE RPMs of version 3.5.2, from the older/original KDE version that shipped with SUSE 9.3 Pro. i didn't have any other 3.5.x version but this one installed.

i've been trying to find reports on this for Suse (since this seems to be an isolated problem, one that occurs mostly on Ubuntu distros based on my web search for the past 36 hours.)  maybe you can look up on this KDE pips?  this must be a KDE bug?

thanks! :D


by the way running a module separately from konsole, for example "kcmshell kdm", and then clicking on the "ADMINISTRATOR MODE" button will give you this output:

   kdesu: Unknown option '-n'.
   kdesu: Use --help to get a list of available command line options.
Comment 3 joseph eblaste 2006-04-03 06:41:17 UTC
i just found out that if you replaced your existing kdesu binary (currently for me it is kdebase v 3.5.2  install) with a previous copy, one that you know is sure to work (try from v 3.4.x), you'll be able to go root again on modules in kcontrol that will require you to do so.  in my case i replaced both kdesu & kdesud with copies from version 3.4.0.

so what is this, kdesu's fault or kcontrol's? :O
Comment 4 Maksim Orlovich 2006-04-03 06:56:05 UTC
coolo: patch kdesu-dont-keep-pwd.diff in SUSE SRPMS for 3.5.2 looks like the likely suspect for this breakage. (Was it you who asked to be notified of packaging bugs, or someone else?)
Comment 5 Stephan Binner 2006-04-10 13:22:41 UTC
That's fixed for one week in the next revision of kdebase3.rpm