Bug 124511 - kwin crashes when switching windows with Alt-Tab
Summary: kwin crashes when switching windows with Alt-Tab
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash with 3 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 124524 124816 124817 124826 126209 126214 126516 127278 127710 127748 128092 128927 131749 139934 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-03-29 20:09 UTC by Sergio Davis
Modified: 2007-01-24 12:24 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Davis 2006-03-29 20:09:21 UTC
Version:           3.5.2 (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 3.2.3 
OS:                Linux

Backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 16242)]
[KCrash handler]
#6  0xb665e020 in KWinInternal::Workspace::nextFocusChainClient ()
   from /usr/lib/./libkdeinit_kwin.so
#7  0xb665a4b5 in KWinInternal::TabBox::createClientList ()
   from /usr/lib/./libkdeinit_kwin.so
#8  0xb665a869 in KWinInternal::TabBox::reset ()
   from /usr/lib/./libkdeinit_kwin.so
#9  0xb665d3d1 in KWinInternal::Workspace::startKDEWalkThroughWindows ()
   from /usr/lib/./libkdeinit_kwin.so
#10 0xb665cffb in KWinInternal::Workspace::slotWalkThroughWindows ()
   from /usr/lib/./libkdeinit_kwin.so
#11 0xb6643bd6 in KWinInternal::Workspace::qt_invoke ()
   from /usr/lib/./libkdeinit_kwin.so
#12 0xb778717e in KGlobalAccelPrivate::activate ()
   from /usr/lib/./libkdecore.so.4
#13 0xb7786ac3 in KGlobalAccelPrivate::x11KeyPress ()
   from /usr/lib/./libkdecore.so.4
#14 0xb7786750 in KGlobalAccelPrivate::x11Event ()
   from /usr/lib/./libkdecore.so.4
#15 0xb76f74df in KApplication::x11EventFilter ()
   from /usr/lib/./libkdecore.so.4
#16 0xb6658442 in KWinInternal::Application::x11EventFilter ()
   from /usr/lib/./libkdeinit_kwin.so
#17 0xb7035534 in qt_set_x11_event_filter ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#18 0xb703eb7c in QApplication::x11ProcessEvent ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#19 0xb70555eb in QEventLoop::processEvents ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#20 0xb70ba86b in QEventLoop::enterLoop () from /usr/lib/qt/lib/libqt-mt.so.3
#21 0xb70ba714 in QEventLoop::exec () from /usr/lib/qt/lib/libqt-mt.so.3
#22 0xb70a9560 in QApplication::exec () from /usr/lib/qt/lib/libqt-mt.so.3
#23 0xb6658820 in kdemain () from /usr/lib/./libkdeinit_kwin.so
#24 0xb669d926 in kdeinitmain () from /usr/lib/kde3/kwin.so
#25 0x0804d2a6 in launch ()
#26 0x0804e3b9 in handle_launcher_request ()
#27 0x0804e8fc in handle_requests ()
#28 0x0804f88a in main ()
Comment 1 Sergio Davis 2006-03-29 20:23:04 UTC
It seems to happen when there are no windows open, and when the "show window list when switching windows" option is activated.
Comment 2 Jaison Lee 2006-03-30 00:13:42 UTC
*** Bug 124524 has been marked as a duplicate of this bug. ***
Comment 3 david.ponce 2006-03-30 11:26:28 UTC
On my Fedora Core 4 box, since I upgraded KDE to 3.5.2
(kdebase-3.5.2-1.0.fc4.kde ), Kwin also crashes when I use the Alt-TAB
key to switch windows.  Below is the backtrace I got.  Here are my
window setting:

Desktop/Window behavior/Navigation

  Show window list while switching windows ON
  Traverse windows on all desktops         ON
  Desktop navigation wraps around          OFF
  Popup desktop name on desktop switch     OFF

Notice that Kwin doesn't crash if I disable "Show window list while
switching windows". So, as a workaround for now, I just disabled it.

Hope it will help.

David

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209107776 (LWP 3441)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x00406b52 in KWinInternal::Workspace::nextFocusChainClient ()
   from /usr/lib/libkdeinit_kwin.so
#7  0x00406d29 in KWinInternal::TabBox::nextPrev ()
   from /usr/lib/libkdeinit_kwin.so
#8  0x00406e86 in KWinInternal::Workspace::KDEWalkThroughWindows ()
   from /usr/lib/libkdeinit_kwin.so
#9  0x0041ad5b in KWinInternal::Workspace::tabBoxKeyPress ()
   from /usr/lib/libkdeinit_kwin.so
#10 0x0044bf50 in KWinInternal::Workspace::workspaceEvent ()
   from /usr/lib/libkdeinit_kwin.so
#11 0x0044c0cc in KWinInternal::Application::x11EventFilter ()
   from /usr/lib/libkdeinit_kwin.so
#12 0x04a54ca1 in qt_set_x11_event_filter ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x04a61803 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x04a764b8 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x04ae61f2 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#16 0x04ae6116 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x04acd559 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x00448deb in kdemain () from /usr/lib/libkdeinit_kwin.so
#19 0x0084fd7f in __libc_start_main () from /lib/libc.so.6
#20 0x080483e1 in ?? ()
Comment 4 Ruben Jenster 2006-03-30 13:15:28 UTC
Same problem here with 3.5.2 and gentoo packages. Reverting back to kwin-3.5.1 solves this issue for me.
Comment 5 Dirk Mueller 2006-03-31 12:43:54 UTC
SVN commit 524823 by mueller:

a kwin that crashes is a bad kwin
BUG: 124511


 M  +4 -0      tabbox.cpp  


--- branches/KDE/3.5/kdebase/kwin/tabbox.cpp #524822:524823
@@ -1152,6 +1152,8 @@
 */
 Client* Workspace::nextFocusChainClient( Client* c ) const
     {
+    if ( !c )
+        return 0;
     int desktop = c->isOnAllDesktops() ? currentDesktop() : c->desktop();
     if ( focus_chain[desktop].isEmpty() )
         return 0;
@@ -1170,6 +1172,8 @@
 */
 Client* Workspace::previousFocusChainClient( Client* c ) const
     {
+    if ( !c )
+        return 0;
     int desktop = c->isOnAllDesktops() ? currentDesktop() : c->desktop();
     if ( focus_chain[desktop].isEmpty() )
         return 0;
Comment 6 Boris Dušek 2006-03-31 21:21:35 UTC
After upgrading kwin with this patch, I get weird behaviour: alt+tab no longer causes crashes, but no longer is useless: when a window is minimized, it is not concidered by alt+tab as available (so e.g. 10 windows minimized->alt+tab gives "no windows" message).
Comment 7 Boris Dušek 2006-03-31 21:37:14 UTC
>"no longer is useless"
sorry, I ment "no longer is useful"
Comment 8 MAHU 2006-04-01 18:05:28 UTC
For me this patch solves the crash, but the issue that only windows from the currently active desktop are shown although the option "Traverse windows on all desktops" is activated in kcontrol, still remains. Any suggestions?
Comment 9 Dirk Mueller 2006-04-03 15:09:16 UTC
I updated the patch accordingly.
Comment 10 Jaison Lee 2006-04-03 20:21:22 UTC
*** Bug 124817 has been marked as a duplicate of this bug. ***
Comment 11 Carsten Lohrke 2006-04-04 14:41:12 UTC
Dirk, I have the updated patch applied. But the issue persists. Not being  comfortable with the KDE code base, might be the change from

readNumEntry to readBoolEntry be the problem (with existing configuration data)?
Comment 12 Thiago Macieira 2006-04-05 13:00:36 UTC
*** Bug 124816 has been marked as a duplicate of this bug. ***
Comment 13 MAHU 2006-04-06 00:52:42 UTC
Applied the updated patch, too. But I'm still not able to browse through all windows. No change noticeable since the last patch...
Comment 14 Stephan Binner 2006-04-10 17:34:45 UTC
*** Bug 124826 has been marked as a duplicate of this bug. ***
Comment 15 Lubos Lunak 2006-04-25 11:12:28 UTC
*** Bug 126209 has been marked as a duplicate of this bug. ***
Comment 16 Lubos Lunak 2006-04-25 11:13:32 UTC
*** Bug 126214 has been marked as a duplicate of this bug. ***
Comment 17 HÉDER Mihály 2006-04-26 22:32:55 UTC
After upgrading to kdebase-3.5.2-0.2.fc5 (with yum) last weekend, I have the same problem (No windows form other Desktops and crash on double-alt-tab if only one window is shown)
Comment 18 Jaison Lee 2006-05-02 15:23:11 UTC
*** Bug 126516 has been marked as a duplicate of this bug. ***
Comment 19 Jaison Lee 2006-05-15 04:53:24 UTC
*** Bug 127278 has been marked as a duplicate of this bug. ***
Comment 20 Jaison Lee 2006-05-21 05:50:25 UTC
*** Bug 127710 has been marked as a duplicate of this bug. ***
Comment 21 Jaison Lee 2006-05-21 13:25:11 UTC
*** Bug 127748 has been marked as a duplicate of this bug. ***
Comment 22 Lubos Lunak 2006-05-29 19:34:35 UTC
*** Bug 128092 has been marked as a duplicate of this bug. ***
Comment 23 Thiago Macieira 2006-06-18 16:16:42 UTC
*** Bug 128927 has been marked as a duplicate of this bug. ***
Comment 24 Lubos Lunak 2006-08-04 11:23:01 UTC
*** Bug 131749 has been marked as a duplicate of this bug. ***
Comment 25 Lubos Lunak 2007-01-24 12:24:55 UTC
*** Bug 139934 has been marked as a duplicate of this bug. ***