Bug 124032 - konqueror crash on linuxtoday.com
Summary: konqueror crash on linuxtoday.com
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: 3.5
Platform: Debian testing Linux
: NOR crash with 1 vote (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-21 22:56 UTC by Robert Gomułka
Modified: 2006-03-25 15:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gomułka 2006-03-21 22:56:09 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages

First of all, I am reporting this bug, because it occured when I wanted to verify other people's problem with crashing reported on debian-kde list. I am not sure if there aren't any duplicates, however I couldn't find any similar bug.
Steps to reproduce:
1. Enter www.linuxtoday.com in konqueror
2. Navigate through this page (enter article, go back, ...)
3. It should crash very early.

Debian packages exact version:
KDE_3_5_BRANCH update (up to r517245). [kdelibs]
Others suggest that this version works ok:
KDE_3_5_BRANCH update (up to r515119).

Stack trace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1231931712 (LWP 7258)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0xb7d4b7c7 in raise () from /lib/tls/libc.so.6
#6  0xb7d4d06b in abort () from /lib/tls/libc.so.6
#7  0xb7d82525 in __fsetlocking () from /lib/tls/libc.so.6
#8  0xb7d8867c in malloc_usable_size () from /lib/tls/libc.so.6
#9  0xb7d89741 in free () from /lib/tls/libc.so.6
#10 0xb7d8aaa1 in calloc () from /lib/tls/libc.so.6
#11 0xb5eca21b in KJS::Identifier::rehash () from /usr/lib/libkjs.so.1
#12 0xb5eca2db in KJS::Identifier::shrink () from /usr/lib/libkjs.so.1
#13 0xb5ed672f in KJS::Identifier::remove () from /usr/lib/libkjs.so.1
#14 0xb5ed67ab in KJS::UString::Rep::destroy () from /usr/lib/libkjs.so.1
#15 0xb5edcf5a in KJS::PropertyMap::clear () from /usr/lib/libkjs.so.1
#16 0xb5edcfc0 in KJS::ObjectImp::deleteAllProperties ()
   from /usr/lib/libkjs.so.1
#17 0xb616c9ff in EmbedLiveConnect::EmbedLiveConnect ()
   from /usr/lib/libkhtml.so.4
#18 0xb61b0eb0 in EmbedLiveConnect::toString () from /usr/lib/libkhtml.so.4
#19 0xb600ff22 in KHTMLPart::clear () from /usr/lib/libkhtml.so.4
#20 0xb602a5b8 in KHTMLPart::~KHTMLPart () from /usr/lib/libkhtml.so.4
#21 0xb601030c in KHTMLPart::clear () from /usr/lib/libkhtml.so.4
#22 0xb6037bb2 in KHTMLPart::restoreState () from /usr/lib/libkhtml.so.4
#23 0xb5ff01de in KHTMLPartBrowserExtension::restoreState ()
   from /usr/lib/libkhtml.so.4
#24 0xb68252ef in KonqView::restoreHistory ()
   from /usr/lib/libkdeinit_konqueror.so
#25 0xb682d7a2 in KonqView::go () from /usr/lib/libkdeinit_konqueror.so
#26 0xb683780e in KonqMainWindow::slotGoHistoryDelayed ()
   from /usr/lib/libkdeinit_konqueror.so
#27 0xb684207e in KonqMainWindow::qt_invoke ()
   from /usr/lib/libkdeinit_konqueror.so
#28 0xb72c67ff in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#29 0xb7654421 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#30 0xb72e3eec in QSignal::activate () from /usr/lib/libqt-mt.so.3
#31 0xb72eb9b0 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#32 0xb725d122 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#33 0xb725d314 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#34 0xb792dfde in KApplication::notify () from /usr/lib/libkdecore.so.4
#35 0xb71ee861 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#36 0xb724ebad in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#37 0xb7202566 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#38 0xb7275b01 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#39 0xb7275a26 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#40 0xb725bc35 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#41 0xb683bf9c in kdemain () from /usr/lib/libkdeinit_konqueror.so
#42 0xb7fbe524 in kdeinitmain () from /usr/lib/kde3/konqueror.so
#43 0x0804e1d6 in ?? ()
#44 0x00000002 in ?? ()
#45 0x080f4de0 in ?? ()
#46 0x00000001 in ?? ()
#47 0x00000000 in ?? ()
Comment 1 Tommi Tervo 2006-03-22 11:30:56 UTC
Cannot reproduce (r520601). It seems to be debian spesific, there is a one recent comment to old closed bug, see http://bugs.kde.org/show_bug.cgi?id=41013
Comment 2 Robert Gomułka 2006-03-22 23:12:05 UTC
I am not sure if this is Debian specific. I would rather guess the bug has appeared in upstream code, then maybe fixed in the meantime.
Comment 3 Thiago Macieira 2006-03-25 15:03:56 UTC
I couldn't make it crash either. KDE 3.5.1 r512077.
Comment 4 Robert Gomułka 2006-03-25 15:15:29 UTC
Thiago, I would preferably see closing this bug because it does not exist on newer version, than specified in bugreport. However, you have provided older version, on which it doesn't happen on our systems, too.
Comment 5 Thiago Macieira 2006-03-25 15:21:55 UTC
You tested on 3.5.1 and it crashed.

I tested on post-3.5.1 and it did not crash. Tommi tested on 3.5.2 and it did not crash.

Looks to me that it has been fixed. Unless you can reproduce with 3.5.2 (it's been tagged), I'd say it's been fixed.