Bug 123504 - cookie alert blocks konqueror.
Summary: cookie alert blocks konqueror.
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: kcookiejar (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-12 16:44 UTC by Aron Fischer
Modified: 2011-11-26 18:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Fischer 2006-03-12 16:44:53 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Compiled From Sources
OS:                Linux

I have cookie alerts turned on.

sometimes a website wants to set a cookie but the alert window looses focus - for whatever reason - or is in the background. 
In this case the website will not load and I usually resort to changing to firefox before realising (often much later) that there was a cookie alert somewhere selectively blocking all konqueror sites requiring cookies.

This is especially annoying when I leave many konqueror windows open at the end of a session and on logging in again, there is some website on desktop 6 that wants to set a cookie.
How long does it take before I realise that on desktop 6 there is a dialogue that I should click 'reject' on before my konqueror works again?

Why does one cookie alert in one konqueror block ALL other websites in other konquerors that want to set a cookie?
PLUS: There is absolutely no feedback from a blocked konqueror. It just looks as if the site won't load. If you don't know about this cookie alert problem, you'll probably guess Konqueror is broken.
Comment 1 Thiago Macieira 2006-03-13 18:57:44 UTC
The window should be modal and not let you get out of focus.
Comment 2 James Spahlinger 2008-04-19 15:26:37 UTC
This is confirmed in 4.0.3. Quite annoying too, there is no feedback that the browser wants a cookie, so it just looks like the site is taking forever to load.

Using Gentoo Linux ~x86 (testing in gentoo lingo). KDE 4.0.3 and the majority of packages compiled using gcc 4.3.0. 
Comment 3 Dawit Alemayehu 2011-11-26 18:15:50 UTC
Git commit 33306f48b30d8d7a0210eeafe9a3a4eb561ab0c6 by Dawit Alemayehu.
Committed on 26/11/2011 at 08:59.
Pushed by adawit into branch 'KDE/4.7'.

Just like the password dialog, associate the cookie configuration dialog with
the correct parent window.

BUG: 123504
BUG: 160044
FIXED-IN: 4.7.4

M  +18   -5    kioslave/http/kcookiejar/kcookieserver.cpp
M  +3    -0    kioslave/http/kcookiejar/kcookieserver.h

http://commits.kde.org/kdelibs/33306f48b30d8d7a0210eeafe9a3a4eb561ab0c6