Bug 122832 - Filelight ignores large files
Summary: Filelight ignores large files
Status: RESOLVED FIXED
Alias: None
Product: filelight
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Max Howell
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-28 13:22 UTC by Tomas Pospisek
Modified: 2006-08-30 00:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
filelight in action (24.75 KB, image/png)
2006-08-20 10:18 UTC, Tomas Pospisek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Pospisek 2006-02-28 13:22:43 UTC
Version:           1.0-beta4 (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Filelight completely ignores files larger than 2Gb. Please see http://bugs.debian.org/341680
*t
Comment 1 Max Howell 2006-08-15 20:30:49 UTC
I believe this is fixed in SVN. Please test, or test against 1.0. I'll leave open until confirmation, since I can't test it really, it only effects certain linux distro's like debian.
Comment 2 Tomas Pospisek 2006-08-20 10:18:31 UTC
Created attachment 17427 [details]
filelight in action
Comment 3 Tomas Pospisek 2006-08-20 10:19:20 UTC
I've tested with 1.0-rc1 from the filelight homepage [1] but files >2GB still can't be seen - see attached filelight screenshot.

# dd if=/dev/zero of=/mnt/hda9/2gb count=2200 bs=1M
$ ls -lh /mnt/hda9/
total 2.2G
-rw-r--r-- 1 root root 2.2G Aug 20 09:56 2gb
drwxr-xr-x 8 tpo  tpo  4.0K May 27  2005 buildknoppix
drwxr-xr-x 3 tpo  tpo  4.0K May 27  2005 crux
drwxr-sr-x 2 tpo  tpo  4.0K May 27  2005 knoppix
drwx------ 2 root root  16K May 27  2005 lost+found
drwxr-xr-x 3 tpo  tpo  4.0K Dec 15  2005 multimedia
drwxr-xr-x 2 tpo  tpo  4.0K Jul 15  2005 uml

*t

[1] http://www.methylblue.com/filelight/
Comment 4 Max Howell 2006-08-21 02:34:02 UTC
Yes sorry I thought I'd included the fix, but it was another bit of similar looking code. Will try to include fix for 1.0, which will prolly mean an rc2 in near future.
Comment 5 Max Howell 2006-08-21 23:37:51 UTC
SVN commit 575690 by mhowell:

BUG: 122832
Fixed? I hope. Support Debian and it's strange stat semantics.


 M  +18 -0     localLister.cpp  


--- trunk/extragear/utils/filelight/src/part/localLister.cpp #575689:575690
@@ -110,6 +110,24 @@
       #define ST_NBLOCKSIZE 512
    #endif
 
+//some GNU systems don't support big files for some reason
+#ifndef __USE_LARGEFILE64 //see dirent.h
+ #define DIRENT dirent
+ #define SCANDIR scandir
+ #define STATSTRUCT stat
+ #define LSTAT lstat
+#else
+ #define DIRENT dirent64
+ #define SCANDIR scandir64
+ #define STATSTRUCT stat64
+ #define LSTAT lstat64
+#endif
+
+#ifndef NULL
+#define NULL 0
+#endif
+
+
    #include <errno.h>
    static void
    outputError( QCString path )
Comment 6 Max Howell 2006-08-23 00:33:53 UTC
I released RC2, please check http://methylblue.com/filelight for the tarball, if you'd like to test. I'm fairly sure it'll work this time. If not I'll have to try and find a debian install myself or something.
Comment 7 Tomas Pospisek 2006-08-30 00:08:18 UTC
No, the problem is still not fixed in rc2. I still can't see the file.
Comment 8 Tomas Pospisek 2006-08-30 00:12:56 UTC
Please accept my apologies - it *does* work now with large files. I just forgot to "make install" so probably filelight was accessing the old filelight.la or something.