Bug 122746 - images are not shown anymore. black screen.
Summary: images are not shown anymore. black screen.
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ImageEditor-Load (show other bugs)
Version: 0.8.1
Platform: unspecified Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-26 16:42 UTC by Fabian Müller
Modified: 2022-02-03 03:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Müller 2006-02-26 16:42:30 UTC
Version:           0.8.1 (using KDE 3.5.1, Debian Package 4:3.5.1-2 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.15.4

Doubleclicking some image in digikam opens up the image viewer, but this only shows a black area. The picture has size 0x0 according to the lower right info-panel of the viewer (but thats not true!). An earlier post had an error with imlib2 or imlib2_loaders, so i tried to view the pictures with 'feh' as suggested there, which worked.
The reason might be, that digikam assumes the picures to be in RAW-format and cannot decode them.
I attach the console-output:

>>> snip >>>

KIPI (loading): KIPI::PluginLoader: Loaded plugin RawConverter
digikam: WARNING: Running dcraw command : dcraw -c -2 -w -a -q 0 '/directory/img_0408.jpg'
/directory/img_0408.jpg: Cannot decode Canon PowerShot A520 JPEG images.
digikam: WARNING: Not a raw digital camera image.
digikam: WARNING: Running dcraw command : dcraw -c -2 -w -a -q 0 '/directory/img_0408.jpg'
/directory/img_0408.jpg: Cannot decode Canon PowerShot A520 JPEG images.
digikam: WARNING: Not a raw digital camera image.

<<< snap <<<

What's up? Why doesn't digikam just decode this as jpg-image if it obviously knows that it is not in RAW-format?

Strange behaviour.
Comment 1 caulier.gilles 2006-02-28 10:05:07 UTC
This problem have been normally fixed in svn (stable branch). Please test it and give me a report. Thanks in advance

Gilles Caulier
Comment 2 Israel Cabrera 2006-03-02 18:27:38 UTC
YEs I have the same problem, And I'm not using debian but SuSE.

=(  So sad...

Comment 3 caulier.gilles 2006-04-04 10:04:30 UTC
*** Bug 123129 has been marked as a duplicate of this bug. ***
Comment 4 tmpuser 2006-05-06 12:01:13 UTC
I've just got 0.8.2-beta1 version from the svn and compiled it.
The bug is still there...
Comment 5 plz 2006-06-28 08:45:03 UTC
have the same problem, using SuSe - need solution fast! penny 
Comment 6 caulier.gilles 2006-06-28 08:56:10 UTC
can you give me your ~/.kde/share/config/digikamrc ?

Gilles Caulier
Comment 7 F.J. Cruz 2006-06-28 22:17:03 UTC
El Mi
Comment 8 caulier.gilles 2006-06-29 07:57:10 UTC
Paco, 

you want mean this problem is relevant of an incompatibility between multiple libdigikam.la installed ? Are you already reproduce this problem ? (because i have never reproduce it on my computers).

Gilles
Comment 9 caulier.gilles 2006-07-18 09:59:28 UTC
Please check your system and install form sctrach the new digiKam 0.8.2 using these tarballs :

http://digikam3rdparty.free.fr/0.8.2/

Check if you have older digikam package installed on your system. remove old libdigikam.la before to install a new digiKam release on your computer, and give us a feedback

Gilles Caulier
Comment 10 julian hughes 2006-10-27 13:44:57 UTC
I had this same bug with digikam 0.8.2 on Suse 10.1. I found that libdigikam.la had not even been accessed after I had tried to view several images with digikam and saw the black screen with the 0 pixel size info. The problem is solved by installing imlib2-loaders.  
Comment 11 julian hughes 2006-10-27 16:19:54 UTC
p.s. using Smart package manager I can see that imlib2-loaders describes itself (it seems correctly) as required by digikam, but digikam does not list imlib2-loaders as a requirement. 
Comment 12 William Curry 2006-11-14 22:32:55 UTC
This problem just began for me today, after using digikam for several months with no problems. Now, although the album viewer still displays the thumbnails, even those of newly imported files, the image editor shows "0x0" pixels and a black screen. Running 0.8.2(KDE 3.5.5 39.1) just updated today trying to fix this..with
Kipi lib 0.1.4. the imlib2_loaders/image .so files all show 11-08-2006 dates (probably installed with KDE 3.5.5 today??) usr.lib/im2lib is an empty dir.
Comment 13 caulier.gilles 2006-11-14 22:35:41 UTC
The problem is relevant of imlib2 loaders witch are used by digiKam 0.8.x to load images data in editor. Fix imlib2 loader and you will fix this problem.

Note : digiKam 0.9.0 do not use imlib2 anymore.

Gilles Caulier
Comment 14 caulier.gilles 2006-12-11 15:38:27 UTC
digiKam 0.9.0 don't use imlib2 library anymore to load/save JPEG file.

I close this file now.

Gilles Caulier