Bug 122465 - meinproc is relicensing docs
Summary: meinproc is relicensing docs
Status: RESOLVED FIXED
Alias: None
Product: docs.kde.org
Classification: Websites
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Documentation Editorial Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-22 07:35 UTC by Ben Burton
Modified: 2006-04-04 15:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
patch as described (1.11 KB, patch)
2006-02-23 18:42 UTC, Philip Rodrigues
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2006-02-22 07:35:18 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Hi,

I have a KDE application whose documentation is licensed under the GPL.
In particular, its index.docbook contains the line:

    <legalnotice>&underGPL;</legalnotice>

When I build the application and meinproc is run over the docbook files,
it generates an HTML title page that looks like:

    Title (large bold heading)

    Author
    Revision number
    Copyright notice

    Legal Notice

    Abstract ...

In past versions of KDE, the legal notice was actually a short blurb
stating which license was used.  Now it is simply a hyperlink with the
two words "Legal Notice".

So: To find out the license, you must click on the "Legal Notice"
hyperlink, and --- it sends you to help:/common/fdl-notice.html, which
states that the documentation is licensed under the GFDL version 1.1 or
later.

I believe this is a serious issue -- the title page that is shown to
users in the help centre should not be offering incorrect license
information, and in some cases (such as GPLed documentation) it is
in fact forbidden to relicense the documentation as GFDL in this way.

As for the cause:  I'm not too familiar with meinproc internals, but I
suspect the culprit is /usr/share/apps/ksgmltools2/customization/kde-chunk.xsl.
Around lines 90--100 it does look like the fdl-notice is being dropped into
the documentation regardless of what actually appears inside the
<legalnotice> tag.

Commenting out this block in kde-chunk.xsl seems to fix the problem -- the
correct contents of <legalnotice>..</legalnotice> are displayed on the
title page of the HTML documentation (as in earlier KDE versions).

I would appreciate if this could be fixed in the stable branch as well
as in new releases, since (as mentioned above) offering incorrect license
information is a serious issue.

Many thanks,

Ben.
Comment 1 Christian Loose 2006-02-22 10:29:36 UTC
The problematic commit was revision 415291 (http://websvn.kde.org/trunk/KDE/kdelibs/kdoctools/customization/kde-chunk.xsl?rev=415291&view=rev)
Comment 2 Philip Rodrigues 2006-02-23 12:27:02 UTC
IIUC, all "official" KDE docs are licensed under FDL, which is why the commit that Christian mentions has fdl-notice.html hardcoded. Obviously, third-party authors should be able to use what licence they like, so this should be changed. I might have some time to look into it, but probably not in the next week or two
Comment 3 Ben Burton 2006-02-23 12:47:38 UTC
> I might have some time to look into it, but probably not in the next
> week or two


If it's going to be time-consuming to code up a better solution, I
believe it will be trivial to solve the big problem (every license is
replaced with the GFDL) -- just comment out that xsl:template block
(lines 90--100 of kde-chunk.xsl).

This at least reduces the bigger license problem to a smaller problem that
is purely aesthetic (how to move the legal notice onto a separate page).

Ben.
Comment 4 Philip Rodrigues 2006-02-23 18:42:01 UTC
Created attachment 14831 [details]
patch as described
Comment 5 Philip Rodrigues 2006-02-23 18:45:39 UTC
And here's the description of the patch:

If legalnotice is FDL, put it on a separate page. If not, put it on the title page. Ben, can you check that this works for you? If so, I'll commit it
Comment 6 Ben Burton 2006-02-24 05:50:01 UTC
Hi,

> If legalnotice is FDL, put it on a separate page. If not, put it on
> the title page. Ben, can you check that this works for you? If so,
> I'll commit it


It certainly keeps me happy -- my non-GFDL license is showing up
correctly on the title page.

However, I did a test with &underFDL; also, and it again puts the text on
the title page (i.e., it doesn't link to a separate page as intended).
So I'm not sure if it keeps you happy. :)

Note that if I spell out
<legalnotice>GNU Free Documentation License</legalnotice> instead of using
the entity <legalnotice>&underFDL;</legalnotice>, it puts it on a separate
page the way you want it.  So I suspect &underFDL; is not being expanded
before the contains() test is run.

At any rate, this is not such a bad thing -- the serious issue of
giving the wrong license has been replaced with the aesthetic issue of
the FDL notice appearing on the title page instead of a separate page.

Thanks,

Ben.
Comment 7 Philip Rodrigues 2006-02-24 11:48:56 UTC
That's odd, the FDL notice is off the front page for me. What are your KDE and libxml/libxslt versions? Sometimes a difference in those has odd effects. I'll try to find some people from the docs team to test further.
Comment 8 Ben Burton 2006-02-24 13:40:22 UTC
> What are your KDE and libxml/libxslt versions?


KDE 3.5.1 (debian unstable)
libxml 2.6.23.dfsg.1
libxslt 1.1.15

b.
Comment 9 Philip Rodrigues 2006-02-24 15:05:11 UTC
OK, thanks to a comment from qupada, I have some more insight:
You have <legalnotice>&underGPL;</legalnotice> which should be <legalnotice>&GPLnotice;</legalnotice>, and presumably when you changed to &underFDL; (instead of &FDLnotice;), you got a different string to mine, so no match, and the behaviour you describe.

However, the &underFDL; expansion does contain 'Free Documentation License', but with a newline in the middle, so no match. Therefore you've simultaneously uncovered a bug in my patch and in your docs :-).

I'll think more about how to do this better and try to come up with another patch.
Comment 10 Ben Burton 2006-03-20 01:07:43 UTC
Hi,

Regarding the "meinproc replaces all licenses with GFDL" bug:  is it
possible to at least commit the current patch in #122465 ?

It seems we have now missed the KDE 3.5.2 tagging.  The bug as it currently
stands is quite serious (relicensing documentation without author consent).
The patch fixes this serious problem in most cases, and the main
outstanding issue is aesthetic (and it's not even "wrong", it's just a
case of the legal notice being printed on the title page in some cases
where the fdl-notice link could be used instead).

Apologies for pushing on this issue, but from what I can tell, the only
real way to get the incorrect licensing fixed on end user systems is to
have the distributions provide a fixed meinproc, which means getting a
patch into some stable KDE 3.5.x release.

Many thanks,

Ben.
Comment 11 Philip Rodrigues 2006-04-04 15:45:40 UTC
SVN commit 526331 by philrod:

Revert 415291, to fix bug 122465, until we come up with a nicer solution.

BUG:122465
CCMAIL:lauri@kde.org


 M  +0 -12     kde-chunk.xsl  


--- branches/KDE/3.5/kdelibs/kdoctools/customization/kde-chunk.xsl #526330:526331
@@ -87,18 +87,6 @@
    <meta name="GENERATOR" content="KDE XSL Stylesheet V{$KDE_VERSION} using libxslt"/>
 </xsl:template>
 
-<xsl:template match="/book/bookinfo/legalnotice" mode="titlepage.mode">
-  <xsl:variable name="filename" select="concat($kde.common,'fdl-notice.html')"/>
-  <xsl:variable name="title">
-    <xsl:apply-templates select="." mode="title.markup"/>
-  </xsl:variable>
-  <p>
-    <a href="{$filename}">
-      <xsl:copy-of select="$title"/>
-    </a>
-  </p>
-</xsl:template>
-
 <!-- try with olinks: it nearly works --><!--
   <xsl:template match="olink">
     <a>