Bug 122393 - submit items in submit.xml to last.fm as soon as the connection can be stablished
Summary: submit items in submit.xml to last.fm as soon as the connection can be stabli...
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 1.4-SVN
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 101547 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-21 03:28 UTC by Adeodato Simó
Modified: 2006-06-11 12:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adeodato Simó 2006-02-21 03:28:26 UTC
Hi, this comes from Debian Bug#344429 (http://bugs.debian.org/344429) 
submitted by Christian Perrier <bubulle@debian.org>.

Current amaroK behavior with respect to submit.xml seems to be the following: 
after start, when the time for the first submission comes, if there are items 
in submit.xml, it sends the first 9 or so, and stores the present one for 
later submission. Repeat with next song, etc.

What Christian would like is that, if when amaroK starts and there are items 
in submit.xml, that they are tried to be sent immediately, so that the queue 
can be cleared even if no music is played.

This sounds a fair wishlist to me, hence I'm forwarding; I do realize, though, 
that the implementation for this may add unneeded complexity, and that tieing 
clearing the queue with the normal submission process does really simplify the 
process.

Thanks.
Comment 1 Alexandre Oliveira 2006-04-06 03:16:16 UTC
*** Bug 101547 has been marked as a duplicate of this bug. ***
Comment 2 Shane King 2006-04-27 13:50:54 UTC
This is fixed in the latest svn.