Bug 121932 - [testcase] tbody with overflow:auto behaves funny (cleverdot.com)
Summary: [testcase] tbody with overflow:auto behaves funny (cleverdot.com)
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml renderer (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-14 01:37 UTC by Zoran Davidovac
Modified: 2006-07-06 18:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
domain4.png (102.80 KB, image/png)
2006-02-17 01:29 UTC, Zoran Davidovac
Details
domain3.png (118.69 KB, image/png)
2006-02-17 01:29 UTC, Zoran Davidovac
Details
domain2.jpg (13.92 KB, image/jpeg)
2006-02-17 01:29 UTC, Zoran Davidovac
Details
domain1.jpg (13.43 KB, image/jpeg)
2006-02-17 01:29 UTC, Zoran Davidovac
Details
mozilla.bz2 (deleted)
2006-02-17 21:55 UTC, Zoran Davidovac
Details
mozilla.tar.gz (32.25 KB, application/x-tgz)
2006-02-17 21:55 UTC, Zoran Davidovac
Details
testcase (357 bytes, text/html)
2006-02-17 21:55 UTC, Maksim Orlovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoran Davidovac 2006-02-14 01:37:00 UTC
Version:           3.5.1 (using KDE 3.5.1, compiled sources)
Compiler:          gcc version 3.4.5
OS:                Linux (i686) release 2.6.15.2-zmaj

I notice this problem more than once,
but I not 100% shure where is the problem!the on site!

Hower bug can be recreated without of problem,
I have 2 domains registered on http://www.cleverdot.com/
in mozilla firefox I can see 2 domains (manage domains)

but not i Konqueror (3.5.1) where I can see only one domain out of 2.

I belive that this is some minor bug in representing tables or some javascript representing.

As pictures show more than word take a look at:
correct mozilla http://zmaj.lir.dk/mozilla.jpg
wrong konqueror http://zmaj.lir.dk/konqueror.jpg

I hope this helps :)
Comment 1 Maksim Orlovich 2006-02-17 00:37:29 UTC
Since we can not access this page, the only way for us to fix this based on this report is if you can provide a problematic snipper of the page. 
Mozilla's save complete page feature may be a good starting point
Comment 2 Zoran Davidovac 2006-02-17 01:29:16 UTC
Ok it is reproducible I am sending you html,
now I registered 3 domains but there is still sam bug :(
also here are screen shots:

old domain 1 and 2
new domain 3 and 4

note domain are changed privacy reason

On Friday 17 February 2006 00:37, you wrote:
[bugs.kde.org quoted mail]


Created an attachment (id=14727)
domain4.png

Created an attachment (id=14728)
domain3.png

Created an attachment (id=14729)
domain2.jpg

Created an attachment (id=14730)
domain1.jpg

Created an attachment (id=14731)
mozilla.bz2
Comment 3 Maksim Orlovich 2006-02-17 04:16:53 UTC
Thanks for the information --- but the .bz2 file you attached is empty
Comment 4 Zoran Davidovac 2006-02-17 17:31:17 UTC
sorry for bad archive, I am resending archive again !


Created an attachment (id=14736)
mozilla.tar.gz
Comment 5 Maksim Orlovich 2006-02-17 21:50:41 UTC
Thanks. Are the domain links clickable for you, by the way?
Comment 6 Maksim Orlovich 2006-02-17 21:55:47 UTC
Created attachment 14743 [details]
testcase

overflow:auto on a tbody. urk
Comment 7 Zoran Davidovac 2006-02-20 23:02:45 UTC
Yes the domain links are clickable, you get new window to manage domains.
Comment 8 Germain Garand 2006-07-06 18:41:15 UTC
SVN commit 559131 by ggarand:

-adapt work by Apple developers to get working overflow on 
 table-* displays.
-Some more clean-up and fixes on tables. 
-Consistently account for border{Bottom,Top}Extra.

reference patches: 
WC/r13372/#7841/
WC/r13366/
WC/r13346/
WC/r10566/

BUG: 121932




 M  +7 -0      css/cssstyleselector.cpp  
 M  +3 -8      rendering/render_block.cpp  
 M  +0 -6      rendering/render_block.h  
 M  +12 -9     rendering/render_box.cpp  
 M  +1 -4      rendering/render_box.h  
 M  +1 -1      rendering/render_canvas.cpp  
 M  +1 -1      rendering/render_canvas.h  
 M  +28 -15    rendering/render_layer.cpp  
 M  +14 -18    rendering/render_object.cpp  
 M  +8 -5      rendering/render_object.h  
 M  +161 -60   rendering/render_table.cpp  
 M  +16 -5     rendering/render_table.h  
 M  +1 -9      rendering/render_text.cpp  
 M  +1 -1      rendering/render_text.h  
 M  +2 -2      xml/dom_nodeimpl.cpp