Bug 121833 - simpify ejecting of mounted cds/dvds with the help of the HAL signal "EjectPressed"
Summary: simpify ejecting of mounted cds/dvds with the help of the HAL signal "EjectPr...
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: media (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
: 129521 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-12 16:39 UTC by Yves Glodt
Modified: 2015-01-04 22:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yves Glodt 2006-02-12 16:39:14 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages
OS:                Linux

HAL provides a signal called "EjectPressed", which is fired, guess, when the eject button is pressed on an optical device.

By making kded listen to thi signal, kded could, when a user presses Eject, consult the list of open files on the 
media, and if it finds some, present the user a window which lists the applications and the files they have opened on the media. So the user can close the apps and then the cd could be unmounted and ejected.

In case kded would not detect any open files, it could directly unmount and eject the cd.
Comment 1 Kevin Ottens 2006-06-12 12:31:56 UTC
SVN commit 550578 by ervin:

Merge coolo's branch, it contains quite some fixes and interesting 
features. It'll be available in KDE 3.5.4, couldn't be committed before,
but thanks to the partial feature unfreeze...

FEATURE:
BUG: 50185
BUG: 105482
BUG: 108823
BUG: 114854
BUG: 120619
BUG: 121833
BUG: 127788
CCMAIL: coolo@kde.org


 M  +3 -2      Makefile.am  
 M  +7 -0      configure.in.in  
 M  +2 -2      kcmodule/managermodule.cpp  
 M  +4 -3      kcmodule/notifiermodule.cpp  
 M  +1 -1      kfile-plugin/kfile_media.desktop  
 M  +7 -2      kfile-plugin/kfilemediaplugin.cpp  
 M  +4 -0      libmediacommon/medium.cpp  
 M  +20 -1     libmediacommon/medium.h  
 M  +14 -1     mediaimpl.cpp  
 M  +643 -41   mediamanager/halbackend.cpp   [POSSIBLY UNSAFE: popen]
 M  +20 -0     mediamanager/halbackend.h  
 M  +72 -9     mediamanager/mediamanager.cpp  
 M  +8 -0      mediamanager/mediamanager.h  
 M  +6 -3      medianotifier/medianotifier.cpp  
 M  +1 -1      mounthelper/Makefile.am  
 M  +32 -19    mounthelper/kio_media_mounthelper.cpp  
 AM            propsdlgplugin (directory)   branches/work/coolos_media/propsdlgplugin#549689
Comment 2 Stephan Kulow 2006-06-12 12:56:36 UTC
it should be noted that many CD drives do _not_ emit the hardware signal required. Most newer CD drives do though
Comment 3 Stephan Kulow 2006-06-21 09:37:40 UTC
*** Bug 129521 has been marked as a duplicate of this bug. ***