Bug 118167 - system:/media/camera is broken (wrong path is created when clicking on specific camera folder)
Summary: system:/media/camera is broken (wrong path is created when clicking on specif...
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: system (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 140 votes (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-12 11:03 UTC by Ingo Klöcker
Modified: 2009-02-27 19:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Klöcker 2005-12-12 11:03:33 UTC
Version:           unknown (using KDE 3.5.0 Level "a" , SUSE 9.3 UNSUPPORTED)
Compiler:          gcc version 3.3.5 20050117 (prerelease) (SUSE Linux)
OS:                Linux (i686) release 2.6.11.4-21.9-default

I plug in my camera and turn it on. Konqueror with path "system:/media/camera" opens and shows a folder for my camera (Canon PowerShot A75). So far so good. I click on the camera icon. URL changes to "system:/media/camera/camera" (yes, that's "camera" twice) and Konqueror shows me "Canon PowerShot A75", Size: 0 B, File Type: Unknown, Permissions: drw-rw-rw- (looks bogus to me). I click on this entry. URL changes to "system:/media/camera/camera/camera" and Konqueror tells me:
"An error occurred while loading system:/media/camera/camera/camera:

Unknown error
Falsche Parameter"

Note that using the camera io slave works flawlessly.
Comment 1 Ingo Klöcker 2005-12-12 11:04:09 UTC
Sorry, I confused media and system io slave.
Comment 2 Ingo Klöcker 2005-12-12 11:06:59 UTC
fix summary. sorry, for the noise.
Comment 3 James Umbanhowar 2006-01-06 21:33:46 UTC
I get the same thing with a nikon coolpix 990 on a debian sid kde 3.5.0 box
Comment 4 lpetersen 2006-02-05 12:00:16 UTC
Still the same with KDE 3.5.1 (and a Canon Powershot G5 here).
system:/media/camera and media:/camera don't work, camera:/ does.
Comment 5 sunru 2006-03-14 06:15:05 UTC
this is for any camera detected through kamera and gphoto2
The camera is detected and an icon loads on desktop however the url is incorrect the provided link media:/camera is a dead link to the device.
It seems the correct url is camera:/ and it works fine.
Comment 6 sunru 2006-03-21 06:30:21 UTC
This NEW bug is over 3 months old.
Comment 7 Juha Tuomala 2006-06-18 14:57:15 UTC
Here:
  camera: Nikon Coolpix 990
  OS: FC5
  KDE: 3.5.2

system:/media/camera does not work. 
camera:/             does not work.
kamera program can see the device.
When I plug the camera into usb bus, KDE correctly opens dialog and asks what to do.
gphoto2 --auto-detect lists camera correctly.
gphoto2 --auto-detect -O downloads all images correctly.
Comment 8 Thomas Bettler 2006-08-22 15:28:52 UTC
Hmm. Same problem here with my Canon IXUS 40 and IXUS 55 in KDE 3.5.4.

media ioslave broken (see comment #1)

camera ioslave works somehow
Comment 9 Jens 2006-08-30 11:03:41 UTC
Perhaps related to this Ubuntu bug: https://launchpad.net/distros/ubuntu/+bug/48717 and KDE Bug 118168.
Comment 10 Thomas Bettler 2007-01-19 00:52:33 UTC
This bugs is not a bug itself, but seems a consequence of #125696 or the like.

The primary bug might be the broken camera:/ slave.
Comment 11 Kevin Ottens 2009-02-27 19:34:20 UTC
kio system is gone in the KDE4 serie.