Bug 118074 - KMail creates duplicate messages in Dovecot IMAP mail folders
Summary: KMail creates duplicate messages in Dovecot IMAP mail folders
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal with 282 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 129017 143518 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-10 17:11 UTC by sean.sweng
Modified: 2015-04-12 10:22 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sean.sweng 2005-12-10 17:11:41 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Ubuntu Packages

Leaving KMail open with interval checking turned on, I have found that it frequently creates many duplicate email on the Dovecot IMAP server.  I am running KDE 3.5 from kubuntu.

Sean
Comment 1 giaso 2005-12-12 10:33:42 UTC
Same thing happening here, last message in Inbox folder is duplicated every time I check new mail (both manual and auto) on IMAP sever. KDE 3.5, KMail 1.9.1 with packages from fedora4 and kde-redhat.org.
Comment 2 Carsten Burghardt 2005-12-13 17:05:20 UTC
What dovecot version is this?
Comment 3 sean.sweng 2005-12-14 01:15:20 UTC
I am using Dovecot 1.0Alpha5.  But I also saw the same problem in Dovecot 0.99.14.  I am running it on OpenBSD 3.7.

Sean
Comment 4 Martin Pärtel 2006-06-30 01:22:37 UTC
Same here with dovecot 1.0.beta5 and the latest KMail 1.9.1 from Debian unstable.

Only newly arrived messages seem to get duplicated. Messages that already exist when KMail starts are not duplicated.
Comment 5 marrs 2006-08-25 21:47:15 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 George Fazio 2006-10-31 05:13:26 UTC
I'm also seeing this in FreeBSD. KMail 1.9.4 was installed from FreeBSD ports. I'm using Dovecot IMAP. New messages to the inbox are duplicated, but new messages to other folders do not exhibit the issue.
Comment 7 S. Burmeister 2007-01-15 22:55:14 UTC
Duplicate of bug 95064?
Comment 8 George Fazio 2007-01-18 05:19:50 UTC
After turning off "Act on new/uread mail in this folder" in the Properties of 
the Inbox, I can confirm that this is still an issue. Please correct me if 
I've overlooked something, but it does not appear to be a duplicate.

On Mon January 15 2007 16:55, S.Burmeister wrote:
> ------- Additional Comments From sven.burmeister gmx net  2007-01-15 22:55
> ------- Duplicate of bug 95064?

Comment 9 ivan 2007-01-24 23:07:51 UTC
Hi,

i am victim to (kubuntu 6.10/ kde 3.5.5/ kmail 1.9.5).
For me it is surely related to spam-filters.

This might be same as Bug 128014 ?
Comment 10 Witold Krakowski 2007-01-27 01:04:24 UTC
I see the same bug using a POP3 account. KMail version 1.9.6 on Kde 3.5.5.
Comment 11 Thomas McGuire 2007-03-27 20:20:17 UTC
Does this still occur if you turn of filtering?
Comment 12 Thomas McGuire 2007-03-27 20:24:07 UTC
*** Bug 143518 has been marked as a duplicate of this bug. ***
Comment 13 Peter Parzer 2007-05-21 15:52:46 UTC
I see the same bug on Kubuntu 7.04 with IMAP from MS Exchange 2003.
Comment 14 Thomas McGuire 2007-06-25 13:29:12 UTC
*** Bug 129017 has been marked as a duplicate of this bug. ***
Comment 15 mi+kde 2007-12-15 18:45:56 UTC
Bug 153975 was deemed a duplicate of this bug.
Comment 16 Konstantin 2008-02-12 05:48:29 UTC
The same with KMail 1.9.7 (Debian testing, KDE 3.5.8)

-------------------
Received: from (192.168.57.58) by *************.com (192.168.56.247)
 with IMAP; Tue, 12 Feb 2008 00:45:00 +0600
Received: from (192.168.57.58) by *************.com (192.168.56.247)
 with IMAP; Tue, 12 Feb 2008 00:39:32 +0600
Received: from (192.168.57.58) by *************.com (192.168.56.247)
 with IMAP; Tue, 12 Feb 2008 00:33:59 +0600
Received: from (192.168.57.58) by *************.com (192.168.56.247)
 with IMAP; Tue, 12 Feb 2008 00:28:31 +0600
Received: from (192.168.57.58) by *************.com (192.168.56.247)
 with IMAP; Tue, 12 Feb 2008 00:23:04 +0600
-------------------
Comment 17 John Andersen 2008-08-11 21:53:45 UTC
Is it possible this is a duplicate of http://bugs.kde.org/show_bug.cgi?id=95064
bug 95064 which has been outstanding since 2004?

On that bug thread turning off all client side filters seems to make the problem go away.  
Comment 18 Sheldon Hearn 2008-12-22 17:03:34 UTC
Nope.

I don't use any client filters at all, and see this with KMail 1.9.9 on a Debian unstable (Sid) client and dovecot 1.0rc15 on a Debian stable (Etch) server.  Note that dovecot-imapd is fronted on my server with imapproxy 1.2.4.
Comment 19 Chris Stone 2009-05-06 18:19:24 UTC
I am seeing this as well after changing a couple of my servers over to Dovecot IMAP 1.2.rc3. Running Mandrive 2009.0, KDE 4.1.3.1, KMail 4.1.3.2. One account even loops through duplicating, deleting, and re-adding the messages.

Using no client filters or rules.
Comment 20 Stan 2010-05-12 04:06:22 UTC
Hi,

This has been happening to me for a while also. If I have
kmail open with 1 min. interval checking on 2 pc's I will starting
getting duplicate email.
I use:
Mandriva 2010.0 - with all latest updates.
Kde - Currently installed version: 4.4.0-2mdv2010.0
kmail - 1.13.0  for kde 4.4.00
courier-imap - 4.5.0
courier-base - 4.5.0

I am pretty sure it was happening in mandriva 2009 also.
Comment 21 Laurent Montel 2015-04-12 10:22:06 UTC
Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.