Bug 118069 - Pretends to let me delete covers from id3 tags or filesystem
Summary: Pretends to let me delete covers from id3 tags or filesystem
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 1.3.7
Platform: Slackware Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 134240 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-10 15:57 UTC by Sam
Modified: 2008-03-14 05:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam 2005-12-10 15:57:17 UTC
Version:           1.3.7 (using KDE KDE 3.5.0)
Installed from:    Slackware Packages
OS:                Linux

Everytime I try to unset an image, it tells me it has done so and nothing happens. The cover Art stays unless I replace it.
Comment 1 Seb Ruiz 2005-12-10 23:51:38 UTC
You either have cover art embedded in your id3 tag, or an image lying in the same folder as the audio file.

I'll rename the bug report because the action is misleading.
Comment 2 Sam 2005-12-12 01:51:05 UTC
There isnt a picture in the folder and shouldn't amarok be able to erase that part of the song's id3 tag?

btw, thanks for renaming my bug, It makes more sense the way it is now.
Comment 3 Seb Ruiz 2005-12-12 01:53:24 UTC
On Monday 12 December 2005 11:51, Sam wrote:
> and shouldn't amarok be able to erase that part of the song's id3 tag?


No, we can't alter id3 tags like that.  Markey's script will soon be able to 
remove them however.
Comment 4 Sam 2005-12-12 01:58:05 UTC
Oh, well I do look forward to that thank you. Some Things I really wish didn't have album art because it's not right and there isn't the right one. thank you.
Comment 5 Seb Ruiz 2005-12-12 02:01:15 UTC
I'm going to reopen the bug, because we still do pretend to let the user remove the artwork.
Comment 6 Alexandre Oliveira 2006-01-08 02:06:25 UTC
"No, we can't alter id3 tags like that."
Why not? If the user wants to delete/change the cover, we should remove it. Taglib does let us do that.
Comment 7 Seb Ruiz 2006-08-22 14:23:39 UTC
SVN commit 575884 by seb:

Delete artwork off the filesystem as well as the cache if it is requested
CCBBUG: 118069


 M  +15 -4     collectiondb.cpp
Comment 8 Alexandre Oliveira 2006-09-18 02:46:28 UTC
*** Bug 134240 has been marked as a duplicate of this bug. ***
Comment 9 Mark Kretschmann 2006-12-28 12:44:47 UTC
SVN commit 617196 by markey:

Don't physically delete custom cover images from the filesystem. Apparently users really don't like this, although it was originally meant as a feature.

BUG: 134043
CCBUG: 118069



 M  +1 -1      collectiondb.cpp  


--- trunk/extragear/multimedia/amarok/src/collectiondb.cpp #617195:617196
@@ -2295,7 +2295,7 @@
     QString hardImage = findDirectoryImage( artist, album );
     debug() << "hardImage: " << hardImage << endl;
 
-    if( !hardImage.isEmpty() && QFile::remove( hardImage ) )
+    if( !hardImage.isEmpty() )
     {
         int id = MountPointManager::instance()->getIdForUrl( hardImage );
         QString rpath = MountPointManager::instance()->getRelativePath( id, hardImage );
Comment 10 Dan Meltzer 2008-03-14 05:44:06 UTC
Looks like this should be closed.. Correct me If I'm wrong.