Bug 117785 - kmails stalls on "Retrieving Folder Contents" with IMAP folders
Summary: kmails stalls on "Retrieving Folder Contents" with IMAP folders
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: IMAP (show other bugs)
Version: 1.9
Platform: Gentoo Packages Linux
: NOR normal with 96 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 128702 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-06 12:39 UTC by JP Renaud
Modified: 2009-02-12 16:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenie of the problem (88.50 KB, image/png)
2005-12-06 12:41 UTC, JP Renaud
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JP Renaud 2005-12-06 12:39:57 UTC
Version:           1.9 (using KDE KDE 3.5.0)
Installed from:    Gentoo Packages
Compiler:          gcc version 3.4.3-20050110 (Gentoo Linux 3.4.3.20050110-r1, ssp-3.4.3.20050110-0, pie-8.7.7) 
OS:                Linux

Regularly, kmail stalls for ever when displaying the "Retrieving Folder Contents, Please Wait ..." message in the new blue colored display. It seems to fetch emails properly as they appears as new in the folder list (see screenie attached), I just can't see the message list. The only way to get out of this seems to be to play with the subscription options for one of the IMAP folder. I have no idea what does this and certainly cannot reproduce it reliably. It just happens regularly, maybe once a day.

I have tried quitting and reponening kmail, using it witin Kontacy or not and always get the same behaviour.

JP
Comment 1 JP Renaud 2005-12-06 12:41:02 UTC
Created attachment 13785 [details]
screenie of the problem
Comment 2 JP Renaud 2005-12-06 12:51:52 UTC
It's just happened again and using "File_>New->New Windows" got rid of the problem (only in the new window).

JP
Comment 3 kilian 2006-01-19 11:08:50 UTC
I confirm this behaviour in kmail 1.9, installed from Gentoo packages too.
Comment 4 JP Renaud 2006-01-19 11:59:30 UTC
I also noticed that the progress bar on the bottom right of the windows sometimes shows a negative number: "-1%".

Basically, for me this bug means I cannot use Kontact because there is no menu entry "New"->"Window" for the kmail component. So I end up using kmail on its own and once a day (more or less) have to open a new window and close the old one.
Comment 5 Felix Eckhofer 2006-01-29 14:30:01 UTC
I have the same problem and I can reproduce it like this:

*) Click on an IMAP folder with many messages in it (Spam-Folder!),
   wait until the "Retrieving Folder Contents"-screen shows up.
*) Click on another folder before the message list is shown.

==> The message list is gone. The only way to resolve it (for me) is to quit Kontact completely and restart it.

PLEASE make this "Retrieving Folder Contents"-thing optional. It is not really useful and even if it works - it is still annoying.
Comment 6 Felix Eckhofer 2006-02-01 14:14:14 UTC
See bug #116773 for a quick workaround.
Comment 7 JP Renaud 2006-02-24 13:29:17 UTC
I have tried the above workaround and it sort of work *BUT* if for some reason, more than 10s are used (or whatever was set FolderLoadingTimeout to in kmailrc), the message list is still lost.

So IMHO, it is only a temporary fix. 
Comment 8 Christiaan Hees 2006-05-15 21:25:02 UTC
I am having the same problem.

To reproduce:
Have 2 imap accounts setup.
Click on the inbox of the first and it will give you a blue screen with: "Retrieving Folder Contents Please wait . . ."
Click on the inbox of the second imap account and you will get the same.
Click on the first inbox right after it has loaded and before the second one is loaded.
It will now always display the blue screen for both even though they are both completely loaded.

I'm not completely sure if this is the exact way to reproduce it but I've had it a couple of times already and it's always been something like this.

Workaround:
Clicking on Local Folders (which displays the blue Welcome to KMail message and then back on one of the mailboxes will fix it.

Note, I never saw it with previous versions so I think the bug came in with the KDE 3.5 release.
Comment 9 Chris 2006-06-20 22:15:24 UTC
I have exactly the same behaviour in kmail 1.9.1 like comment #8.
Comment 10 Frederic Vanneste 2006-06-21 08:43:07 UTC
Same here (kde 3.5.3), this is a nasty bug.
For the moment I'm using thunderbird, had some really annoying imap experiences with the latest releases of kmail... Hope this all reverts back to the way kmail  worked in the pre-3.5 days.
Comment 11 Jaakko Holster 2006-10-31 09:27:49 UTC
Confirm this bug. Has been around for 2-3 years, as far as I remember. The bug usually happens when you switch quickly between IMAP folders (or accounts) and/or there's (maybe) some lag on server. I've two IMAP accounts, and I face this bug daily.

Could not the folder contents be cached, thus making the "Retrieve folder contents" message unnecessary?
Comment 12 Andreas Scherf 2006-12-02 23:13:20 UTC
*** Bug 128702 has been marked as a duplicate of this bug. ***
Comment 13 Marius 2007-03-01 09:59:59 UTC
I have the same problem only i have just one imap account, still it often hangs on "Retrieving Folder Contents", it seems to happen more often if i suspend my computer....

This is only one of two imap problems i have in kmail ( http://bugs.kde.org/show_bug.cgi?id=136070 )
Comment 14 Stephan Kulow 2007-03-20 21:22:52 UTC
SVN commit 644741 by coolo:

this checks looks nonsense as the ptr is regenerated on
every folder select
BUG: 117785


 M  +1 -1      kmmainwidget.cpp  


--- branches/KDE/3.5/kdepim/kmail/kmmainwidget.cpp #644740:644741
@@ -1904,7 +1904,7 @@
   bool newFolder = ( mFolder != aFolder );
   bool isNewImapFolder = aFolder && aFolder->folderType() == KMFolderTypeImap && newFolder;
   if( !mFolder
-      || ( !isNewImapFolder && mShowBusySplashTimer && !mShowBusySplashTimer->isActive() )
+      || ( !isNewImapFolder && mShowBusySplashTimer )
       || ( newFolder && mShowingOfflineScreen && !( isNewImapFolder && kmkernel->isOffline() ) ) ) {
     if ( mMsgView ) {
       mMsgView->enableMsgDisplay();
Comment 15 Peter Lewis 2009-02-12 16:27:17 UTC
Hmmm... I'm still getting this on 4.2.

Particularly, if the network goes down while KMail is in online mode, then I have to restart KMail in order to get it to display the folder which it had loaded when the network went down. Otherwise I just get the loading page.

Thanks.
Comment 16 Peter Lewis 2009-02-12 16:29:16 UTC
Actually, I'm guessing that what I'm describing is the same as bug #77862.