Bug 115401 - Cannot add contact category under certain circumstances
Summary: Cannot add contact category under certain circumstances
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kab3
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Tobias Koenig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-30 23:02 UTC by min
Modified: 2009-08-05 16:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch to fix (492 bytes, patch)
2006-09-21 18:27 UTC, Philip Rodrigues
Details

Note You need to log in before you can comment on or make changes to this bug.
Description min 2005-10-30 23:02:21 UTC
Version:            (using KDE KDE 3.4.92)
Installed from:    Unlisted Binary Package
OS:                Linux

How to reproduce:

- open the edit categories dialog from KAddressbook's New Contact dialog

- press the Add button

- write something in the text input on the bottom of the dialog

Expected result:

- a new category shoul be created

Actual result:

- the topmost category (which is selected by default) gets modified

The dialog works correctly if one first selects another category from the listview.
Comment 1 Philip Rodrigues 2006-09-21 18:27:45 UTC
Created attachment 17864 [details]
Patch to fix

Patch to fix (apply in libkdepim).

Make sure the current item from the category list is put in the edit box at
startup. This is needed because the Add action checks that the edit box != ""
before doing anything.

On a wider note, I found it a little tricky to work out how to use this dialog.
Are there plans to change the way it functions? If not, would it be worthwhile
to ask the usability folks?
Comment 2 Tobias Koenig 2006-10-04 14:34:23 UTC
SVN commit 592324 by tokoe:

Applyed patch for bug #115401, written by Philip Rodrigues <phil@kde.org>

BUGS:115401


 M  +1 -0      categoryeditdialog.cpp  


--- branches/KDE/3.5/kdepim/libkdepim/categoryeditdialog.cpp #592323:592324
@@ -76,6 +76,7 @@
   }
   mWidget->mButtonRemove->setEnabled( categoriesExist );
   mWidget->mCategories->setSelected( mWidget->mCategories->firstChild(), true );
+  mWidget->mEdit->setText( mWidget->mCategories->currentItem()->text( 0 ) );
 }
 
 void CategoryEditDialog::slotTextChanged(const QString &text)
Comment 3 Tobias Koenig 2009-08-05 16:27:49 UTC
The development of the old KAddressBook will be discontinued for KDE 4.4.
Since the new application has the same name, but a completly new code base we close all bug reports against the old version and ask the submitters to resend there reports against the new product.