Bug 115261 - Implement a "Dictionary" drop-down list in the composer, like KMail
Summary: Implement a "Dictionary" drop-down list in the composer, like KMail
Status: RESOLVED WORKSFORME
Alias: None
Product: knode
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist with 24 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 115609 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-10-28 15:31 UTC by Tristan Miller
Modified: 2014-06-10 20:57 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The backtrace from the crash (7.77 KB, text/plain)
2005-11-19 15:34 UTC, greatbunzinni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2005-10-28 15:31:37 UTC
Version:            (using KDE KDE 3.4.3)
Installed from:    SuSE RPMs

Bug 75937 causes the application to crash when the user tries to select a new spelling dictionary through the "Configure KNode..." or "Spelling" dialog.  Furthermore, having to invoke a new dialog window is a lot of work to change dictionaries, especially when one writes news articles in various different languages every day.

To fix this, please include a "Dictionary" drop-down list in the article composer so that the user can switch languages for a particular article on the fly.  KMail recently implemented this feature and it works great.
Comment 1 Volker Krause 2005-11-03 14:22:47 UTC
*** Bug 115609 has been marked as a duplicate of this bug. ***
Comment 2 greatbunzinni 2005-11-19 15:32:00 UTC
I also have this problem (knode crashes, taking kontact with him) and I find Tristan's suggestion to be excellent. 
Comment 3 greatbunzinni 2005-11-19 15:34:11 UTC
Created attachment 13557 [details]
The backtrace from the crash

This is the backtrace from the crash that was caused by the switching of the
spellchecker's dictionary.
Comment 4 Thiago Macieira 2005-11-19 18:09:34 UTC
Pasting the backtrace:

no debugging symbols found)
[KCrash handler]
#4  0xb6dc997a in QGVector::size () from /usr/lib/libqt-mt.so.3
#5  0xb6dc99e9 in QPtrVector<QConnectionList>::size ()
   from /usr/lib/libqt-mt.so.3
#6  0xb6dc9a37 in QSignalVec::at () from /usr/lib/libqt-mt.so.3
#7  0xb6dc8ded in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#8  0xb7131ec4 in QComboBox::activated () from /usr/lib/libqt-mt.so.3
#9  0xb6e6c274 in QComboBox::internalActivate () from /usr/lib/libqt-mt.so.3
#10 0xb7132065 in QComboBox::qt_invoke () from /usr/lib/libqt-mt.so.3
#11 0xb6dc8929 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb6dc9238 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb713bb38 in QListBox::selected () from /usr/lib/libqt-mt.so.3
#14 0xb6eb2ec6 in QListBox::mouseDoubleClickEvent ()
   from /usr/lib/libqt-mt.so.3
#15 0xb6e03395 in QWidget::event () from /usr/lib/libqt-mt.so.3
#16 0xb6d5ff80 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#17 0xb6d60500 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#18 0xb73e3e37 in KApplication::notify () from /usr/lib/libkdecore.so.4
#19 0xb6cf0db7 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#20 0xb6e6cd59 in QComboBox::eventFilter () from /usr/lib/libqt-mt.so.3
#21 0xb6dc5a72 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#22 0xb6dc5af0 in QObject::event () from /usr/lib/libqt-mt.so.3
#23 0xb6e03268 in QWidget::event () from /usr/lib/libqt-mt.so.3
#24 0xb6d5ff80 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#25 0xb6d60500 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#26 0xb73e3e37 in KApplication::notify () from /usr/lib/libkdecore.so.4
#27 0xb6cf0e25 in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#28 0xb6cebf62 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#29 0xb6cea66f in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#30 0xb6d03fff in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#31 0xb6d77cfb in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#32 0xb6d77c1e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#33 0xb6d5ec13 in QApplication::exec () from /usr/lib/libqt-mt.so.3
Comment 5 Jim Scadden 2014-05-11 15:31:16 UTC
This can probably be closed since bug 75937 was closed some time ago and knode provides a drop-down list of languages in the spelling dailog now
Comment 6 Christoph Feck 2014-06-10 20:57:56 UTC
Okey, let's close it.