Bug 114002 - can't change number's position
Summary: can't change number's position
Status: RESOLVED FIXED
Alias: None
Product: kruler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Mathias Soeken
URL:
Keywords:
: 155024 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-10-07 07:09 UTC by Mathieu Jobin
Modified: 2009-01-09 19:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Jobin 2005-10-07 07:09:31 UTC
Version:           3.4.91 (using KDE 3.4.91 (beta1, >= 20050910), Gentoo)
Compiler:          gcc version 3.3.6 (Gentoo 3.3.6, ssp-3.3.6-1.0, pie-8.7.8)
OS:                Linux (i686) release 2.6.12-gentoo-r6

It's cool we can change the orientation (N,E,S,W) but I wish I could change where the 0 (zero) is situated. like left or right, above or bottom... or I'd say even middle. if we could move the zero as we wish, so we can get a ruler like .....

-3 -2 -1  0  1  2  3

you know ...

thanks, great utility

very usefull
Comment 1 Mathias Soeken 2008-12-16 11:58:31 UTC
*** Bug 155024 has been marked as a duplicate of this bug. ***
Comment 2 Mathias Soeken 2009-01-09 19:48:54 UTC
SVN commit 908462 by msoeken:

Now it is possible to change the origin of the scale.
 * You can set it to the center of the ruler
 * You can move it via the mouse wheel
 * You can specify an exact value via a input dialog

BUGS: 114002


 M  +92 -98    klineal.cpp  
 M  +4 -0      klineal.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=908462