Bug 113749 - Vertical scrollbar when showing journals
Summary: Vertical scrollbar when showing journals
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-03 00:58 UTC by Niels
Modified: 2007-01-17 18:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Niels 2005-10-03 00:58:03 UTC
Version:           1.2 (using KDE KDE 3.4.90)
Installed from:    Gentoo Packages

When showing more than a handful of journal entries, the window isn't big enough. A srollbar should appear so that all entries can be seen.
Comment 1 Thiago Macieira 2005-10-03 01:09:18 UTC
In the summary view?
Comment 2 Niels 2005-10-03 04:17:24 UTC
I suppose... It's hard to tell which frame is called what.

In Journal mode, when I select a day in the calendar, the rightmost frame will show the journal entries for that day. This is where the scrollbar is needed. 

It's possible to select more than one day, in which case all those entries are shown. The frame is sure to overflow.

(another thing: when are the journal entries saved? I just had a crash and lost several. I'll open another report if this is a real bug.)
Comment 3 Thiago Macieira 2005-10-03 04:55:28 UTC
Then it's not the Summary view.
Comment 4 Jerry Amundson 2005-12-28 22:57:31 UTC
Same issue on Fedora Core 4, KDE 3.5 - very annoying.
Comment 5 Jerry Amundson 2005-12-28 23:04:56 UTC
Note, though, Kontact shows Journal entries in the List view of Calendar, if you happen to use Kontact...
Comment 6 Elias Probst 2006-06-26 11:23:27 UTC
This problem is still there on 3.5.3 ;-(
Comment 7 min 2006-08-20 08:04:37 UTC
I just had to delete a couple of journal entries because of this issue, in order to recover a more important one :-/

Please make the journal view scrollable.
Comment 8 Jean-Philippe Monteiro 2006-10-03 04:36:13 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 Reinhold Kainhofer 2006-11-02 19:35:48 UTC
Reassigning all KOrganizer bug reports and wishes to the newly created 
korganizer-devel mailing list.
Comment 10 Lubos Lunak 2007-01-17 18:57:56 UTC
SVN commit 624681 by lunakl:

Finish what r307993 was trying to do - when there are too many
entries in the journal, make a scrollbar appear.
BUG: 113749



 M  +2 -2      kojournalview.cpp  


--- branches/KDE/3.5/kdepim/korganizer/kojournalview.cpp #624680:624681
@@ -49,11 +49,11 @@
   QVBoxLayout*topLayout = new QVBoxLayout( this );
   topLayout->setAutoAdd(true);
   mSV = new QScrollView( this, "JournalScrollView" );
-  topLayout = new QVBoxLayout( mSV->viewport() );
-  topLayout->setAutoAdd(true);
   mVBox = new QVBox( mSV->viewport() );
   mSV->setVScrollBarMode( QScrollView::Auto );
   mSV->setHScrollBarMode( QScrollView::AlwaysOff );
+  mSV->setResizePolicy( QScrollView::AutoOneFit );
+  mSV->addChild( mVBox );
 //  mVBox->setSpacing( 10 );
 }