Bug 113398 - cannot remove "KOrganizer reminder" from system tray
Summary: cannot remove "KOrganizer reminder" from system tray
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 30 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 102120 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-09-27 01:06 UTC by Oliver Grimm
Modified: 2008-10-12 15:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Grimm 2005-09-27 01:06:12 UTC
Version:           1.1.1 (using KDE KDE 3.4.1)
Installed from:    Debian testing/unstable Packages
OS:                Linux

To reproduce do

- start Kontact
- quit Kontact
- Kontact has added an icon "KOrganizer reminder" to the tray
- right click this tray icon
- uncheck "run reminder on KDE startup"
- right click the tray icon again
- select "exit"
- exit & restart KDE
- the KOrganizer reminder icon reappears, though it's supposed to be removed

But I "accidently" found a way to remove it:

- right click the "Kontact reminder" tray icon
- uncheck "run reminder on KDE startup"
- do NOT quit the reminder
- exit & restart KDE
- the icon IS removed
Comment 1 Mathy Vanvoorden 2006-01-02 10:40:58 UTC
I can confirm this. The reminder daemon doesn't start when it is still running when you close KDE but it does when you close it on beforehand. This is very annoying since I don't want it always running (my .ics-file is on a remote server which I can't always reach). On a (maybe) related note: I have sessions completely disabled.
Comment 2 Raphael 2006-02-11 12:40:38 UTC
Hello,

the bug is still present in the kde3.5.1 ubuntu packages, but the "solution" outlined above did work for me too - thank you :-)
I hope this gets fixed soon anyways, b/c it makes me feel like kde is ignoring my choice and rather doing what is belives is best. While I know that's not the reason behind, it is still annoying... (just a very personal statement).
regards,
raph
Comment 3 Reinhold Kainhofer 2006-11-02 19:30:48 UTC
Reassigning all KOrganizer bug reports and wishes to the newly created 
korganizer-devel mailing list.
Comment 4 José Salavert Torres 2007-01-17 02:40:01 UTC
still happening in kde 3.5.5
Comment 5 Nick 2007-02-02 18:27:58 UTC
Bug is still here for me too in Kubuntu Edgy. Here's a quick and dirty solution:

sudo mv /usr/bin/korgac /usr/bin/korgac.bak

This just renames the executable of the system tray icon so that it doesn't run. Note that this makes the system tray icon unavailable for everyone.

Here's hoping this bug gets fixed soon.

- Vuen
Comment 6 Allen Winter 2008-04-02 18:01:10 UTC
SVN commit 792937 by winterz:

New option: if [General]->ShowReminderDaemon is false,
then do not show the korgac icon in the systray.

I will add this setting to the KOrganizer configuration dialog.
Note however that the daemon still runs whenever KOrganizer is started.

BUGS: 113398


 M  +10 -4     koalarmclient.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=792937
Comment 7 FiNeX 2008-09-29 01:17:29 UTC
*** Bug 102120 has been marked as a duplicate of this bug. ***
Comment 8 Dmitry 2008-10-11 20:13:40 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 Allen Winter 2008-10-12 15:14:21 UTC
This has been fixed since KDE 4.1.

Go into the General settings page, under the System Tray tab.
You can remove the reminder daemon from the systray in there.